Das Archiv des Excel-Forums

Zufallszahlen

Bild

Betrifft: Zufallszahlen
von: Ulf

Geschrieben am: 06.10.2003 13:39:53

Hallo Excel Friends
wie kriege Ich es hin das In einer Tabelle in einem bestimmten Bereich Zufallszahlen eingetragen werden die als Summe 11 ergibt und deren Wert in einer Zelle nicht 4 überschreitet.

BSP
https://www.herber.de/bbs/user/1299.xls




danke für eure Hilfe
Ulf
Bild


Betrifft: AW: Zufallszahlen
von: Holger Levetzow
Geschrieben am: 06.10.2003 14:57:19

gibt es irgendein System (wieviel Zahlen, auf Dezimalzahlen, wieviel Kommastellen, ...)
Holger


Bild


Betrifft: AW: Zufallszahlen
von: Ulf
Geschrieben am: 06.10.2003 15:03:26

Hi Holger,

es können Dezimalzahlen und Ganze 70/30 gemischt werden. Die Dezimalzahlen müssten in 0,5 Schritten laufen.

mfg
Ulf


Bild


Betrifft: AW: Zufallszahlen
von: Beni
Geschrieben am: 06.10.2003 15:11:59

Hallo Ulf,
dieses Makro ist zu deinem Beispiel.
Gruss Beni


Sub Zufall()
'06.10.03 von Bernhard Mächler
[B5:Q28] = ""
For z = 2 To 17
For i = 5 To 28
C = Int((5 * Rnd) + 0)
If (Cells(29, z) + C) <= 11 Then Cells(i, z) = C
If Cells(i, z) = 0 Then Cells(i, z) = ""
Next i
Next z
End Sub



Bild


Betrifft: AW: Zufallszahlen
von: Ulf
Geschrieben am: 06.10.2003 15:24:25

Hi Beni,
funktioniert schon ganz gut. Geht es auch das die Sub 0,5 Zahlen einbaut und es werden hauptsächlich die Zahlen in den oberen Bereich geschrieben. Hat das was damit zu tun das links am Anfang was stehen muss.

danke schon mal für deine Hilfe.

Ulf


Bild


Betrifft: ohne VBA:
von: Günther Oppold
Geschrieben am: 06.10.2003 15:45:57

Hi Ulf

in H5: =OBERGRENZE(ZUFALLSZAHL()*4;0,5)
in H6: =WENN(ANZAHL2(A6:A$28)=1;11-SUMME(H$5:H5);WENN(ANZAHL2(A6:A$28)*0,5>=11-SUMME(H$5:H5);0,5;WENN((11-SUMME(H$5:H5)-(ANZAHL2(A6:A$28)*0,5))>=4;OBERGRENZE(ZUFALLSZAHL()*4;0,5);OBERGRENZE(ZUFALLSZAHL()*(11-SUMME(H$5:H5)-(ANZAHL2(A6:A$28)*0,5));0,5))))

die Formel nach unten ziehen

bei über 90 % kommt es richtig, bei unter 10% hat die letzte Zelle einen Wert >4,00 :-(


Günther


Bild


Betrifft: AW: Zufallszahlen
von: Ulf
Geschrieben am: 06.10.2003 15:53:40

An Günther,

danke dir auch funktioniert Klasse allerdings muss an solange hin und herziehen bis Ich auf Summe Stunden = 11 komme.

Danke für deinen Lösungsansatz.

Ulf


Bild


Betrifft: AW: Zufallszahlen
von: Beni
Geschrieben am: 06.10.2003 16:40:32

Hallo Ulf,
das sollte funktionieren.
Gruss Beni


Sub Zufall()
'06.10.03 von Bernhard Mächler
[B5:Q28] = ""
For z = 2 To 17
For i = 5 To 60
C = Int((9 * Rnd) + 0) / 2
1:
p = Int((24 * Rnd) + 5)
If Cells(p, z) <> "" Then GoTo 1
If (Cells(29, z) + C) <= 11 Then Cells(p, z) = C
If Cells(p, z) = 0 Then Cells(p, z) = ""
Next i
Next z
End Sub



Bild


Betrifft: AW: Beni
von: Ulf
Geschrieben am: 07.10.2003 08:41:05

Tausend Dank Beni funzt hervorragend!:):)

Ulf


 Bild

Excel-Beispiele zum Thema " Zufallszahlen"

Zufallszahlen generieren, die sich nicht wiederholen download Gleiche Zufallszahlen zählen und in Diagramm anzeigen download
Zufallszahlen bis zum 4-fachen Wert generieren download