Zählenwenn !

Bild

Betrifft: Zählenwenn !
von: Noessi
Geschrieben am: 14.10.2003 14:20:25

Hallo, habe folgendes Problem:

in der Spalte X7:X335 stehen Durchschnittspreise, wobei einige Felder entweder leer sind oder ein 0 aufweisen. Ich möchte jetzt die Anzahl der Felder zählen, die einen Wert aufweisen, der kleiner als ein vorgegebenr Wert (hier: X3) sind.
Mit meiner bisherigen Formel kann ich allerdings nicht die 0 ausschliessen.

=ZÄHLENWENN(X7:X335;"<"& WERT(X3))

Danke

Bild


Betrifft: AW: Zählenwenn !
von: Harald Kapp
Geschrieben am: 14.10.2003 14:31:00

Hallo Noessi,
probier mal:

=ZÄHLENWENN(X7:X335;"<"& WERT(X3))-ZÄHLENWENN(X7:X335;"=0")

Erst alle
Gruß Harald


Bild


Betrifft: AW: Zählenwenn !
von: Noessi
Geschrieben am: 14.10.2003 14:34:27

Super Harald,

funktioniert bestens !

Danke, hats mir noch viel grübeln erspart !!


Bild


Betrifft: sorry hatte nicht aktualisiert__ot
von: chris
Geschrieben am: 14.10.2003 14:50:22




Bild


Betrifft: AW: Zählenwenn !
von: chris
Geschrieben am: 14.10.2003 14:48:50

=ZÄHLENWENN(X7:X335;"<"& WERT(X3))-ZÄHLENWENN(X7:X335;0)

Gruß
Christian


Bild


Betrifft: Kürzer
von: M@x
Geschrieben am: 14.10.2003 15:46:52

Hi
=SUMMENPRODUKT((A1:A30>0)*1)
oder als Array
{=SUMME((A1:A30>0)*1)}
{}geschwungene Klammer nicht eingeben, sondern Formel mit Strg+Shift+Return abschließen

Gruss

M@x


Bild


Betrifft: die formel stammte uebrigens von Chris.
von: th.heinrich
Geschrieben am: 14.10.2003 17:34:08

https://www.herber.de/forum/archiv/320to324/t323191.htm


 Bild

Beiträge aus den Excel-Beispielen zum Thema " aus einem Feld Vorname+Name zwei Felder"