Tag- Wochenzuordnung

Bild

Betrifft: Tag- Wochenzuordnung
von: Rene
Geschrieben am: 26.11.2003 13:50:33

Hallo zusammen,

wie kann ich eine Tages- und Wochenzuordnung machen, dass in der ersten Spalte die Tage Montag bis Sonntag und in der zweiten Spalte die Wochen stehen und das fortlaufen durch eine Leerzeile pro Woche getrennt.

Vielen Dank im voraus

René

Bild


Betrifft: AW: Tag- Wochenzuordnung
von: oos
Geschrieben am: 26.11.2003 15:14:19

Hallo René,

nachfolgend ein Vorschlag - beachte, dass in Spalte A in den ersten drei Zellen unterschiedliche Formeln stehen - ab Zeile 3 kannst du sie kopieren. Nach dem Monatswechsel erfolgt wie gewünscht eine Leerzelle. Es wurde in alle Zellen ein Datumswert (1.1.03) eingegeben und anschließend die Zelle mit(ttt) formatiert (Format - Zellen - Benutzerdefiniert). Die Formel in Spalte B berücksichtigt die Kalenderwoche nach DIN, du weißt vielleicht, dass die Excel-Funktion 'Kalenderwoche' nach amerikanischem Standard rechnet.
In Spalte C ist eine Zelle in die du unterschiedliche Jahreszahlen eingeben kannst.
Hoffe es hilft dir weiter ;-)

G.a.BY
Niko
 
 ABCD
1Donnerstag1 2004
2Freitag1  
3Samstag1  
4Sonntag1  
5Montag2  
Formeln der Tabelle
A1 : =DATUM(D1;1;1)
B1 : =KÜRZEN((A1-WOCHENTAG(A1;2)-DATUM(JAHR(A1+4-WOCHENTAG(A1;2));1;-10))/7)
A2 : =WENN(A1="";""+1;WENN(MONAT(A1)<>MONAT(A1+1);"";A1+1))
B2 : =KÜRZEN((A2-WOCHENTAG(A2;2)-DATUM(JAHR(A2+4-WOCHENTAG(A2;2));1;-10))/7)
A3 : =WENN(A2="";A1+1;WENN(MONAT(A2)<>MONAT(A2+1);"";A2+1))
B3 : =KÜRZEN((A3-WOCHENTAG(A3;2)-DATUM(JAHR(A3+4-WOCHENTAG(A3;2));1;-10))/7)
A4 : =WENN(A3="";A2+1;WENN(MONAT(A3)<>MONAT(A3+1);"";A3+1))
B4 : =KÜRZEN((A4-WOCHENTAG(A4;2)-DATUM(JAHR(A4+4-WOCHENTAG(A4;2));1;-10))/7)
A5 : =WENN(A4="";A3+1;WENN(MONAT(A4)<>MONAT(A4+1);"";A4+1))
B5 : =KÜRZEN((A5-WOCHENTAG(A5;2)-DATUM(JAHR(A5+4-WOCHENTAG(A5;2));1;-10))/7)
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Bild


Betrifft: AW: Tag- Wochenzuordnung
von: Rene
Geschrieben am: 26.11.2003 15:42:15

Hallo Niko,

vielen Dank, es hilft mir weiter :-)

René


Bild

Beiträge aus den Excel-Beispielen zum Thema " Symbolleiste läßt sicht nich einstellen !"