SummeWenn

Bild

Betrifft: SummeWenn
von: Simone
Geschrieben am: 28.11.2003 11:12:25

Hallo,

ich habe zwei Spalten. In Spalte A stehen die Bezeichnungen, in Spalte B die Werte. Nun möchte ich Werte aus Spalte B mit bestimmten Bezeichnungen (Spalte A) addieren. Ich habe das Problem erstmal mit der SummeWenn-Formel gelöst. Da ich aber bis zu 10 und mehr unterschiedliche Bezeichnungen addieren möchte, muß ich die SummeWenn-Formel mindestens 10x hintereinander schreiben. Habt ihr eine Idee wie man das vereinfachen kann?

Danke&Gruß
Simone

Bild


Betrifft: AW: SummeWenn
von: Andre
Geschrieben am: 28.11.2003 11:16:44

Hi Simone,

wie soll das jetzt genau aussehen? Schreibst du in eine Zelle das Kriterium und willst dann die Summe der einzelnen Positionen aus Spalte B wissen? Kann mir noch nicht genau vorstellen, wo das Problem liegen soll.

Gruß Andre


Bild


Betrifft: AW: SummeWenn
von: Simone
Geschrieben am: 28.11.2003 11:58:40

Hallo Andre,

genauso mein ich es
SpalteA / SpalteB
a / 1
b / 2
c / 10
d / 5
ich will nun die Werte von a und c die in Splate B stehen addieren (a+c=11). Das allerdings in größerem Umfang ......

Simone


Bild


Betrifft: SummeWenn für viele Bezeichnungen
von: WF
Geschrieben am: 28.11.2003 11:25:13

Hi Simone,

=SUMMENPRODUKT((B1:B100={"a"."b"."c"."d"})*A1:A100)

{"a"."b"."c"."d"} usw. sind die Bezeichnungen.
Die geschweiften Klammern eingeben mit AltGr7 und AltGr0

trapp, trapp, trapp, trapp, trapp, brrrrr
WF

http://www.excelformeln.de/
die ultimative Formelseite


Bild


Betrifft: AW: SummeWenn für viele Bezeichnungen
von: Simone
Geschrieben am: 28.11.2003 12:02:11

Hi WF,

funktioniert nicht ... kommt eine Fehlermeldung (#Value), oder ich bin zu d....


Bild


Betrifft: AW: SummeWenn für viele Bezeichnungen
von: Boris
Geschrieben am: 28.11.2003 12:14:20

Hi Simone,

ich denke einfach nur, dass du die Spalten vertauschen musst
=SUMMENPRODUKT((A1:A100={"a"."b"."c"."d"})*B1:B100)

oder aber in deinen Spalten kommt der Fehlerwert #WERT! vor.

Es geht im übrigen auch mit SUMMEWENN:

=SUMME(SUMMEWENN(A:A;{"a"."b"."c"."d"};B:B))

Grüße Boris


Bild


Betrifft: AW: SummeWenn für viele Bezeichnungen
von: Simone
Geschrieben am: 28.11.2003 12:52:55

Supi, danke!

mit der SummeWenn funktioniert es, allerdings mit ";" statt "." .

Gruß
Simone


Bild


Betrifft: Dann hast du aber kein deutsches Excel...
von: Boris
Geschrieben am: 28.11.2003 13:32:58

Hi Simone,

...denn da ist es völlig wurscht ob Semikolon oder Punkt.

Grüße Boris


Bild

Beiträge aus den Excel-Beispielen zum Thema " SummeWenn "