Microsoft Excel

Herbers Excel/VBA-Archiv

Bezüge gehen verloren

Betrifft: Bezüge gehen verloren von: trebor-robert
Geschrieben am: 11.08.2004 15:49:16

Hallo zusammen,

bei nachfolgender Formel:

=SVERWEIS(A689;'C:\Sitzmöbel\[Preisliste 2004-02-02 Office
(Master).xls]OFFICE CHAIRS'!$BW$7:$CL$656;3;FALSCH)

war in der Formel vorher der Pfad "H:\...." angegeben.
Habe am Wochenende die Datei, in der diese Formel steht mit
nach Hause genommen und dafür auf dem Desktop gespeichert. Deswegen jetzt Sverweis auf Pfad "C:\...."

Dabei muss Excel mir überall die Pfadangaben von H nach C
gesetzt haben. Wie kann ich das wieder rückgängig machen
bzw. korrigieren, damit er die Werte aus der Quelldatei
aktualisiert, jetzt gehen nämlich keine Aktualisierungen.

Sind ungefähr 1000 Zeilen mit je 20 Spalten, d. h.
manuelle Korrektur wäre nicht möglich, da nicht alle
Zeilen auf den gleichen Quellbereich verweisen.

Hoffe es gibt dafür eine Lösung und zweite Frage. Wie kann
ich das in Zukunft unterbinden?

danke
trebor-robert

  


Betrifft: AW: Bezüge gehen verloren von: LotharP
Geschrieben am: 11.08.2004 16:01:07

Hallo Robert,

Versuch mal unter bearbeiten, Verknüpfungen die Verknüpfung auf die alte Datei zu wechseln.
Andernfalls mußt du durch bearbeiten ersetzen den aktuellen Pfad eingeben und durch den richtigen Pfad ersetzen lassen.

Hoffe du kommst so klar?!

Deine zweite Frage ist durch die Antwort mit den Verknüpfungen geklärt.
Hier kannst du Verknüpfungen verwalten. Es ist allerdings so, daß Excel die Verknüpfungen immer "mitnimmt".
Speicherst du die Datei irgendwo zwischen, dann bezieht sich die Verknüpfung auch auf diesen Ort.

Gruß

Lothar


  


Betrifft: AW: Bezüge gehen verloren von: trebor-robert
Geschrieben am: 11.08.2004 16:20:41

Hallo Lothar,

danke für die Hilfe. Ich hatte neulich schon mal versucht Zeichenketten zu verändern durch diesen Befehl und war nicht auf die Idee gekommen, daß es hier funktionieren könnte. Danke.

Dennoch die Frage: Warum funktioniert das nicht wenn ich z. B. bei vielen Formeln einfach den Spaltenbuchstaben verändern will. Es ist sichergestellt das in der Spalte der zu ersetztende Buchstabe im Wert nicht vorkommt, da eine Zahl. Komisch, daß es dort dann nicht funktioniert hat.

robert


  


Betrifft: AW: Bezüge gehen verloren von: lotharp
Geschrieben am: 11.08.2004 17:09:15

High Robert,

das funktioniert eigentlich immer!
Ich bin aber dabei auch schonmal auf die Nase gefallen weil der Spaltenbezeichner auch im Funktionsnamen auftauchte. Kann sowas vieleicht sein?

Aber hauptsache du bist weitergekommen!

Danke für die Rückmeldung!


Gruß

Lothar


 

Beiträge aus den Excel-Beispielen zum Thema "Bezüge gehen verloren"