Microsoft Excel

Herbers Excel/VBA-Archiv

Makrostart durch Formel

Betrifft: Makrostart durch Formel von: Helga
Geschrieben am: 11.08.2004 17:32:03

Hallo Experten, ist es möglich duch Ausführung einer Formel ein Makro zu
starten ?
Zum Bsp. Wenn A2 = 1 dann Makro1 oder so Wenn A2 = 2 dann Makro2

oder geht es nur per VBA?

Gruss Helga

  


Betrifft: AW: Makrostart durch Formel von: Nepumuk
Geschrieben am: 11.08.2004 17:45:10

Hallo Helga,
die Formel lautet so: =WENN(A2=1;funktion1();WENN(A2=2;funktion2();""))
Du kannst aber nur Funktionen und keine Sub's aufrufen und auch bei den Funktionen gibt es Einschränkungen.
Gruß
Nepumuk


  


Betrifft: AW: Makrostart durch Formel von: Helga
Geschrieben am: 11.08.2004 17:52:46

Hallo Nepumuk,danke Dir für deine Mühe.Wie würde den der Vba Code lauten zu den gleichen Bedingungen wenn ich Sub aufrufen möchte?

Habe mir schon alle Makros aufgezeichnet.

Gruss Helga


  


Betrifft: AW: Makrostart durch Formel von: Nepumuk
Geschrieben am: 11.08.2004 18:03:13

Hallo Helga,

Wie würde den der Vba Code lauten zu den gleichen Bedingungen wenn ich Sub aufrufen möchte?

Den Satz verstehe ich nicht. Kannst du mir den mal wie einem fünfjährigen erklären?

Gruß
Nepumuk


  


Betrifft: AW: Makrostart durch Formel von: Helga
Geschrieben am: 11.08.2004 18:14:29

Hi Nepumuk, habe mir die Makro's aufgezeichnet es sind 12 Stück.

Wenn es mit der Formel nich möglich ist Sub's zu starten muß ich es wohl oder übel mit VBA machen.

Mit gleiche Bedingung meine ich: A2 = 1 Dann Makro1 ........

Gruss Helga


  


Betrifft: AW: Makrostart durch Formel von: Nepumuk
Geschrieben am: 11.08.2004 18:22:19

Hallo Helga,
alles klar, du musst eine Funktion schreiben, die dein Makro startet.
Beispiel:


Public Function Funktion1()
    Call Makro1
End Function


Aber wie schon geschrieben. Auch Makros, die durch benutzerdefinierte Funktionen (das sind Funktionen die in Formeln verwendet werden) aufgerufen werden, unterliegen Beschränkungen. So kannst du z.B. keine Zellwerte in anderen Zellen manipulieren. Auch verschiedene VBA - Anweisungen werden dadurch einfach ignoriert und können zu falschen Ergebnissen führen.
Gruß
Nepumuk


  


Betrifft: Danke euch allen o.T. :-)) von: Helga
Geschrieben am: 11.08.2004 18:25:58

'


  


Betrifft: AW: Makrostart durch Formel von: tgh
Geschrieben am: 11.08.2004 18:17:33

Mische mich nur ungern ein, zumal Nepumuk schon am Werk ist.
Private Sub Worksheet_Change(ByVal Target As Range)
'Dein Makro
End Sub

Diesen Code in Deine Tabelle
by the way: Hallo Nepumuk
Ist das hier von Dir?
https://www.herber.de/bbs/user/9527.xls
Gruss Thomas


  


Betrifft: @Thomas von: Nepumuk
Geschrieben am: 11.08.2004 18:28:22

Hallo Thomas,
1. Wir befinden uns in ein öffentliches Diskussionsforum. Hier ist Einmischung erwünscht (zumindest von mir).
2. Nein, schau mal unter Datei - Eigenschaften, dort findest du den Autor.
Gruß
Nepumuk


 

Beiträge aus den Excel-Beispielen zum Thema "Makrostart durch Formel"