Microsoft Excel

Herbers Excel/VBA-Archiv

Suchfunktion

Betrifft: Suchfunktion von: Olli
Geschrieben am: 12.08.2004 16:32:59

Hallo Leute,
so sieht die Formel aus wenn ich den Suchbegriff und die Spalte (in der die Matrix sich befindet)in einer Tabelle habe:=WENN(ZEILE()>SUMME(ISTZAHL(FINDEN("AGB";A$1:A$100))*1);"";INDEX(A:A;KKLEINSTE(WENN(ISTZAHL(FINDEN("AGB";A$1:A$100));ZEILE($1:$100));ZEILE(A1))))

Meine Frage: Wie muß die Formel aussehen wenn ich den Suchbegriff in Tabelle 4 eingebe und die Matrix in Tabelle 5 ist ?

Gruß
Olli

  


Betrifft: AW: Suchfunktion von: Boris
Geschrieben am: 12.08.2004 17:27:25

Hi,

Wie muß die Formel aussehen wenn ich den Suchbegriff in Tabelle 4 eingebe und die Matrix in Tabelle 5 ist ?

Die Tabellen 4 und 5 sind groß - in welche der jeweils 16.777.216 Zellen gedenkst du denn, deinen Suchbegriff und deine Matrix einzupflegen?

Grüße Boris


  


Betrifft: AW: Suchfunktion von: Olli
Geschrieben am: 12.08.2004 17:48:20

Hallo Boris,
Suchbegriff: Tabelle 4 - C1
Matrix: Tabelle 5 A1:A100

Sorry!

Gruß
Olli


  


Betrifft: AW: Suchfunktion von: Boris
Geschrieben am: 12.08.2004 18:21:44

Hi Olli,

ungetestet - sollte aber tun:

{=WENN(ZEILE()>SUMME(ISTZAHL(FINDEN(Tabelle4!C1;Tabelle5!A$1:A$100))*1);"";INDEX(Tabelle5!A:A;KKLEINSTE(WENN(ISTZAHL(FINDEN(Tabelle4!C1;Tabelle5!A$1:A$100));ZEILE($1:$100));ZEILE(A1))))}

Grüße Boris


  


Betrifft: AW: Suchfunktion von: Olli
Geschrieben am: 12.08.2004 18:22:23

Diese Frage ist noch offen!!!!!

Sorry!!!


  


Betrifft: AW: Suchfunktion von: Olli
Geschrieben am: 12.08.2004 18:31:16

Hallo Boris,
Super!!!!

Danke!!!!!!!!!!!

Gruß
Olli