Microsoft Excel

Herbers Excel/VBA-Archiv

Auswertung

Betrifft: Auswertung von: Paul
Geschrieben am: 18.08.2004 12:13:53

Ich versuch schon den ganzen Morgen !
Ich möchte aus einer anderen Arbeismappe heraus in dem beigefügten Beispiel die Spalten zählen wenn z.B.in A=00006308 und in b ein Text aber nicht leer steht.

wer kann mir helfen ?

https://www.herber.de/bbs/user/9767.xls

  


Betrifft: AW: Auswertung von: Mac4
Geschrieben am: 18.08.2004 12:22:40

Hallo Paul,

wenn in A Text steht, dann so:

=SUMMENPRODUKT((A2:A31="00006305")*(ISTTEXT(B2:B31)))

Marc (aus Köln)


  


Betrifft: AW: Auswertung von: Paul
Geschrieben am: 18.08.2004 12:30:03

Der wert in A ist eine Zahl, geht das auch ?


  


Betrifft: AW: Auswertung von: Reinhard
Geschrieben am: 18.08.2004 12:34:09

Hi Paul,
anstatt isttext()
nicht(istleer())
Gruß
Reinhard


  


Betrifft: AW: Auswertung von: Mac4
Geschrieben am: 18.08.2004 12:35:11

Hallo Paul,

klar, dann hast Du A mit führenden Nullen formatiert, oder?
=SUMMENPRODUKT((A2:A31=6305)*(ISTTEXT(B2:B31)))

Marc (aus Köln)


  


Betrifft: AW: Auswertung von: Paul
Geschrieben am: 18.08.2004 12:40:29

Die Zahl ist eine Kundennummer, ich hab die nicht formatiert die Tabelle wurde aus einer ACCESS Datenbank erzeugt.


  


Betrifft: AW: Auswertung von: Paul
Geschrieben am: 18.08.2004 12:41:43

Aber es funktioniert.
Ich danke Euch

Gruß Paul


  


Betrifft: AW: Auswertung von: Paul
Geschrieben am: 18.08.2004 13:14:55

Etwas geht noch nicht und zwar zählt es mir auch die Zeilen in denen B= leer also nichts drinn steht.


 

Beiträge aus den Excel-Beispielen zum Thema "Auswertung"