Microsoft Excel

Herbers Excel/VBA-Archiv

Fehler in Formel!

Betrifft: Fehler in Formel! von: Josef
Geschrieben am: 20.08.2004 16:40:18

Hallo!
Danke einer Hilfe von Pepi und mittels folgender Formel,werden Werte zusammengezählt.

=SUMMENPRODUKT(('1'!B4:B2000="w")*('1'!C4:C2000="x"))

mit "x" wird gezählt, jedoch mit 1

=SUMMENPRODUKT(('1'!B4:B2000="w")*('1'!C4:C2000="1"))

bleibt die Summe auf 0, trotz Eingabe von Werten im Sheet "1"

Wieso funktioniert es bitte bei x schon und bei 1 nicht?

Danke


Josef

  


Betrifft: AW: Fehler in Formel! von: Jörg Gradert
Geschrieben am: 20.08.2004 16:49:13

Hallo Josef,
versuch mal die Anführungsstriche wegzulassen, wenn es Zahl sein soll.

=SUMMENPRODUKT(('1'!B4:B2000="w")*('1'!C4:C2000=1))

sonst müssten die Zellen, vor der Eingabe, als Text formatiert werden, damit deine Formel funktioniert.
Menü Format, Zellen, Text
Zahl steht rechtsbündig in der Zelle, Text linksbündig.

Gruss Jörg


  


Betrifft: AW: Fehler in Formel! von: Josef
Geschrieben am: 20.08.2004 16:50:28

Danke Jörg!

Jetzt paßt es.

Josef


 

Beiträge aus den Excel-Beispielen zum Thema "Fehler in Formel!"