Microsoft Excel

Herbers Excel/VBA-Archiv

Adressdaten matchen

Betrifft: Adressdaten matchen von: Sebastian
Geschrieben am: 25.08.2004 11:39:48

Hallo Ihr,

heute habe ich mal ein kniffliges Problem ... in dem ich selbst schon sehr gekommen bin.
Ich möchte Adressdaten in zwei Tabellen blättern miteinander vergleichen. In beiden Tabellen habe ich dazu über =A1&";"&A2&";2&A3 die Straße, PlZ und Ort miteinander verknüpft. Über die Funktion VERGLEICH zeigt mir Excel auch Treffer (als Zeilennr. in der Such-Matrix) und keine Treffer (als #NV) an.
Es gibt aber durchaus mehrere Treffer, die in der Suchmatrix stehen, leider wird mir aber jeweils nur der erste Treffer angezeigt. Über die Zeilennummer kann ich per SVERWEIS auch die gleiche Adresse rauskriegen.

Eine Idee habe ich ja selbst noch, nur an der Umsetzung scheitert es.
Ich durchsuche die Matrix ab (der 1.Fundstelle + 1) einfach weiter ! Jedoch schaffe ich es nicht die VERGLEICH-sFunktion, speziell den Matrix mit dem neuen Startwert zu parametrisieren. Ich schreibe in Tabelle1
=VERGLEICH(W2;Adressen2_gesamt!$O$2:$O$22126;0) Wie schaffe ich es, den Teil der Suchmatrix "$O$2" automstisch durch etwas anderes, beispielsweise "$O$100" zu ersetzen, wenn ich die "100" aus einer Zelle auslese.

Verstanden ???? Wenn nicht, dann bitte email ...

Bitte helft mir.

Vielen Dank
Sebastian

  


Betrifft: VERGLEICH bei mehreren Treffern von: Boris
Geschrieben am: 25.08.2004 11:49:14

Hi Sebastian,

eine arrayfreie Lösung:
In Spalte A stehen deine verketteten Werte.
In C1 steht der Suchbegriff.
Schreibe in D1:
=VERGLEICH(C1;A:A;)
und in D2 (und dann runterkopieren):
=VERGLEICH($C$1;INDIREKT("A"&D1+1&":A65536");)+D1

Im Ergebnis erhälst du alle Zeilennummern der Treffer.

Grüße Boris


  


Betrifft: AW: VERGLEICH bei mehreren Treffern von: Sebastian
Geschrieben am: 25.08.2004 13:31:50

Hallo Boris,

funktioniert leider nicht so, wie ich mir das vorstelle.
Wie sieht Deiner Meinung nach das Ergebnis aus!!!
Vielleicht liegt der fehler auch bei mir ???

Danke im Voraus


  


Betrifft: Hab die Glaskugel grad nicht dabei... von: Boris
Geschrieben am: 25.08.2004 13:46:04

Hi Sebastian,

...woher soll ich wissen, was bei dir nicht funktioniert? Und warum es eben nicht klappt?
Eine Beispieldatei wirkt in diesem Fall wahrscheinlich Wunder...

Grüße Boris


  


Betrifft: AW: Hab die Glaskugel grad nicht dabei... von: Sebastian
Geschrieben am: 25.08.2004 14:28:35

Hallo Boris,

du hast ja recht - bin froh, dass Du Dich um mich sorgst.
hier also die Datei. https://www.herber.de/bbs/user/10102.xls
Ich hoffe, Du siehst ein bisschen klarer...

Viele Grüße
Sebastian


  


Betrifft: Soll das Ganze horizontal ausgelesen werden? von: Boris
Geschrieben am: 25.08.2004 15:23:06

Hi Sebastian,

denn so sieht es für mich aus.
Schreibe in G2 die Formel:
=VERGLEICH(A2;$C:$C;0)
und kopier sie runter.
Dann in H2:
=VERGLEICH($A2;INDIREKT("C"&G2+1&":C1000");)+G2
und nach rechts UND nach unten kopieren.

Im Ergebnis erhälst du jetzt in der Waagerechten alle Zeilennummern.

Grüße Boris


  


Betrifft: AW: Soll das Ganze horizontal ausgelesen werden? von: Sebastian
Geschrieben am: 25.08.2004 15:47:24

Boris - Du bist SPITZE !!!!

Genau so sollte es sein. Jetzt ist es mir möglich, zu den
gefundenen Zahlen weitere Informationen anzeigen zu lassen.

Schau doch mal rein.
https://www.herber.de/bbs/user/10105.xls

Ich bin einfach wahnsinnig happy und danke Dir wie verrückt. :-)

Bis zum nächsten Mal.
Viele Grüße
Sebastian


 

Beiträge aus den Excel-Beispielen zum Thema "Adressdaten matchen"