Microsoft Excel

Herbers Excel/VBA-Archiv

Benutzerdefinierte Gültigkeit

Betrifft: Benutzerdefinierte Gültigkeit von: Fritz
Geschrieben am: 27.08.2004 16:45:09

Hallo Excelfreunde,
ich bitte um eure Hilfe:
ich möchte in einer Tabelle für die Zellen A1, A2 und A3 eine Gültigkeitsprüfung erstellen, die Eingaben unter Berücksichtigung der nachfolgenden Kriterien erlauben soll:
1. In jeder der drei Zellen soll eine Zahl eingegeben werden.
2. Es sollen nur die Werte 10, 20, 30, 40, 50, 60, 70 oder 80 möglich sein.
3. Die kleinste mögliche Zahl in diesen Zellen ist somit 10, die größte 80
4. Die Summe aller Zahlen in den 3 Zellen muss 100 ergeben.

Ich hoffe sehr, dass einer von euch Spezialisten für diese (für mich zu schwere Aufgabe) eine Lösung findet und danke im voraus für jede Hilfe.

Mfg
Fritz

  


Betrifft: AW: Benutzerdefinierte Gültigkeit von: Boris
Geschrieben am: 27.08.2004 16:55:39

Hi Fritz,

4. Die Summe aller Zahlen in den 3 Zellen muss 100 ergeben.

Das kannst du aber nicht mit der Gültigkeit garantieren, denn irgendwann muss ja mal der erste Wert eingegeben werden - und die Summe wird dabei noch nicht 100 sein.
Oder wenn die Werte mal geändert werden, dann wird es sich temporär auch nicht auf 100 summieren.

Ergo:
Ohne VBA kannst du das nur in Kombination mit der Bedingten Formatierung realisieren, die beispielsweise die Zellen so lange rot einfärbt, bis deren Summe 100 ergibt.

Dazu hinterlegst du bei jeder Zelle in der Gültigkeit einfach die Zahlenliste 10,20 etc...

und für die bedingte Formatierung für alle Zellen (Formel ist):
=SUMME($A$1:$A$3)<>100
und weist z.B. rot als Hintergrundfarbe zu.

Aber dass die Zellen rot sind, wird den geneigten User möglicherweise nicht weiter stören...

Grüße Boris


  


Betrifft: AW: Benutzerdefinierte Gültigkeit von: Fritz
Geschrieben am: 27.08.2004 17:04:11

Hallo Boris,

ich kann mit der vorgeschlagenen Lösung gut leben.
Vielen Dank für Deine Hilfe.

Gruß
Fritz


 

Beiträge aus den Excel-Beispielen zum Thema "Benutzerdefinierte Gültigkeit"