Microsoft Excel

Herbers Excel/VBA-Archiv

Summenfunktion

Betrifft: Summenfunktion von: Peter Bünger
Geschrieben am: 30.08.2004 12:23:10

Gibt es eine (einfache) Möglichkeit, in einer Zeile eine Zelle zu addieren, die nächste nicht, die nächste wieder zu addieren etc. Ich habe das Problem, daß ich weit über 30 solcher Zellen habe und damit das Maximum der Argumente für die Summenfunktion überschreite.

Danke

Peter

  


Betrifft: AW: Summenfunktion von: Hans W. Hofmann
Geschrieben am: 30.08.2004 12:32:32

=SUMMENPRODUKT(A1:A30;{1;0;1;0;1;0;1;0;1;0;1;0;1;0;1;0;1;0;1;0;1;0;1;0;1;0;1;0;1;0})

Gruß HW

myWebSite:Excellenzen & Powerpoint interaktiv
PowerPoint-Anwendertage im Oktober 2004 in Fulda: www.ppt-user.de


  


Betrifft: AW: Summenfunktion von: Boris
Geschrieben am: 30.08.2004 12:39:55

Hi Hans,

daß ich weit über 30 solcher Zellen habe

Viel Spass...;-)

Grüße Boris


  


Betrifft: oder allgemein...;-) von: IngoG
Geschrieben am: 30.08.2004 13:11:08

Hallo zusammen

oder für mehr als 30 zeilen... ;-)
=summenprodukt((a1:a100)*(rest(zeile(a1:a100);2)))

gruß Ingo


  


Betrifft: AW: oder allgemein...;-) von: Boris
Geschrieben am: 30.08.2004 13:16:10

Hi Ingo,

danke - aber das war mir sehr wohl bekannt.

Grüße Boris


  


Betrifft: @Boris: Dir schon... das war mir klar ;-) oT von: IngoG
Geschrieben am: 30.08.2004 13:21:42

.


  


Betrifft: AW: @Boris: Dir schon... das war mir klar ;-) oT von: Boris
Geschrieben am: 30.08.2004 14:40:42

Hi Ingo,

wenn dir das klar war: Warum postest du dann die Lösung?
Soll sich Peter (oder auch Hans) doch erstmal melden...

Grüße Boris


  


Betrifft: AW: @Boris: Dir schon... das war mir klar ;-) oT von: IngoG
Geschrieben am: 30.08.2004 17:32:17

Hallo Boris,

in diesem Punkt stimme ich nur bedingt mit Dir überein.
Prinzipiell gehe ich davon aus, dass sich ein Fragesteller erst einmal mit dem Problem beschäftigt hat und keine für Ihn zufriedenstellende Lösung erreicht hat, bevor er hier eine Frage stellt. Oft ist es dann so, dass man schon unter einem gewissen Zeitdruck steht und froh ist, wenn man eine funktionierende Lösung bekommt.

Bei mir ist es zumindest so, dass der größte Lerneffekt eintritt, wenn ich eine funktionierende Lösung sehe, an der ich etwas "rumspielen" kann um zu sehen, wie sich änderungen auf das Ergebnis auswirken.
Das mag zugegebenermassen bei anderen anders sein.

Wo ich Dir recht gebe ist, dass in jedem Fall eine Rückmeldung des Fragestellers angbracht ist und ich mich auch schon einige Male geärgert habe, wenn ich eine aufwändige Lösung präsentiert habe, die dann aus meiner Sicht im Nichts verpufft.
(ein aktuelles Beispiel ist meine hervorragende rekursive Lösung für das Schachproblem mit 8 Damen vom 26/27.08, die keinen mehr interessiert,aber das nur am Rande schnüff ;-))
Häufig versuche ich dies mit der überschäumenden Freude der (neuen) Fragesteller zu entschuldigen, die endlich einen Schritt weitergekommen sind, aber das hilft auch nicht immer...

Also deshalb poste ich auch schonmal fertige Lösungen ohne Nachfrage, wenn mir der Aufwand gering erscheint

Gruß Ingo




  


Betrifft: Rückmeldung und Sonstiges von: Boris
Geschrieben am: 30.08.2004 18:19:45

Hi Ingo,

darum ging´s doch in diesem konkreten Fall gar nicht.
Genau so, wie ich die Kompetenz von Hans W. Hofmann schätze, empfinde ich seine Art, im Forum zu posten, mitunter etwas "herablassend".
Und genau dahin wollte ich mich mit meinem Kommentar "Viel Spass..." auch einfach mal herablassen - wohl wissen, dass auch Hans W. Hofmann eine passendere Antwort im Zweifel parat hat.

Zum Thema Rückmeldung:
Das Präsentieren einer kompletten Lösung verleitet den Frager doch dazu, diese einfach "einzuheimsen" und sich nicht mehr zu melden - denn es gibt dafür ja keine Notwendigkeit (und Kinderstube ist wohl keine mehr).
Also empfinde ich das im Großen und Ganzen eher kontraproduktiv (siehe auch deine "rekursive Lösung" - viel Arbeit für nix...).

K.Rola macht das mitunter ganz geschickt: Sie stellt öfter erst mal ne Rückfrage nach dem Motto: "Bordmittel oder VBA?"
Und wenn keine Reaktion vom Frager kommt, dann bleibt der Thread eben unbeantwortet - und gut is.
Find ich zwar manchmal auch schade, da ich auch vom Mitlesen ne Menge profitiere - aber es bleibt mir ja unbelassen, mich direkt - um beim Beispiel zu bleiben - an K.Rola zu wenden.

Und dass du und andere ne Menge von der Excelmaterie verstehen, steht doch außer Frage.

Grüße Boris


  


Betrifft: AW: Rückmeldung und Sonstiges von: Peter
Geschrieben am: 31.08.2004 10:08:42

Danke für die Auskunft,

leider hat es mit meiner Reaktion etwas gedauert, was euch nicht in Aufregung versetzen muß - wenngleich Spekulationen über die soziale Veranlagung von Fragestellern ("Kinderstube") sicherlich reizvoll sind - ich hatte bisher keine Zeit, mir eure Antworten in Ruhe anzuschauen.
Wenn mir einer von euch Könnern die Funktion noch etwas näher erläutern könnte, wäre ich euch dankbar, denn mir gelingt es nicht, sie fehlerfrei in meiner Tabelle anzupassen, was sicherlich auf Verständisfehlern beruht.

Danke

Peter


  


Betrifft: Erläuterung der Formel von: Boris
Geschrieben am: 31.08.2004 10:16:21

Hi Peter,

nehmen wir diese Formel:

=SUMMENPRODUKT(A1:A100;REST(ZEILE($1:$100);2))

Der Part REST(ZEILE($1:$100);2) dividiert die Zahlen 1 bis 100 (=Zeilen 1 bis 100) durch 2 und liefert den Rest dieser Division als Ergebnis.
Und dieser Rest ist immer abwechselnd 1 oder Null (z.B.: 3/2=1 Rest 1, 4/2=2 Rest 0 usw. usw..)
Und jeder Wert aus A1:A100 wird mit dem zugehörigen Rest zunächst multipliziert und anschließend addiert (daher Summe und Produkt = SUMMENPRODUKT).

Alles klar?

Grüße Boris


  


Betrifft: AW: Erläuterung der Formel von: Peter
Geschrieben am: 31.08.2004 12:29:28

Hallo Boris,

danke für deine Erläuterung, jetzt funktionierts.

Gruß

Peter


  


Betrifft: Danke für die Rückmeldung und Sonstiges ;-) von: IngoG
Geschrieben am: 31.08.2004 22:05:05

Hallo Peter,

freut mich, dass Du mein positives Weltbild wieder etwas realistischer erscheinen lässt.
;-)
Gruß Ingo