Microsoft Excel

Herbers Excel/VBA-Archiv

Automatischer Sverweis

Betrifft: Automatischer Sverweis von: Thomas_H
Geschrieben am: 30.08.2004 13:20:32

Hallo NG!

Wende mich wiedereinmal mit einem Problem an euch!
Gibt es eine Möglichkeit eine Funktion zu erstellen (sverweis) welche immer auf die gleiche aber geschlossene Datei verweist ???

Als Beispiel:
Funktionsname = Daten
Suchkriterium = A1.
Matrix = C:\Rodaten\Tabelle1!A:B
Spaltenindex = 2

Dann sollte die Funktion in z.B. Spalte B2 so aussehen =Daten(A1)

Hoffe ich habe mich verständlich ausgedrückt. Danke auf jedenfall für eure Hilfe.
Thomas H.

  


Betrifft: Hilfe bei Formel ..... von: Thomas_H
Geschrieben am: 30.08.2004 13:54:45

Habe jetzt folgende Formel zusammengestellt...

Function Usp(Zellenbezug As Variant)
    a = Workbooks("Übersichtstabellen.xls").Sheets("Sp_Spgrp_USP").[F:G]
    Usp = WorksheetFunction.VLookup(Zellenbezug, a, 2, False)
End Function


Leider funktioniert sie nicht...
Könntet ihr mir helfen, was ich falsch mache.... bzw. was muss ich machen wenn die Verweisdatei geschlossen ist???

Danke für eure Hilfe, TH


  


Betrifft: AW: Hilfe bei Formel ..... von: Bert
Geschrieben am: 30.08.2004 14:04:39

Wenn die Datei geschlossen ist, gehts nur via Zellbezug.

Set a = Workbooks("Übersichtstabellen.xls").Sheets("Sp_Spgrp_USP").[F:G]

Bert


  


Betrifft: AW: Hilfe bei Formel ..... von: Thomas_H
Geschrieben am: 30.08.2004 14:16:09

Hallo Bert!

Danke für die Hilfe. Nur wie sieht die Formel aus wenn die Set Datei geschlossen ist.... ???

Set a= ????

Danke für die Hilfe, TH


  


Betrifft: AW: Hilfe bei Formel ..... von: Bert
Geschrieben am: 30.08.2004 14:18:40

Die Formel muss dann in einer Zelle stehen:

=SVERWEIS(......)

Mit VBA gehts dann nicht!

Bert


 

Beiträge aus den Excel-Beispielen zum Thema "Automatischer Sverweis"