Microsoft Excel

Herbers Excel/VBA-Archiv

Formel KGRÖSSTE

Betrifft: Formel KGRÖSSTE von: Rudolf Perkams
Geschrieben am: 30.08.2004 19:37:21

Hallo Excel-Freunde,

ich habe folgendes Problem beim Erstellen einer Spielliste:
In einer Tabellenzeile habe ich für jeden Teilnehmer das jeweilige Monatsergebnis als Zahl eingetragen. In Monaten, wo der Teilnehmer nicht mitmachte, ist das Feld leer.
Nun will ich z.B. die Monatsergebnisse eines Teilnehmers mit der Formel KGRÖSSTE sortieren. Da der Bereich aber auch wie erwähnt leere Felder enthält, bekomme ich die Fehlermeldung #ZAHL! .
Gibt es eine Lösung, um doch die Sortierung vorzunehmen?

Gruss
Rudolf

  


Betrifft: AW: Formel KGRÖSSTE von: Teo
Geschrieben am: 30.08.2004 23:32:38

hi

versuch mal das

=WENN(SUMME(B3:B13)<>0;KGRÖSSTE(B3:B13;2);";)")

gruß
teo


  


Betrifft: wenn(istfehler... von: Günther Oppold
Geschrieben am: 31.08.2004 12:45:47

Hi Rudolf:

=wenn(istfehler(DEINE FORMEL);"";DEINE FORMEL)

Tabelle1
 BCD
17144
18222
19 11
204#ZAHL! 
Formeln der Tabelle
C17 : =KGRÖSSTE(B$17:B$20;ZEILE()-16)
D17 : =WENN(ISTFEHLER(KGRÖSSTE(B$17:B$20;ZEILE()-16));"";KGRÖSSTE(B$17:B$20;ZEILE()-16))
C18 : =KGRÖSSTE(B$17:B$20;ZEILE()-16)
D18 : =WENN(ISTFEHLER(KGRÖSSTE(B$17:B$20;ZEILE()-16));"";KGRÖSSTE(B$17:B$20;ZEILE()-16))
C19 : =KGRÖSSTE(B$17:B$20;ZEILE()-16)
D19 : =WENN(ISTFEHLER(KGRÖSSTE(B$17:B$20;ZEILE()-16));"";KGRÖSSTE(B$17:B$20;ZEILE()-16))
C20 : =KGRÖSSTE(B$17:B$20;ZEILE()-16)
D20 : =WENN(ISTFEHLER(KGRÖSSTE(B$17:B$20;ZEILE()-16));"";KGRÖSSTE(B$17:B$20;ZEILE()-16))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Günther

 

Beiträge aus den Excel-Beispielen zum Thema "Formel KGRÖSSTE"