Microsoft Excel

Herbers Excel/VBA-Archiv

Suche Formeln

Betrifft: Suche Formeln von: Heidi
Geschrieben am: 31.08.2004 11:33:53

Moin Experten, ich suche eine Formel.

Habe in einer Tab. Zellen jede enthält ein Datum nun möchte ich die Differenz zwischen den beiden Daten wissen, das bekomme ich noch hin mit DATEDIF aber es soll mir auch angeben wenn die Differenz 6 Tage beträgt soll das Ergebnis mit einen Text anhang wie folgt ausehen " 1. Block ", sollten 12 Tage Diff. sein so sollte der Txt lt. " 2. Blöcke ", sollte die Diff. 18 Tage sein mit Txt " 3. Blöcke "

Kann ich das auch an die Formel DATEDIF anhängen oder gibt es dazu eine andere Lösung ?

Gruss Heidi

  


Betrifft: AW: Suche Formeln von: Harald Kapp
Geschrieben am: 31.08.2004 12:14:08

Hallo Heidi,
1) kannst Du direkt die Datumswerte subtrahieren
2) kannst Du das Ergebnis zusätzlich verändern:

=(B1-A1) & "Tage, " &WENN(REST(B1-A1;6)=0;" " &(B1-A1)/6 & ". Blöcke";)

Gruß Harald


  


Betrifft: AW: Suche Formeln von: Heidi
Geschrieben am: 31.08.2004 12:27:16

Hi Harald, Danke Dir für die Antwort hast Du noch soetwas parat wo mit ich nich die Diff. der Tage , sonder die genaue Anzahl der Tage als Ergebnis bringt.

z.Bsp. 04.01.2004 bis 09.01.2004 mit deiner Formel Diff. = 5 Tage ( funz auserdem prima )

04.01.2004 bis 09.01.2004 Formel..... = Anzahl der Tage 6


Gruss Heidi


  


Betrifft: B1-A1+1 von: Günther Oppold
Geschrieben am: 31.08.2004 12:36:07

Hallo Heidi

wenn Anfangs- und Enddatum mitgezählt werden sollen, so addiere zu der Differenz einfach eine 1 hinzu.

Günther


  


Betrifft: AW: Suche Formeln von: Günther Oppold
Geschrieben am: 31.08.2004 12:15:38

Hallo Heidi

ich habs hier ohne Datedif gemacht, da Datedif eigentlich nur ab Dirrerenzen von Monaten / Jahren .. sinnvoll ist. Bei Tagesdifferenzen genügt es die beiden Datas von einander abzuziehen.
natürlich kannst Du die Datedif entsprechend einsetzen.

Tabelle2
 ABC
131.08.200402.09.20042
231.08.200404.09.20044
331.08.200406.09.20046 / 1. Block
431.08.200408.09.20048
531.08.200410.09.200410
631.08.200412.09.200412 / 2 Blöcke
731.08.200414.09.200414
831.08.200416.09.200416
931.08.200418.09.200418 / 3 Blöcke
1031.08.200420.09.200420
1131.08.200422.09.200422
1231.08.200424.09.200424 / 4 Blöcke
1331.08.200426.09.200426
1431.08.200428.09.200428
Formeln der Tabelle
C1 : =WENN(B1-A1=6;B1-A1&" / 1. Block";WENN(REST(B1-A1;6)=0;B1-A1&" / "&(B1-A1)/6&" Blöcke";B1-A1))
C2 : =WENN(B2-A2=6;B2-A2&" / 1. Block";WENN(REST(B2-A2;6)=0;B2-A2&" / "&(B2-A2)/6&" Blöcke";B2-A2))
C3 : =WENN(B3-A3=6;B3-A3&" / 1. Block";WENN(REST(B3-A3;6)=0;B3-A3&" / "&(B3-A3)/6&" Blöcke";B3-A3))
C4 : =WENN(B4-A4=6;B4-A4&" / 1. Block";WENN(REST(B4-A4;6)=0;B4-A4&" / "&(B4-A4)/6&" Blöcke";B4-A4))
C5 : =WENN(B5-A5=6;B5-A5&" / 1. Block";WENN(REST(B5-A5;6)=0;B5-A5&" / "&(B5-A5)/6&" Blöcke";B5-A5))
C6 : =WENN(B6-A6=6;B6-A6&" / 1. Block";WENN(REST(B6-A6;6)=0;B6-A6&" / "&(B6-A6)/6&" Blöcke";B6-A6))
C7 : =WENN(B7-A7=6;B7-A7&" / 1. Block";WENN(REST(B7-A7;6)=0;B7-A7&" / "&(B7-A7)/6&" Blöcke";B7-A7))
C8 : =WENN(B8-A8=6;B8-A8&" / 1. Block";WENN(REST(B8-A8;6)=0;B8-A8&" / "&(B8-A8)/6&" Blöcke";B8-A8))
C9 : =WENN(B9-A9=6;B9-A9&" / 1. Block";WENN(REST(B9-A9;6)=0;B9-A9&" / "&(B9-A9)/6&" Blöcke";B9-A9))
C10 : =WENN(B10-A10=6;B10-A10&" / 1. Block";WENN(REST(B10-A10;6)=0;B10-A10&" / "&(B10-A10)/6&" Blöcke";B10-A10))
C11 : =WENN(B11-A11=6;B11-A11&" / 1. Block";WENN(REST(B11-A11;6)=0;B11-A11&" / "&(B11-A11)/6&" Blöcke";B11-A11))
C12 : =WENN(B12-A12=6;B12-A12&" / 1. Block";WENN(REST(B12-A12;6)=0;B12-A12&" / "&(B12-A12)/6&" Blöcke";B12-A12))
C13 : =WENN(B13-A13=6;B13-A13&" / 1. Block";WENN(REST(B13-A13;6)=0;B13-A13&" / "&(B13-A13)/6&" Blöcke";B13-A13))
C14 : =WENN(B14-A14=6;B14-A14&" / 1. Block";WENN(REST(B14-A14;6)=0;B14-A14&" / "&(B14-A14)/6&" Blöcke";B14-A14))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Günther

  


Betrifft: AW: Herzlichen Dank an euch beiden o.T. von: Heidi
Geschrieben am: 31.08.2004 12:57:39

'


 

Beiträge aus den Excel-Beispielen zum Thema "Suche Formeln"