Microsoft Excel

Herbers Excel/VBA-Archiv

Wie mach ich das...

Betrifft: Wie mach ich das... von: Dan
Geschrieben am: 31.08.2004 16:22:03

Hallo,

ích habe eine grosse Excel Datei mit 1000 Zeilen und einer Spalte. In jeder Spalte befinden sich in der Mitte des Textes drei Doppelpunkte. Wie kann ich den Text so umändern, dass sowohl der erste Buchstabe nach den drei Doppelpunkten gross geschrieben wird als auch alle Buchstaben die nach einem Leerzeichen auftauchen.

Weiss das evtl jemand? Wenns geht ohne VBA.

Mit folgendem Code kann man den ersten Buchstaben nach den drei Doppelpunkten grossschreiben, aber nicht die Buchstaben nach den Leerzeichen:
=ERSETZEN(A1;FINDEN(":::";A1)+3;1;GROSS(TEIL(A1;FINDEN(":::";A1)+3;1)))

Ich bräuchte also einen Code mit dem man beides gleichzeitig kann...

gruss
dan

  


Betrifft: AW: Wie mach ich das... von: Reinhard
Geschrieben am: 31.08.2004 16:45:45

Hi dan,
probiersmal so:
=GROSS2(ERSETZEN(A1;FINDEN(":::";A1)+3;1;GROSS(TEIL(A1;FINDEN(":::";A1)+3;1))))
Gruß
Reinhard


  


Betrifft: AW: Wie mach ich das... von: Wolfgang
Geschrieben am: 31.08.2004 16:50:57

Hallo Dan,

hab folgendes für dich:

=WENN(ISTFEHLER(ERSETZEN(A2;FINDEN(":::";A2)+3;1;GROSS(TEIL(A2;FINDEN(":::";A2)+3;1))));ERSETZEN(A2;FINDEN(" ";A2)+1;1;GROSS(TEIL(A2;FINDEN(" ";A2)+1;1)));WENN(ISTFEHLER(ERSETZEN(A2;FINDEN(" ";A2)+1;1;GROSS(TEIL(A2;FINDEN(" ";A2)+1;1))));ERSETZEN(A2;FINDEN(":::";A2)+3;1;GROSS(TEIL(A2;FINDEN(":::";A2)+3;1)));ERSETZEN(A2;FINDEN(":::";A2)+3;1;GROSS(TEIL(A2;FINDEN(":::";A2)+3;1)))))

Leider klappt das nur wenn nur Leerzeichen ODER ::: vorkommt. Wenns gemischt ist, weiß ich leider keine Lösung durch Formeln, dann hilft meines Wissens nur noch VBA....


Gruß
Wolfgang


  


Betrifft: AW: Wie mach ich das... von: Dan
Geschrieben am: 31.08.2004 17:13:34

Danke für die zwei Antworten. Aber leider klappt das mit Eurer Formel nicht. Habe vielleicht vergessen zu erwähnen, dass sich in meinen Spalten ausschliesslich HTML-Code mit externen Links befindet. Es tauchen also jede Menge Zeichen wie Bindestriche, Semikolon etc auf. Ich habe mal eine Excel Tabelle als Beispiel hochgeladen... https://www.herber.de/bbs/user/10356.xls

Ich hoffe der eine oder andere kriegt die Formel hin. Ich schaffe es leider nicht :(

gruss
Dan


  


Betrifft: AW: Wie mach ich das... von: Reinhard
Geschrieben am: 31.08.2004 17:27:35

Hi Dan,
also aus
<a href="http://www.bilder.asien.net/wod_18.php:::bilder asien</a><br>
soll
<a Href="http://www.bilder.asien.net/wod_18.php:::Bilder Asien</a><br>
werden?
Gruß
Reinhard