Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl

Betrifft: Anzahl von: stefan 13
Geschrieben am: 01.09.2004 09:32:21

Hallo Zusammen

Volgendes ich möchte die Anzahl einer Liste ermitteln.
Da jedoch in den Feldern folgende Formel steht,
z.b.
=WENN(ISTFEHLER(Tabelle!J32);"";Tabelle!J32)
zählt er diese immer mit.
Sollte jedoch leere Felder nicht mitzählen!

Please Help
Gruß Stefan

  


Betrifft: =ANZAHL2(A1:A4)-ANZAHLLEEREZELLEN(A1:A4) von: Boris
Geschrieben am: 01.09.2004 09:41:55

Grüße Boris


  


Betrifft: AW: kürzer von: HermannZ
Geschrieben am: 01.09.2004 09:49:16

Hallo Boris,

zähle auch keine Formel und Leerzellen.

---=ANZAHL(WENN(A1:A100<>0;A1:A100))----

Gruß Hermann


  


Betrifft: Viel kürzer wäre dann aber =ANZAHL(A:A) von: Boris
Geschrieben am: 01.09.2004 09:55:48

Hi Hermann,

zählt aber - genau wie deine Formel - nur Zahlen und keine Texte.

Grüße Boris


  


Betrifft: AW: Ok. gewonnen.. oT von: HermannZ
Geschrieben am: 01.09.2004 09:58:02

..


  


Betrifft: Hilft leider nicht ! von: Stefan 13
Geschrieben am: 01.09.2004 09:49:07

Zählt zelle weiterhin mit.


  


Betrifft: AW: Hilft leider nicht ! von: Boris
Geschrieben am: 01.09.2004 09:56:43

Hi Stefan,

Zählt zelle weiterhin mit.

Stimmt nicht.

Grüße Boris


  


Betrifft: Hilft leider auch nicht ! von: Stefan 13
Geschrieben am: 01.09.2004 10:01:47

=WENN(ISTFEHLER(Tabelle!J32);"";Tabelle!J32)
Kann es vieleicht damit zusammenhängen wenn ich diese Formel auf welche sich die Anzahl u.a bezieht, nicht angebe ich als Ausgabe #Wert! erhalte?


  


Betrifft: Bahnhof von: Boris
Geschrieben am: 01.09.2004 10:03:14

Hi Stefan,

lad mal ne Beispieltabelle hoch.

Grüße Boris


  


Betrifft: Beipiel !! von: stefan 13
Geschrieben am: 01.09.2004 10:15:58

Z.B. so


https://www.herber.de/bbs/user/10378.xls


  


Betrifft: 0 ist ja auch nicht "" von: Boris
Geschrieben am: 01.09.2004 10:32:36

Hi Stefan,

in deinem ersten Beitrag hast du das geschrieben:
=WENN(ISTFEHLER(Tabelle!J32);"";Tabelle!J32)

In deiner Tabelle steht aber sinngemäß:
=WENN(ISTFEHLER(Tabelle!J32);0;Tabelle!J32)

Und Null ist eben für die Funktion ANZAHLLEEREZELLEN nicht leer - "" aber sehr wohl.

Grüße Boris


  


Betrifft: Unabhängig davon... von: Boris
Geschrieben am: 01.09.2004 10:35:23

Hi Stefan,

...reicht für dein Beispiel natürlich aus:
=ZÄHLENWENN(H37:H38;">0")

Oder auch
=(H37>0)+(H38>0)

Aber ich fürchte, deine Tabelle ist nur die halbe Wahrheit...;-)

Grüße Boris


  


Betrifft: OK ! 100 zu 1 für Dich Danke !!!! von: Stefan 13
Geschrieben am: 01.09.2004 10:42:20

Grüße
Stefan


 

Beiträge aus den Excel-Beispielen zum Thema "Anzahl"