Microsoft Excel

Herbers Excel/VBA-Archiv

Recherche mit #WERT

Betrifft: Recherche mit #WERT von: Josef
Geschrieben am: 10.09.2004 19:26:13

Guten Abend!

Ich habe in der Recherche die Möglichkeit gefunden einen #WERT mit

=WENN(ISTFEHLER(..... zu unterdrücken.

Wäre dies bitte bei folgender Formel möglich?

=WENN(G494="";0;G496+G498-G521)

Ist ein Wert in G494 ist alles ok, ist kein Wert in G494 erscheint die Fehlermeldung #WERT.
Eine Unterdrückung der Nullen mit Herausnahme des Häckchens unter Extras, Optionen,Ansichten,Nullwerte würde mir nichts bringen, da die Anzeige von Nullen in anderen Zellen notwendig wäre.


Josef

  


Betrifft: AW: Recherche mit #WERT von: th.heinrich
Geschrieben am: 10.09.2004 19:39:05

hallo Josef,

Deine FORMEL =WENN(G494="";0;G496+G498-G521)

funzzt, vergiss den ISTFEHLER.

gruss thomas


  


Betrifft: AW: Recherche mit #WERT von: Josef
Geschrieben am: 10.09.2004 19:44:19

Hallo Thomas!

Die Formel funzt wenn ein Wert in G494 steht, ist kein Wert, dann erscheint #WERT.Und diese Meldung hätte ich gerne unterdrückt.

Josef


  


Betrifft: AW: Recherche mit #WERT von: FP
Geschrieben am: 10.09.2004 20:56:17

Hi Josef,

Du prüfst G494 auf leer oder nicht leer

dann rechnest Du aber mit G496, G498 und G521

und in einer dieser drei Zellen steht definitiv ein Text - und daher kommt #WERT

hier ein paar Beispiele + Lösung

Tabelle1
 ABCDE
1 rechnerechnerechnerechne
211111
322 texttext
444444
50-1-3#WERT!-3
Formeln der Tabelle
A5 : =WENN(A1="";0;A2+A3-A4)
B5 : =WENN(B1="";0;B2+B3-B4)
C5 : =WENN(C1="";0;C2+C3-C4)
D5 : =WENN(D1="";0;D2+D3-D4)
E5 : =WENN(E1="";0;SUMME(E2;E3;-E4))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


dabei genügt schon, dass Du eine Formel wie z.B. =WENN(Bedingung;"";9) verwendest

Tabelle1
 DE
1rechnerechne
211
3  
444
5#WERT!-3
Formeln der Tabelle
D3 : =WENN(D1<>"";"";2)
E3 : =WENN(D1<>"";"";2)
D5 : =WENN(D1="";0;D2+D3-D4)
E5 : =WENN(E1="";0;SUMME(E2;E3;-E4))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  




Servus aus dem Salzkammergut
Franz


  


Betrifft: AW: Recherche mit #WERT von: th.heinrich
Geschrieben am: 10.09.2004 21:22:28

hi Franz,

Du hast natuerlich recht, hatte beim testen die entsprechenden ZELLEN auch als TEXT formatiert, aber es standen nur ZAHLEN drin und keine BUCHSTABEN.

gruss thomas


  


Betrifft: AW: Recherche mit #WERT von: Josef
Geschrieben am: 10.09.2004 22:15:18

Hallo Franz!

Danke für Deine Hilfe. Werde es gleich ausprobieren.

Schönen Abend noch und Grüße aus Wien

Josef