Microsoft Excel

Herbers Excel/VBA-Archiv

Summen von Teilsummen

Betrifft: Summen von Teilsummen von: Thomas F.
Geschrieben am: 14.09.2004 09:16:35

Möchte gerne von veränderlichen Teilsummen (UG) die ich mit der Formel =WENN(A3="";"";SUMME(INDIREKT("d"&ZEILE()+1&":d"&ZEILE()-1+VERGLEICH("*";$A4:A$31;0))))Gruppensummen (LG) bilden die von LG bis LG reichen ohne das ich jedes einzelne Teilergebnis addieren muß (nicht =D3+D8+D15 ....) den ich habe ca. 50 LG und 300 UG. Ich kann dies schlecht erklären, deshalb lade ich auch meine Excel-Tabelle mit hoch. Vielleicht kann mir jemand bei diesem Problem helfen.

https://www.herber.de/bbs/user/10861.xls


l.G. Thomas F.

  


Betrifft: AW: Summen von Teilsummen von: Stephan
Geschrieben am: 14.09.2004 11:13:17

Lieber Thomas,


kopiere doch die UG-Summen in die Spalte nebendran (z.B. mit einer Formel wie =IF(a1="UG", d1, 0) oder so). Dann koenntest Du mit demselben Trick, mit dem die UG-Summen in der Spalte D berechnet werden, die entsprechenden LG-Summen in der neuen Spalte E berechnen. Jetzt brauchst Du sie nur noch zurueck zu schreiben (also einfach aus Spalte D heraus darauf zu verweisen) und die Spalte E zu verstecken...


Herzlichst,
Stephan.


  


Betrifft: AW: Summen von Teilsummen von: Thomas F.
Geschrieben am: 14.09.2004 11:38:52

Danke Stephan,
soweit ist alles klar und es funktioniert auch, aber geht das auch ohne eine neue Spalte "E" ?


  


Betrifft: AW: Summen von Teilsummen von: Stephan
Geschrieben am: 14.09.2004 12:49:19

Lieber Thomas,


man koennte vielleicht versuchen, in Deinen Formeln die Funktion SUMME durch SUMIF (deutsch: SUMMEWENN?) zu ersetzen. Bedingung fuer's summieren ist dann, dass in Spalte 1 "UG" steht.


Herzlichst,
Stephan.


 

Beiträge aus den Excel-Beispielen zum Thema "Summen von Teilsummen"