Microsoft Excel

Herbers Excel/VBA-Archiv

Leere Zelle ohne Text erkennen

Betrifft: Leere Zelle ohne Text erkennen von: Ruwer
Geschrieben am: 15.09.2004 17:56:03

Hallo,
wer kann mir helfen?

Ich führe eine Matrixberechnung mit folgender Formel durch:

=SVERWEIS(X26;C2:E7;3) (z.B. in Zelle F26)

Zusätzlich will ich eine leere Zelle (z.B. B26) auf Texteintrag erkennen und dann den Wert "0", sonst den Ursprungswert in Zelle F26 anzeigen.

Also in Abhängigkeit Text vorhanden oder nicht vorhanden.
Wenn Text vorhanden, dann Wert berechnen.
Wenn Text nicht vorhanden, den Wert "0" in Zelle F26 anzeigen.

Wie lautet die komplette Formel ?

Danke schon mal



  


Betrifft: AW: Leere Zelle ohne Text erkennen von: ransi
Geschrieben am: 15.09.2004 18:08:21

hallo ruwer

so könnte es gehn,
ist aber nicht getestet.
=wenn(b26="";0;SVERWEIS(X26;C2:E7;3))
ransi


  


Betrifft: AW: Leere Zelle ohne Text erkennen von: ruwer
Geschrieben am: 15.09.2004 20:26:58

danke , hat super geklappt


  


Betrifft: AW: Leere Zelle ohne Text erkennen von: Harry
Geschrieben am: 15.09.2004 18:17:23

Hi Ruver,

versuch's mal mit

=Wenn(B26="";"0";SVERWEIS(X26;C2:E7;3)) (z.B. in Zelle F26)

d.h, wenn Zelle B26 leer ist, dann wird in Zelle F26 0 (in diesem Fall als Text), ansonsten als Rechenergebnis angezeigt.

Müsste eigentlich funzen.

Gruss Harry


  


Betrifft: AW: Leere Zelle ohne Text erkennen von: Ruwer
Geschrieben am: 15.09.2004 20:25:28

danke, hat super geklappt


 

Beiträge aus den Excel-Beispielen zum Thema "Leere Zelle ohne Text erkennen"