Zählen

Bild

Betrifft: Zählen
von: Nico
Geschrieben am: 14.02.2005 17:08:48
Hallo,
danke an Ransi und Boris. Ihr wart schnell und gut. Eine Frage hätte ich da aber noch.
wie kann ich jetzt meine Liste durchzählen lassen, wieviel unterschiedliche Argumente darin sind, ohne die doppelten mitzuzählen?
Gruß
Nico

Bild

Betrifft: {=SUMME(1/ZÄHLENWENN(A1:A5;A1:A5))}
von: ransi
Geschrieben am: 14.02.2005 17:12:16
hallo nico
das geht so:
 
 AB
105AA044
206AB03 
307AA05 
405AA04 
5615034 
Formeln der Tabelle
B1 : {=SUMME(1/ZÄHLENWENN(A1:A5;A1:A5))}
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
die formel musst du mit strg+shift+enter abschliessen.
dann kommen die {} automatisch.
wenn du es von hand machst wirds nix..
ransi
Bild

Betrifft: Aber nur, wenn keine Leerzellen dabei sind...oT
von: Boris
Geschrieben am: 14.02.2005 17:23:43
Grüße Boris
Bild

Betrifft: uups, und wie...
von: ransi
Geschrieben am: 14.02.2005 17:30:50
hallo boris
...klappt das mit leerzeilen?
ransi
Bild

Betrifft: Mit Leerzellen
von: Boris
Geschrieben am: 14.02.2005 17:32:27
Hi Ransi,
{=SUMME(WENN(A1:A100<>"";1/ZÄHLENWENN(A1:A100;A1:A100)))}
Grüße Boris
Bild

Betrifft: doch....
von: ransi
Geschrieben am: 14.02.2005 17:39:58
danke boris
...so einfach.
Ich dachte jetzt kommt wieder eine von deinen array formel mit zig index(),
vergleich() und was weiss ich für für hochrasanten funktionen.
;-)
ransi
Bild

Betrifft: Das Gute liegt manchmal so nah...
von: Boris
Geschrieben am: 14.02.2005 19:20:12
Hi Ransi,
...und auch, wenn ich die WENN-Funktion meide wo es geht - hier geht´s eben nicht ohne...;-)
Grüße Boris
 Bild

Beiträge aus den Excel-Beispielen zum Thema "GetOpenFilename(...) - Problem"