VBA

  • VBA von Franz vom 16.02.2005 12:43:45
    • AW: VBA - von Uduuh am 16.02.2005 12:55:55
    • AW: VBA - von Matthias G am 16.02.2005 12:56:01
    • AW: VBA - von Peter am 16.02.2005 13:01:07
Bild

Betrifft: VBA
von: Franz
Geschrieben am: 16.02.2005 12:43:45
Hallo,
habe folgendes Problem:
Da die WENN-Funktion auf 9 Bedingungen begrenzt ist,
versuche ich die restlichen Bedingungen mit folgenden Code zu lösen:
For c = 23 To 766
If Cells(10, 3) = Cells(c, 3) Then Cells(c, 4) = Cells(10, 4)
If Cells(10, 3) <> Cells(c, 3) Then Cells(c, 4) = ""
Next
leider dauert die Berechnung ziemlich lange.
Gibt es eine bessere Lösung?
Gruß, Franz

Bild

Betrifft: AW: VBA
von: Uduuh
Geschrieben am: 16.02.2005 12:55:55
Hallo,
dann kannst du doch gleich die ensprechende Formel in D23:d766 schreiben.
=wenn(c23=$c$10;$d$10;"")
Gruß aus'm Pott
Udo

Bild

Betrifft: AW: VBA
von: Matthias G
Geschrieben am: 16.02.2005 12:56:01
Hallo Franz,
hilf mir mal auf die Sprünge...
Wie sind denn die ersten 9 Bedingungen? Und wie kombinierst du die Wenn-Formel mit dem VBA-Code?
Irgendie schaut das aus wie in D23: =WENN(C$10=C23;D$10;"") und dann runterkopiert.
Gruß Matthias
Bild

Betrifft: AW: VBA
von: Peter
Geschrieben am: 16.02.2005 13:01:07
Hallo,
also ich würde es genau so wie Du machen. Ich habe nur noch ein paar Dinge dazugeschrieben. Bei mir klappt es so...
For c = 23 To 766
If Cells(10, 3) = Cells(c, 3) Then
Cells(c, 4) = Cells(10, 4)
If Cells(10, 3) <> Cells(c, 3) Then
Cells(c, 4) = ""
End If
End If
Next c
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel in Excel darstellen"