mehrere Sieger ermitteln

Bild

Betrifft: mehrere Sieger ermitteln von: Andre
Geschrieben am: 16.02.2005 18:27:42

Hallo Leute!

gibt es eine Möglichkeit mehrere Sieger zu bestimmen und gleichzeitig die entsprechenden Namen anzuzeigen?

Wenn Ihr genauere Informationen benötigt, sagt bescheid!

Danke

/AndRe

Bild


Betrifft: Ja! ot von: Detlef
Geschrieben am: 16.02.2005 18:38:53

d


Bild


Betrifft: ..brauchen nicht mehr Informationen...:-) ...o.T. von: forum
Geschrieben am: 16.02.2005 18:39:36

....


Bild


Betrifft: AW: ..brauchen nicht mehr Informationen...:-) ...o.T. von: Andre
Geschrieben am: 16.02.2005 18:58:38

Ok, dann werd ich die Sache mal ein bissl ausweiten:

Sinn der Sache ist eine Tipp-Tabelle, an der mehrere Spieler teilnehmen können.
Ein Spieltag besteht aus nur 2 Spielen. Einen Punkt bekommt der, der ein Ergebnis richtig hat und einen Zweiten Punkt der, der auch das Zweite Spiel richtig hat.
Das Sieht folgendermaßen aus:

Tabelle1
 ABCDEFGHIJKLMNOPQRSTUV
1   Spieler 1Spieler 2Spieler 3Spieler 4Spieler 5ErgebnisGewinner
2Mannschaft 1:Mannschaft 22:12:32:12:14:22:1 
3Mannschaft 2:Mannschaft 31:21:20:31:21:21:2 
4 211212Namen der Gewinner
Formeln der Tabelle
D4 : =WENN(ODER(ODER($S$2="";$U$2="");ODER($S$3="";$U$3=""));"";WENN(UND(D2=$S$2;F2=$U$2;D3=$S$3;F3=$U$3);2;WENN(ODER(UND(D2=$S$2;F2=$U$2);UND(D3=$S$3;F3=$U$3));1;0)))
G4 : =WENN(ODER(ODER($S$2="";$U$2="");ODER($S$3="";$U$3=""));"";WENN(UND(G2=$S$2;I2=$U$2;G3=$S$3;I3=$U$3);2;WENN(ODER(UND(G2=$S$2;I2=$U$2);UND(G3=$S$3;I3=$U$3));1;0)))
J4 : =WENN(ODER(ODER($S$2="";$U$2="");ODER($S$3="";$U$3=""));"";WENN(UND(J2=$S$2;L2=$U$2;J3=$S$3;L3=$U$3);2;WENN(ODER(UND(J2=$S$2;L2=$U$2);UND(J3=$S$3;L3=$U$3));1;0)))
M4 : =WENN(ODER(ODER($S$2="";$U$2="");ODER($S$3="";$U$3=""));"";WENN(UND(M2=$S$2;O2=$U$2;M3=$S$3;O3=$U$3);2;WENN(ODER(UND(M2=$S$2;O2=$U$2);UND(M3=$S$3;O3=$U$3));1;0)))
P4 : =WENN(ODER(ODER($S$2="";$U$2="");ODER($S$3="";$U$3=""));"";WENN(UND(P2=$S$2;R2=$U$2;P3=$S$3;R3=$U$3);2;WENN(ODER(UND(P2=$S$2;R2=$U$2);UND(P3=$S$3;R3=$U$3));1;0)))
S4 : =MAX(D4:R4)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Bild


Betrifft: AW: ..brauchen nicht mehr Informationen...:-) ...o.T. von: Hübi
Geschrieben am: 16.02.2005 19:12:01

Hi Andre,

ist ja toll - stellst dich mit "Kaum Excel/VBA-Kenntnisse" vor, hast alle Voraussetzungen zur Visualisierung deines Problems und lässt uns raten.

Meinen Beitrag habe ich geleistet ;-))))

FF

Gruß Hübi


Bild


Betrifft: AW: ..brauchen nicht mehr Informationen...:-) ...o.T. von: Andre
Geschrieben am: 16.02.2005 19:15:16

Ja, das ist in meinen Augen auch noch net viel...! ;)

Für mich stellt sich V4 als Problem dar, in dem EIN oder MEHRERE Gewinner angezeigt werden sollen. Von Matrixformeln hab ich keinen schimmer. Letztendlich müssten hier in diesem Beispiel Spieler 1 und Spieler 4 als Sieger stehen. Das bekomm ich nicht hin =(


Bild


Betrifft: AW: mehrere Sieger ermitteln von: Hübi
Geschrieben am: 16.02.2005 18:40:51

Hi Andre,

ganz einfach mit Rang
Tabelle1
 ABC
1NamePunktePlatz
2Jan145
3Feb251
4Mrz183
5Apr127
6Mai232
7Jun174
8Jul510
9Aug89
10Sep98
11Okt145
Formeln der Tabelle
C2 : =RANG(B2;$B$2:$B$11)
C3 : =RANG(B3;$B$2:$B$11)
C4 : =RANG(B4;$B$2:$B$11)
C5 : =RANG(B5;$B$2:$B$11)
C6 : =RANG(B6;$B$2:$B$11)
C7 : =RANG(B7;$B$2:$B$11)
C8 : =RANG(B8;$B$2:$B$11)
C9 : =RANG(B9;$B$2:$B$11)
C10 : =RANG(B10;$B$2:$B$11)
C11 : =RANG(B11;$B$2:$B$11)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hübi


Bild


Betrifft: AW: mehrere Sieger ermitteln von: HermannZ
Geschrieben am: 16.02.2005 18:46:39

Hallo AndRe,

meinst du so etwas???

Beispiel;

Rang
 ABCDEFGH
37        
381.) niedrigste Punktzahl gleich höchster Rang       
392.) niedrigste Punktzahl gleich erster Rang       
40NamenPunkte1.)1.) sortiert1.) Name2.)2.) sortiert2.) Name
41Werner1066Klaus11Klaus
42Klaus1066Werner11Werner
43Reiner1435Sascha42Sascha
44Josef1435Rick42Rick
45Rick1254Rudi23Rudi
46Sascha1254Detlef23Detlef
47Detlef1343Josef34Josef
48Hans1523Reiner54Reiner
49Günter1522Günter55Günter
50Max1612Hans65Hans
51Udo1611Udo66Udo
52Rudi1341Max36Max
53        
Formeln der Tabelle
C41 : {=SUMME(WENN(WENN(ISTZAHL($B$41:$B$52)*(ZÄHLENWENN(INDIREKT("B41:B"&ZEILE($41:$52));B$41:B$52)=1);$B$41:$B$52;MIN($B$41:$B$52)-1)>B41;1))+1}
D41 : =KGRÖSSTE($C$41:$C$52;ZEILE(A1))
E41 : {=INDIREKT("A"&VERGLEICH(KKLEINSTE(B$41:B$52-ZEILE(B$41:B$52)/1000;ZEILE(A1));B$41:B$52-ZEILE(B$41:B$52)/1000;0)+ZEILE($A$40))}
F41 : {=(SUMME(WENN(WENN(ISTZAHL($B$41:$B$52)*(ZÄHLENWENN(INDIREKT("B39:B"&ZEILE($41:$52));B$41:B$52)=1);$B$41:$B$52;MIN($B$41:$B$52)-1)<B41;1))+1)-(SUMME(1/ZÄHLENWENN($B$41:$B$52;$B$41:$B$52)))}
G41 : =KKLEINSTE($F$41:$F$52;ZEILE(A1))
H41 : {=INDIREKT("A"&VERGLEICH(KKLEINSTE(B$41:B$52-ZEILE(B$41:B$52)/1000;ZEILE(A1));B$41:B$52-ZEILE(B$41:B$52)/1000;0)+ZEILE($A$40))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hermann


Bild


Betrifft: Ich kann nicht glauben das .... von: ransi
Geschrieben am: 16.02.2005 18:54:03

hallo

...ihr aus so einer Fragestellung solche Formeln ableitet.
(Die von Hermann ist saugut)
Wenn mit den Vorschlägen die Lösung erarbeitet ist, solltet ihr es mal mit Lotto
versuchen.
Garantiert 6 Richtige...

;-))

ransi


 Bild

Beiträge aus den Excel-Beispielen zum Thema "mehrere Sieger ermitteln"