Zählenwenn und Farbwerte

Bild

Betrifft: Zählenwenn und Farbwerte
von: BigWoelfi
Geschrieben am: 22.02.2005 23:43:15
Hallo,
die Anwendung von ZÄHLENWENN ist mir soweit klar.
Wie kann ich darauf abstellen, dass nur die Zellen gezählt werden, die keinen farblichen Hintergrund haben?
Wenn das nicht geht, wie kann ich einbinden, ob die Zellwerte ganz bestimmte Teilstrings enthalten, beispielsweise, ob das letzte Zeichen ein "X" ist?

Gruß, Wolfgang

Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: Heinz Ulm
Geschrieben am: 22.02.2005 23:48:39
Hallo Wolfgang,
hilft dir das weiter?
Tabelle1
 ABCD
13350069B9B
246465645BX45BX
31547122CZ2CZ
49325451A1A
51474451CZZ1CZZ
Formeln der Tabelle
C1 : =WENN(LÄNGE(B1)=2;LINKS(B1;1);TEIL(B1;1;WENN(UND(CODE(TEIL(B1;3;1))<=57;CODE(TEIL(B1;3;1))>=48);3;WENN(UND(CODE(TEIL(B1;2;1))<=57;CODE(TEIL(B1;2;1))>=48);2;1))))*1
D1 : =RECHTS(B1;LÄNGE(B1)-LÄNGE(C1))
C2 : =WENN(LÄNGE(B2)=2;LINKS(B2;1);TEIL(B2;1;WENN(UND(CODE(TEIL(B2;3;1))<=57;CODE(TEIL(B2;3;1))>=48);3;WENN(UND(CODE(TEIL(B2;2;1))<=57;CODE(TEIL(B2;2;1))>=48);2;1))))*1
D2 : =RECHTS(B2;LÄNGE(B2)-LÄNGE(C2))
C3 : =WENN(LÄNGE(B3)=2;LINKS(B3;1);TEIL(B3;1;WENN(UND(CODE(TEIL(B3;3;1))<=57;CODE(TEIL(B3;3;1))>=48);3;WENN(UND(CODE(TEIL(B3;2;1))<=57;CODE(TEIL(B3;2;1))>=48);2;1))))*1
D3 : =RECHTS(B3;LÄNGE(B3)-LÄNGE(C3))
C4 : =WENN(LÄNGE(B4)=2;LINKS(B4;1);TEIL(B4;1;WENN(UND(CODE(TEIL(B4;3;1))<=57;CODE(TEIL(B4;3;1))>=48);3;WENN(UND(CODE(TEIL(B4;2;1))<=57;CODE(TEIL(B4;2;1))>=48);2;1))))*1
D4 : =RECHTS(B4;LÄNGE(B4)-LÄNGE(C4))
C5 : =WENN(LÄNGE(B5)=2;LINKS(B5;1);TEIL(B5;1;WENN(UND(CODE(TEIL(B5;3;1))<=57;CODE(TEIL(B5;3;1))>=48);3;WENN(UND(CODE(TEIL(B5;2;1))<=57;CODE(TEIL(B5;2;1))>=48);2;1))))*1
D5 : =RECHTS(B5;LÄNGE(B5)-LÄNGE(C5))
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =RECHTS(A1;1)="X"Abc
B11. / Formel ist =RECHTS(B1;1)="X"Abc
C11. / Formel ist =RECHTS(C1;1)="X"Abc
D11. / Formel ist =RECHTS(D1;1)="X"Abc
A21. / Formel ist =RECHTS(A2;1)="X"Abc
B21. / Formel ist =RECHTS(B2;1)="X"Abc
C21. / Formel ist =RECHTS(C2;1)="X"Abc
D21. / Formel ist =RECHTS(D2;1)="X"Abc
A31. / Formel ist =RECHTS(A3;1)="X"Abc
B31. / Formel ist =RECHTS(B3;1)="X"Abc
C31. / Formel ist =RECHTS(C3;1)="X"Abc
D31. / Formel ist =RECHTS(D3;1)="X"Abc
A41. / Formel ist =RECHTS(A4;1)="X"Abc
B41. / Formel ist =RECHTS(B4;1)="X"Abc
C41. / Formel ist =RECHTS(C4;1)="X"Abc
D41. / Formel ist =RECHTS(D4;1)="X"Abc
A51. / Formel ist =RECHTS(A5;1)="X"Abc
B51. / Formel ist =RECHTS(B5;1)="X"Abc
C51. / Formel ist =RECHTS(C5;1)="X"Abc
D51. / Formel ist =RECHTS(D5;1)="X"Abc
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Heinz
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: BigWoelfi
Geschrieben am: 23.02.2005 00:12:16
Hallo Heinz,
nicht wirklich.
In Spalte A stehen die Wochentage für den Tag aus Spalte B. Da es feste und bewegliche Feiertage gibt, steht in Spalte A, über Formel automatisch generiert, hinter den Wochentagen ein "X". Beispiel: "MoX".
Über bedingte Formatierung werden die Tage in B farblich gekennzeichnet, die entweder Wochenende oder Feiertage sind. Das funktioniert auch gut so und die integrierte Programmierung stellt jetzt voll auf dieses System ab.
Ich möchte jetzt ermitteln, wie viel tatsächliche Arbeitstage im Monat übrig bleiben und kann zum Beispiel mit
=ZÄHLENWENN(A10:A40;"Sa")+ZÄHLENWENN(A10:A40;"So")
die Tage ermitteln, die nicht mitgezählt werden sollen.
Mir wäre es aber lieber, die Tage genau anders herum ermitteln zu können, nämlich genau die Tage, die nicht Wochenende sind.
Irgend wie krieg ich das aber nicht hin, in die Formel einzubauen, dass nur die Tage gezählt werden sollen, die in A nicht "Sa", "So" oder von Rechts das erste Zeichen ein "X" haben, weil ich in diee Formel einfach kein Gleichheitszeichen oder <> eingeben kann. Da kommt immer "Fehler in Formel", ohne dass ich erkennen kann, worin der Fehler besteht.
Das Einfachste wäre, wenn ich den Farbwert der Zellen abfragen und in die Zählenwenn-Funktion einbauen könnte. Also alle Zellen im Bereich zählen, die keinen farblichen Hintergrund haben. Dann bräuchte ich die Inhalte selbst überhaupt nicht abfragen.
Ich habe schon lange im Archiv gesucht, bin aber leider nicht fündig geworden.
Gruß, Wolfgang
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: Hübi
Geschrieben am: 23.02.2005 00:31:03
Hi Wolfgang,
würde denn nicht die Fkt. NETTOARBEITSTAGE() diese Aufgabe besser erfüllen?
Musst vorher die Analyse-Funktionen als Add-In aktivieren.
Gruß Hübi
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: BigWoelfi
Geschrieben am: 23.02.2005 00:43:39
Hallo Hübi,
das habe ich mir gerade angeschaut. Da muss man aber die ganzen Feiertage manuell angeben, die nicht mitgezählt werden sollen. Für die festen Feiertage geht das ja noch. Die beweglichen Feiertage müsste man dann ja jedes Jahr separat anpassen, weil man ja nicht im voraus so ohne weiteres weiß, in welche Monae die Feiertage konkret fallen.
Ich weiß natürlich, wie ich diese Feiertage berechnen kann und benutze das auch ja auch für die Einfügung des "X" hinter den Wochentagsbezeichnungen. Das ist aber eine andere Baustelle.
Gruß, Wolfgang
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: Hübi
Geschrieben am: 23.02.2005 00:53:36
Hi Wolfgang,
da die beweglichen Feiertage am Ostersonntag hängen, ist das kein Problem. Findest hier im Forum massenhaft Lösungen. Oder schaust bei Excelformeln http://www.excelformeln.de/formeln.html?welcher=3 nach.
Gruß Hübi
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: BigWoelfi
Geschrieben am: 23.02.2005 01:03:08
Hübi,
hast du sicher übersehen:
Ich weiß, wie ich Ostersonntag berechnen kann und benutze es auch.
Gruß, Wolfgang
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: Heinz Ulm
Geschrieben am: 23.02.2005 00:56:28
Hallo Wolfgang,
schau dir mal diese Tabelle an, sie berechnet automatisch alle Feiertage für Baden Würtemberg, Feiertage in anderen Bundesländer musst du halt analog eingeben.
https://www.herber.de/bbs/user/18556.xls

Gruß Heinz
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: Heinz Ulm
Geschrieben am: 23.02.2005 01:03:14
Hallo Wolfgang,
korrigierte jahresfeiertagtabelle ist hier:
https://www.herber.de/bbs/user/18557.xls

Gruß Heinz
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: Heinz Ulm
Geschrieben am: 23.02.2005 00:46:31
Hallo Wolfgang,
mal ein anderer Ansatz mit
=Nettoarbeitstage(Beginndatum;Enddatum;FreieTage)
Tabelle4
 ABCDE
101.01.2005SaXArbeitstage 
202.01.2005SoXJanuar20
303.01.2005Mo   
404.01.2005Di   
505.01.2005Mi   
606.01.2005Do Feiertage 
707.01.2005Fr 01.01.2005 
808.01.2005SaX06.01.2005 
909.01.2005SoXusw. 
1010.01.2005Mo   
1111.01.2005Di   
1212.01.2005Mi   
1313.01.2005Do   
1414.01.2005Fr   
1515.01.2005SaX  
1616.01.2005SoX  
1717.01.2005Mo   
1818.01.2005Di   
1919.01.2005Mi   
2020.01.2005Do   
2121.01.2005Fr   
2222.01.2005SaX  
2323.01.2005SoX  
2424.01.2005Mo   
2525.01.2005Di   
2626.01.2005Mi   
2727.01.2005Do   
2828.01.2005Fr   
2929.01.2005SaX  
3030.01.2005SoX  
3131.01.2005Mo   
3201.02.2005Di   
3302.02.2005Mi   
3403.02.2005Do   
Formeln der Tabelle
B1 : =A1
C1 : =WENN(WOCHENTAG(A1;2)>5;"X";WENN(ISTNV(VERGLEICH(A1;G:G;0));"";"X"))
A2 : =A1+1
B2 : =A2
C2 : =WENN(WOCHENTAG(A2;2)>5;"X";WENN(ISTNV(VERGLEICH(A2;G:G;0));"";"X"))
E2 : =nettoarbeitstage(A1;A31;D7:D8)
A3 : =A2+1
B3 : =A3
C3 : =WENN(WOCHENTAG(A3;2)>5;"X";WENN(ISTNV(VERGLEICH(A3;G:G;0));"";"X"))
A4 : =A3+1
B4 : =A4
C4 : =WENN(WOCHENTAG(A4;2)>5;"X";WENN(ISTNV(VERGLEICH(A4;G:G;0));"";"X"))
A5 : =A4+1
B5 : =A5
C5 : =WENN(WOCHENTAG(A5;2)>5;"X";WENN(ISTNV(VERGLEICH(A5;G:G;0));"";"X"))
A6 : =A5+1
B6 : =A6
C6 : =WENN(WOCHENTAG(A6;2)>5;"X";WENN(ISTNV(VERGLEICH(A6;G:G;0));"";"X"))
A7 : =A6+1
B7 : =A7
C7 : =WENN(WOCHENTAG(A7;2)>5;"X";WENN(ISTNV(VERGLEICH(A7;G:G;0));"";"X"))
A8 : =A7+1
B8 : =A8
C8 : =WENN(WOCHENTAG(A8;2)>5;"X";WENN(ISTNV(VERGLEICH(A8;G:G;0));"";"X"))
A9 : =A8+1
B9 : =A9
C9 : =WENN(WOCHENTAG(A9;2)>5;"X";WENN(ISTNV(VERGLEICH(A9;G:G;0));"";"X"))
A10 : =A9+1
B10 : =A10
C10 : =WENN(WOCHENTAG(A10;2)>5;"X";WENN(ISTNV(VERGLEICH(A10;G:G;0));"";"X"))
A11 : =A10+1
B11 : =A11
C11 : =WENN(WOCHENTAG(A11;2)>5;"X";WENN(ISTNV(VERGLEICH(A11;G:G;0));"";"X"))
A12 : =A11+1
B12 : =A12
C12 : =WENN(WOCHENTAG(A12;2)>5;"X";WENN(ISTNV(VERGLEICH(A12;G:G;0));"";"X"))
A13 : =A12+1
B13 : =A13
C13 : =WENN(WOCHENTAG(A13;2)>5;"X";WENN(ISTNV(VERGLEICH(A13;G:G;0));"";"X"))
A14 : =A13+1
B14 : =A14
C14 : =WENN(WOCHENTAG(A14;2)>5;"X";WENN(ISTNV(VERGLEICH(A14;G:G;0));"";"X"))
A15 : =A14+1
B15 : =A15
C15 : =WENN(WOCHENTAG(A15;2)>5;"X";WENN(ISTNV(VERGLEICH(A15;G:G;0));"";"X"))
A16 : =A15+1
B16 : =A16
C16 : =WENN(WOCHENTAG(A16;2)>5;"X";WENN(ISTNV(VERGLEICH(A16;G:G;0));"";"X"))
A17 : =A16+1
B17 : =A17
C17 : =WENN(WOCHENTAG(A17;2)>5;"X";WENN(ISTNV(VERGLEICH(A17;G:G;0));"";"X"))
A18 : =A17+1
B18 : =A18
C18 : =WENN(WOCHENTAG(A18;2)>5;"X";WENN(ISTNV(VERGLEICH(A18;G:G;0));"";"X"))
A19 : =A18+1
B19 : =A19
C19 : =WENN(WOCHENTAG(A19;2)>5;"X";WENN(ISTNV(VERGLEICH(A19;G:G;0));"";"X"))
A20 : =A19+1
B20 : =A20
C20 : =WENN(WOCHENTAG(A20;2)>5;"X";WENN(ISTNV(VERGLEICH(A20;G:G;0));"";"X"))
A21 : =A20+1
B21 : =A21
C21 : =WENN(WOCHENTAG(A21;2)>5;"X";WENN(ISTNV(VERGLEICH(A21;G:G;0));"";"X"))
A22 : =A21+1
B22 : =A22
C22 : =WENN(WOCHENTAG(A22;2)>5;"X";WENN(ISTNV(VERGLEICH(A22;G:G;0));"";"X"))
A23 : =A22+1
B23 : =A23
C23 : =WENN(WOCHENTAG(A23;2)>5;"X";WENN(ISTNV(VERGLEICH(A23;G:G;0));"";"X"))
A24 : =A23+1
B24 : =A24
C24 : =WENN(WOCHENTAG(A24;2)>5;"X";WENN(ISTNV(VERGLEICH(A24;G:G;0));"";"X"))
A25 : =A24+1
B25 : =A25
C25 : =WENN(WOCHENTAG(A25;2)>5;"X";WENN(ISTNV(VERGLEICH(A25;G:G;0));"";"X"))
A26 : =A25+1
B26 : =A26
C26 : =WENN(WOCHENTAG(A26;2)>5;"X";WENN(ISTNV(VERGLEICH(A26;G:G;0));"";"X"))
A27 : =A26+1
B27 : =A27
C27 : =WENN(WOCHENTAG(A27;2)>5;"X";WENN(ISTNV(VERGLEICH(A27;G:G;0));"";"X"))
A28 : =A27+1
B28 : =A28
C28 : =WENN(WOCHENTAG(A28;2)>5;"X";WENN(ISTNV(VERGLEICH(A28;G:G;0));"";"X"))
A29 : =A28+1
B29 : =A29
C29 : =WENN(WOCHENTAG(A29;2)>5;"X";WENN(ISTNV(VERGLEICH(A29;G:G;0));"";"X"))
A30 : =A29+1
B30 : =A30
C30 : =WENN(WOCHENTAG(A30;2)>5;"X";WENN(ISTNV(VERGLEICH(A30;G:G;0));"";"X"))
A31 : =A30+1
B31 : =A31
C31 : =WENN(WOCHENTAG(A31;2)>5;"X";WENN(ISTNV(VERGLEICH(A31;G:G;0));"";"X"))
A32 : =A31+1
B32 : =A32
C32 : =WENN(WOCHENTAG(A32;2)>5;"X";WENN(ISTNV(VERGLEICH(A32;G:G;0));"";"X"))
A33 : =A32+1
B33 : =A33
C33 : =WENN(WOCHENTAG(A33;2)>5;"X";WENN(ISTNV(VERGLEICH(A33;G:G;0));"";"X"))
A34 : =A33+1
B34 : =A34
C34 : =WENN(WOCHENTAG(A34;2)>5;"X";WENN(ISTNV(VERGLEICH(A34;G:G;0));"";"X"))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Kommst du so weiter?
Farben, die mit der Bedingten Formatierung eingestellt werden lassen sich nicht auslesen.
Gruß Heinz
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: BigWoelfi
Geschrieben am: 23.02.2005 01:10:46
Hallo Heinz,
deine Tabelle ist trotzdem ganz anders aufgebaut als meine. Das kann man so nicht übertragen, außer das hier:
nettoarbeitstage(A1;A31;D7:D8)
Hab eich gerade ausprobiert, da ich ja auf dem Datenblatt, wo jeder seine persönlichen Angaben anpassen kann, natürlich auch die Feiertagsauflistungen habe. Eine für feste Feiertage und eine für bewegliche, die natürlich auf der Gaußschen Formel zur Ermittlung des Ostersonntag beruhen.
Leider habe ich die Tabellen nebeneineinader stehen. Deshlab noch die Frage, bevor ich umbaue: Kann man bei "freie Tage" auch zwei Zellbereiche eingeben? Ansonsten funktioniert das prima, habe ich gerade ausprobiert.
Sollte es nicht mit mehreren Bereichsangaben gehen, bringe ich die Datumsangaben untereinander, dann kann ich einfach den Bereich anders angeben und fertig.
Gruß, Wolfgang
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: Heinz Ulm
Geschrieben am: 23.02.2005 01:21:49
Hallo Wolfgang,
ich habs gerade probiert ob ich die freien Tage nebeneinander in Sp. D und E eintragen kann, das klappte aber nicht. Entweder habe ich einen Fehler gemacht oder es geht wirklich nicht. Schreib halt die Feiertage untereinander wenn es dann bei dir klappt.
So nun gute Nacht, ich bin müde,
Bis morgen
Heinz
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: Hübi
Geschrieben am: 23.02.2005 01:28:09
Hi Wolfgang,
schau dir´s an
Tabelle1
 AB
1FeiertageSonstige fr. Tage
201.01.200518.02.2005
317.02.200518.10.2005
4  
5  
618 
Formeln der Tabelle
A6 : =NETTOARBEITSTAGE("1.2.05";"28.2.05";A2:B5)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Kannst natürlich auch Bereichs-Namen verwenden.
Gruß Hübi
Bild

Betrifft: AW: Zählenwenn und Farbwerte
von: BigWoelfi
Geschrieben am: 23.02.2005 01:36:16
Hallo Hübi,
das geht nicht so bei mir. Bei Dir ist das ja auch ein einziger zusammenhängender Bereich. Bei mir sieht das Tabellenblatt gaaaanz anders aus. Da stehen die Datumsangaben der beiden Kategorien nicht in Nachbarspalten, leider.
Ich füge die beiden Feiertagstabellen jetzt untereinander und gut ist.
Gute Nacht und Danke für die Anregungen. Thema ist gegessen.
Gruß, Wolfgang
 Bild

Beiträge aus den Excel-Beispielen zum Thema "dünnere Linien im Diagramm"