SUCHEN()

Bild

Betrifft: SUCHEN()
von: Regina
Geschrieben am: 14.03.2005 12:16:34
Hallo,
wie muss ich die Suchen-funktion verändern, dass sie nicht nur Werte aus dem ersten Feld (e2) findet? (Die Artikelliste ist natürlich länger und normalerweise in einem anderen Arbeitsblatt (aber der gleichen Datei).
https://www.herber.de/bbs/user/19627.xls
Danke im Voraus
Regina, gespannt auf Antworten wartend
P.S.: Ich fürchte, ich habe beim Hochladen Mist gebaut und die Datei mehrmals abgespeichert, weiß aber nicht, wie ich das korrigieren kann...

Bild

Betrifft: =WENN(ISTFEHLER(VERGLEICH(A2;E2:E5;0));"";"Artikel
von: MichaV
Geschrieben am: 14.03.2005 12:30:11
Hi,
versuch mal so.
Gruß!
Bild

Betrifft: AW: SUCHEN()
von: Bert
Geschrieben am: 14.03.2005 12:31:36
https://www.herber.de/bbs/user/19630.xls
Bert
Bild

Betrifft: =INDEX(D2:D5;VERGLEICH(A2&"*";E2:E5;0))
von: IngoG
Geschrieben am: 14.03.2005 12:46:36
Hallo Regina,
obige formel gibt Dir den ersten Wert aus spalte e zurück, der neben einem Eintrag steht, welcher mit dem inhalt von a2 anfängt.
in Deinem Beispiel also 10002
möchtest Du auch einträge finden, die den suchtext nur enthalten mußt Du die Formel:
=INDEX(D2:D5;VERGLEICH("*"&A2&"*";E2:E5;0))
benutzen
Gruß Ingo
Bild

Betrifft: AW: SUCHEN()
von: Gert Seler
Geschrieben am: 14.03.2005 12:54:07
Hallo Regina,
nimm folgende Funktion :
=ZÄHLENWENN(E2:E5;A2)
dann ist 0 das Ergebnis, wenn "GetriebeXYZ" da steht.
mfg
Gert
Bild

Betrifft: Lösung
von: Regina
Geschrieben am: 24.03.2005 18:02:29
Hallo,
ich bins nochmal. Der Vollständigkeit halber und weil mir Eure Tipps so klasse geholfen haben, hier meine Lösung (nur 'zählenwenn' hat dann doch nicht geklappt):
=WENN(ZÄHLENWENN(E2:E6;"*"&A2&"*")>0;"vorhanden";"nicht auf Lager")
https://www.herber.de/bbs/user/20134.xls
Nochmals Vielen Dank für Eure Unterstützung
Regina
Bild

Betrifft: AW: SUCHEN()
von: Regina
Geschrieben am: 14.03.2005 15:47:56
Hallo,
vielen Dank!!! (auf die Variante mit Zählenwenn hätte ich auch kommen können *schäm*)
Ich probiere alle Lösungen mal aus...
Regina
 Bild

Beiträge aus den Excel-Beispielen zum Thema "SUCHEN()"