mit sverweis mehre werte Mittelwert ?

Bild

Betrifft: mit sverweis mehre werte Mittelwert ? von: chris b
Geschrieben am: 16.03.2005 10:59:39

Hallo VBAprofis,
habe eine frage und zwar ist sowas mit Formel möglich Matrix und oder index oder sverweis?
und zwar habe ich folgende Datei.
In Spalte C stehen untereinander "Datums"

11.06.2004 15:44:17
11-Jun-04
12-Jun-04
12-Jun-04
12-Jun-04
usw...

und dazu in Spalte "D" stehen werte.

78,6828
78,991
78,5822
78,9604
usw...

ist es möglich das ich in einer anderen tabelle das datum eingebe in eine zelle und mir excel Automatisch aus tabelle1 die zellen mit dem datum absucht und aus den werten nebenan den Mittelwert bildet und in mir daneben in die Zelle schreibt?
Wäre super wenn ihr mir helfen könnt ! Vielen dank Christian

Bild


Betrifft: AW: mit sverweis mehre werte Mittelwert ? von: heikoS
Geschrieben am: 16.03.2005 11:14:11

Hallo Chris,

{=MITTELWERT(WENN(A1:A8=A11;B1:B8))} sollte es tun. In meinem Beispiel hatte ich in A1:A8 die Datumsangaben und in B1:B8 die Werte. Mußt Du natürlich noch anpassen.

Alternativ (ohne Matrix-Formel) einfach summewenn()/zählenwenn().


Gruß Heiko


Bild


Betrifft: AW: mit sverweis mehre werte Mittelwert ? von: chris b
Geschrieben am: 16.03.2005 11:20:02

Das isses vielen Dank !


Bild


Betrifft: Freut mich. Danke für die Rückmeldung. oT von: heikoS
Geschrieben am: 16.03.2005 11:21:38




Bild


Betrifft: AW: Doch noch ein problem damit von: chris b
Geschrieben am: 16.03.2005 11:51:36

Hallo hat mir wirklich super geholfen ,
aber ein Problem habe ich jetzt doch noch :(

Bei mir in den zellen untereinander stehen ja viele Datums.
Und das ist das Problem in den Zellen steht
12.06.2004 07:44:34
12.06.2004 07:43:34
13.06.2004 07:14:34
usw..
Jetzt muss ich bei dem datum das ich in die zelle eingeba das gesucht werden soll alle mit eingeben das soll aber nicht so genau auf die Uhrzeit schauen sondern den Kompletten tag nicht auf min uten usw.. unterteilt.
geht das auuch noch?


Bild


Betrifft: AW: Doch noch ein problem damit von: heikoS
Geschrieben am: 16.03.2005 12:26:33

Hallo Chris,

wir kriegen das noch hin...

{=MITTELWERT(WENN(TEXT(A1:A8;"TT.MM.JJJJ")=TEXT(A11;"TT.MM.JJJJ");B1:B8))}


Gruß Heiko


Bild


Betrifft: AW: Doch noch ein problem damit von: chris b
Geschrieben am: 16.03.2005 14:12:59

Sau geil also noch mal wunderbar :)
habe zwar jetzt schon ein Makro geschrieben das mir alle zaheln umwandelt aber so ists noch besser !!

danke Dir grüße Christian


Bild


Betrifft: :-) freut mich! oT von: heikoS
Geschrieben am: 16.03.2005 14:16:17




Bild


Betrifft: AW: :-) freut mich! oT von: chris b
Geschrieben am: 16.03.2005 14:29:31

Sorry noch mal :(
Hallo habe schon wieder eine frage dazu, aber dann ist schluss ich versprechs :)
Und zwar ist es möglich in diese Formel noch eine "istfehler" abfrage einzubauen so das wenn in der zelle stehen würde #DIV/0! das dann gar nichts in der zelle steht also diese Leer bleibt ?

Danke nochmals !


Bild


Betrifft: Warum hatte ich da bereits drauf gewartet? ;-) von: heikoS
Geschrieben am: 16.03.2005 14:55:18

Hallo Christian,

die Antwort ist: "Ja!"

{=WENN(ISTFEHLER(MITTELWERT(WENN(TEXT(A1:A8;"TT.MM.JJJJ")=TEXT(A11;"TT.MM.JJJJ");B1:B8)));"";MITTELWERT(WENN(TEXT(A1:A8;"TT.MM.JJJJ")=TEXT(A11;"TT.MM.JJJJ");B1:B8)))}

Allerdings kann ich den #DIV/0-Fehler nur generieren, wenn alle zugehörigen Zellen mit Text gefüllt sind. Datenstruktur?


Gruß Heiko


Bild


Betrifft: AW: Warum hatte ich da bereits drauf gewartet? ;-) von: chris b
Geschrieben am: 16.03.2005 15:13:20

Heiko du bist spitze !!!!!!!!!
Vielen Dank und noch nen schönen Tag :)


Bild


Betrifft: Danke, gleichfalls. oT von: heikos
Geschrieben am: 16.03.2005 16:19:01




 Bild

Beiträge aus den Excel-Beispielen zum Thema "mit sverweis mehre werte Mittelwert ?"