Der Wurm ist drin/ Verweis klappt nicht mehr

Bild

Betrifft: Der Wurm ist drin/ Verweis klappt nicht mehr von: Martin
Geschrieben am: 17.03.2005 19:59:55

Hallo nochmal,

verstehe es nicht, eben hat es noch funktioniert, jetzt nicht mehr. Habe einen Verweis:

=VERWEIS(D2;$D8:$D20000;E8:E20000)

In d2 steht ein wert. ich möchte den wert angezeigt bekommen, der in der zelle neben der steht, die ebenfalls die zahl mit dem wert der zelle d2 hat.

Muss doch gehen, oder nicht?.

Martin

Bild


Betrifft: AW: eigentlich ja, aber ist es beabsichtigt,... von: Luc :-?
Geschrieben am: 17.03.2005 21:59:47

...Martin,
dass nach Vgl mit D2 in der nächsten Formelzelle (falls die Formel mehrfach verwendet wird) dann mit D3 oder E2 vgl wird und sich dann der Ergebnisbereich auf E9:E20001 bzw F8:F20000 verschiebt. Ansonsten funktioniert es so, dass, wenn der Wert von D2 zwischen D8 und D20000 gefunden wird, der Wert aus E mit der gleichen Zeile wie der gefundene Wert in D zurückgegeben wird.
Gruß Luc :-?


Bild


Betrifft: AW: eigentlich ja, aber ist es beabsichtigt,... von: Martin
Geschrieben am: 18.03.2005 07:13:10

Jein,

habe in der richtigen Version an den wichtigen Stellen die $Zeichen gesetzt. Da verschiebt sich nix. Aber Danke trotzdem

Martin


Bild


Betrifft: AW: Der Wurm ist drin/ Verweis klappt nicht mehr von: Boris
Geschrieben am: 17.03.2005 22:28:45

Hi Martin,

bei Verwendung der Funktion VERWEIS muss die Suchspalte (D8:D20000) aufsteigend sortiert sein. Ist das der Fall?

Grüße Boris


Bild


Betrifft: AW: Der Wurm ist drin/ Verweis klappt nicht mehr von: Martin
Geschrieben am: 18.03.2005 07:15:43

Hallo Boris,

vielen Dank für deine ANtwort, ich denke das war der Fehler. habe nur ein Problem: der Wert in der Formel wird zusammengesetzt aus mehreren Zellen, also steht eine Formel drin. Sind die Zellen aus denen ich die Zelle zusammensetzen lasse leer, erscheint natürlich automatisch die 0.

Greetz,

Martin


Bild


Betrifft: Versteh ich nicht... von: Boris
Geschrieben am: 18.03.2005 09:16:56

Hi Martin,

...lad mal ein kleines Beispiel hoch.
Vermutlich bist du mit dem SVERWEIS besser aufgehoben.

Grüße Boris


Bild


Betrifft: AW: Versteh ich nicht... von: Martin
Geschrieben am: 18.03.2005 09:56:27

Hallo Boris,

hab die wirkliche Datei jetzt leider nicht hier, hab aber eine nachgebaut, die im Prinzip so ist. In den farbigen Zellen wird eingegeben, die Zelle daneben wird berechnet und soll dann gesucht werden. Der daneben stehende Datensatz soll in Zeile 1 angezeigt werden.

https://www.herber.de/bbs/user/19821.xls


Danke schonmal,

liebe Grüße,

Martin


Bild


Betrifft: Sag ich doch - SVERWEIS von: Boris
Geschrieben am: 18.03.2005 10:11:55

Hi Martin,

in E1: =SVERWEIS($D$1;$D$5:$F$18;2;)
in F1: =SVERWEIS($D$1;$D$5:$F$18;3;)

Grüße Boris


Bild


Betrifft: Geil! Das funzt. Danke dir!! o.T. von: Martin
Geschrieben am: 18.03.2005 10:25:23




 Bild

Beiträge aus den Excel-Beispielen zum Thema "Der Wurm ist drin/ Verweis klappt nicht mehr"