knifflige wenn-funktion

Bild

Betrifft: knifflige wenn-funktion
von: Pascal Zotto
Geschrieben am: 20.03.2005 12:18:45
hi,
wollte nur nochmal auf mein problemchen aufmerksam machen, da hat sich noch keine lösung gefunden...
siehe link:
https://www.herber.de/forum/archiv/584to588/t584058.htm
gruß,
pascal

Bild

Betrifft: AW: knifflige wenn-funktion
von: Boris
Geschrieben am: 20.03.2005 13:33:26
Hi Pascal,
schilder doch noch mal bitte genau dein Problem und zudem die gewünschte Lösung (anhand deiner bereits hochgeladenen Beispieltabelle).
Grüße Boris
Bild

Betrifft: AW: knifflige wenn-funktion
von: Pascal Zotto
Geschrieben am: 20.03.2005 20:00:37
hi boris,
also:
beispieltabelle
https://www.herber.de/bbs/user/19539.xls
problem:
in spalte b stehen 3 vorgaben: EA, KA, BK
in spalte c fortlaufende nummern (steigerung 1)... jeweils für EA, KA, oder BK
es kann auch vorkommen dass ein paar mal hintereinander ein EA, KA oder BK die gleiche nummer in spalte c hat. (wenn der wert in spalte d aus mehreren werten besteht, werden diese aufgeschlüsselt indem dann einfach zb: ea 2 =y; ea 2 =x; ea 2 =z; angeführt wird.
die nummern sind tabellenübergreifend fortlaufend.
kann man das nun automatisieren?
in der art dass xl immer vergleicht...
=wenn(spalte b="";"";
sonst vergleichen ob EA, KA, BK und für die jeweilige bezeichnung dann die letzte verfügbare nummer (spalte c) in der aktuellen , oder falls nicht vorhanden aus der letzten tabelle, wo die bezeichnung zuletzt verwendet wurde, suchen und mit +1 einfügen.
falls also tab2 begonnen wird und die endwerte in tab1 von EA 5 BK 6 KA 2 wären, so werden die sich nicht mehr ändern und excel soll aus tabelle1 rauslesen welche endwerte EA, BK und KA haben und die dann in tab1 weiter führen... beginnwerte von tab2 wären also EA 6, BK 7 und KA 3... und das bei jeder tabelle; die ersten werte immer mit den letzten der vorherigen tabelle vergleichen...
wobei es nicht abzusehen ist, wieviele EA, BK oder KA es auf jeder tabelle geben wird, und in welcher reihenfolge (mit reihenfolge mein ich EA, BK, EA, EA, BK, KA, und nicht die zahlenreihenfolge dahinter, die ist immer aufsteigend oder in seltenen fällen gleich hintereinander gleichbleibend)
zählenwenn funzt aus oben genannten gründen nicht, horst hat gemeint das ganze wäre vielleicht mit einer pivotauswertung zu lösen!?
gruß,
pascal
Bild

Betrifft: AW: knifflige wenn-funktion
von: Boris
Geschrieben am: 21.03.2005 17:28:53
Hi Pascal,
ich seh auch nur die Möglichkeit der ZÄHLENWENN-Funktion - allerdings musst du sie in jeder Tabelle noch etwas erweitern.
Im Beispiel in Tabelle1, C1:
=ZÄHLENWENN(B$1:B1;B1)
und runterkopieren.
In Tabelle2, C1:
=ZÄHLENWENN(B$1:B1;B1)+ZÄHLENWENN(Tabelle1!B:B;B1)
und ebenfalls runterkopieren.
Wenn noch mehr Tabellen dazukommen: Immer nach dem gleichen Muster erweitern.
Grüße Boris
Bild

Betrifft: AW: knifflige wenn-funktion
von: Pascal Zotto
Geschrieben am: 22.03.2005 00:06:40
hi boris,
das problem bei zählenwenn ist dass wenn ein code für eine zahl aus spalte d, in spalte c mehrmals die gleiche zahl hat, dann ist der wert nicht mehr richtig. da zählenwenn ja alle zellen mit dem bestimmten code zählt...
gruß
pascal
Bild

Betrifft: Du sprichst immer von Spalte D...
von: Boris
Geschrieben am: 22.03.2005 08:51:44
Hi Pascal,
...ich hab nur das Problem, dass ich in deiner Beispieldatei die Spalte D überall nur leer ist...
Bezogen auf dein hochgeladenes Beispiel funktioniert meine Lösung einwandfrei...
Also: Schilder Dein Problem in Gänze und ergänze Dein Beispiel entsprechend.
Grüße Boris
Bild

Betrifft: AW: Du sprichst immer von Spalte D...
von: Pascal Zotto
Geschrieben am: 22.03.2005 10:45:24
hi boris,
naja, es ist nicht wichtig was in spalte d steht, sondern nur dass was da steht... aber hier die erweiterte datei:
https://www.herber.de/bbs/user/19985.xls
gruß
pascal
Bild

Betrifft: Ich kapier es nicht...
von: Boris
Geschrieben am: 22.03.2005 16:23:29
Hi Pascal,
...sorry. Das ist wohl zu hoch für mich. Warum ist Spalte D plötzlich unwichtig?...
Grüße Boris
Bild

Betrifft: AW: Ich kapier es nicht...
von: Pascal Zotto
Geschrieben am: 22.03.2005 16:52:27
hi boris,
spalte d war nur eine nebeninfo um zu erklären wieso in spalte c die zahl zum code in spalte b mehrmals hintereinander vorkommen kann. spielt aber für die lösung des probs keine rolle. für die lösung benötigen nur spalten b + c
gruß
pascal
Bild

Betrifft: In welchen Fällen kann es denn sein,...
von: Boris
Geschrieben am: 22.03.2005 18:20:52
Hi Pascal,
...dass sich die Werte in Spalte C NICHT um 1 erhöhen? In deiner Beispieldatei ist das z.B. in Tabelle2, C13:C15 der Fall. Ich seh die Logik dahinter noch nicht...
Grüße Boris
Bild

Betrifft: AW: In welchen Fällen kann es denn sein,...
von: Pascal Zotto
Geschrieben am: 22.03.2005 18:36:40
hi boris,
das ist im vorhinein nicht zu berechnen, das merkt man immer erst bei der eingabe der werte in spalte d. es kann sein, dass es auf einer tabelle gar nicht vorkommt, aber andererseits dass es mehrmals passiert. in der beispieltabelle zb nur einmal in tab2 von c13:c15. wenn eine logik dahinter wäre, wäre es viel einfacher... ;-)
das ist es ja was das ganze so schwierig macht...

gruß,
pascal
Bild

Betrifft: Du willst eine Formel für Spalte B...
von: Boris
Geschrieben am: 22.03.2005 22:24:11
Hi Pascal,
...aber hinter der Formel steckt keine Logik - sorry, da muss ich passen...
Grüße Boris
Bild

Betrifft: Meinte natürlich Spalte C...OT
von: Boris
Geschrieben am: 22.03.2005 22:25:17

 Bild

Beiträge aus den Excel-Beispielen zum Thema "knifflige wenn-funktion"