Summierung ohne grau formatierte Schrift

Bild

Betrifft: Summierung ohne grau formatierte Schrift von: mykey
Geschrieben am: 24.03.2005 09:51:46

Schönen guten Morgen,

kann mir jemand einen Tipp geben wie bei einer summierung einer Spalte der grau formatierte text nicht mit einberechnet wird ?

Tabelle habe ich angehängt.
https://www.herber.de/bbs/user/20115.xls


Danke im Vorraus

Bild


Betrifft: AW: Summierung ohne grau formatierte Schrift von: =Peter=
Geschrieben am: 24.03.2005 10:03:32

Hallo ?,

eine Möglichkeit:

Einfügen - Name - Definieren - Name in der Arbeitsmappe: 'Schrift' - bezieht sich auf:

=ZELLE.ZUORDNEN(24;INDIREKT("ZS(-1)";FALSCH))

- [Hinzufügen] - OK

Wenn du nun die folgende Formel eingibst wird die Schriftfarbe der jeweils links davon stehenden Zelle ausgegeben:

=Schrift

Mit der Formel

=SUMMEWENN(D9:D22;15;C9:C22)

kannst du jetzt die Zahlen die grau formatiert sind addieren.

HTH
Gruss
Peter


Bild


Betrifft: AW: Korrektur von: =Peter=
Geschrieben am: 24.03.2005 10:18:34

Hallo

ich habe überlesen, dass die grauen Zahlen _nicht_ mit einberechnet werden sollen. Um das zu erreichen musst du die Formel geringfügig ändern:

=SUMMEWENN(D9:D22;"<>15";C9:C22)

HTH
Gruss
Peter


Bild


Betrifft: AW: Summierung ohne grau formatierte Schrift von: mykey
Geschrieben am: 24.03.2005 10:48:11

Moin moin,

Das mit dem Namen definieren klappt nicht ... er summiert nicht richtig.
Die Tabelle die ich erstellt habe ist nur ein Beispiel.
Ausschlaggebend ist die Schriftfarbe ... anhand dieser soll Excel die Summe in Spalte C zusammenrechnen.

Nur zum Verständniss:
was bedeutet INDIREKT("ZS(-1)";FALSCH) beim Namen definieren ???
Soviel wie "Zeile - Spalte Minus 1" ?

Das mit dem Makro habe ich noch nicht ausprobiert. :)


Bild


Betrifft: Dann probiers doch mit dem Makro :( von: Philipp
Geschrieben am: 24.03.2005 11:01:10

...anstatt die Frage offen zu halten.


Bild


Betrifft: AW: Summierung ohne grau formatierte Schrift von: =Peter=
Geschrieben am: 24.03.2005 11:22:02

Hallo

bei mir klappt es problemos. Hast du auch meine Korrektur beachtet? Ich bin zunächst von einer falschen Voraussetzung (nur die grauen Werte sollen addiert werden) ausgegangen.

Bei der Funktion Zelle.Zuordnen handelt es sich um Excel4-Makros.

Nachdem ich aber die Lösung von Hermann gesehen habe würde ich an deiner Stelle diese benutzen.

HTH
Gruss
Peter


Bild


Betrifft: AW: Summierung ohne grau formatierte Schrift von: Philipp
Geschrieben am: 24.03.2005 10:07:32

Hallo,

ich hab dir mal ein kleines Makro geschrieben, mit dem es auch funktioniert:


Sub sum()
startzeile = 9
endzeile = 22
summe = 0
For i = startzeile To endzeile
 If Range("C" & i).Font.ColorIndex <> 15 Then
  summe = summe + Range("C" & i).Value
 End If
Next i
 Range("C" & endzeile + 1).Value = summe
End Sub



Ich hoffe es klappt bei Dir!
Rückmeldung nicht vergessen...

Bis dann
Philipp


Bild


Betrifft: AW: Summierung ohne grau formatierte Schrift von: HermannZ
Geschrieben am: 24.03.2005 10:21:19

Hallo mykey,

oder du nimmst eine Funktion mit der du alle farben benutzen kannst ohne jeweils die farbcode Nr. suchen zu müssen.Alles weitere siehst du imm Beispiel,


https://www.herber.de/bbs/user/20117.xls

Gruß Hermann


Bild


Betrifft: AW: Summierung ohne grau formatierte Schrift von: mykey
Geschrieben am: 24.03.2005 11:21:37

SUBBI !!!

Yessa !

Danke Herrmann !

Das funktioniert bombig ;D


Bild


Betrifft: AW:Danke für die Rückantwort oT. von: HermannZ
Geschrieben am: 24.03.2005 11:25:05

.


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summierung ohne grau formatierte Schrift"