Microsoft Excel

Herbers Excel/VBA-Archiv

Zufallszahlen

Betrifft: Zufallszahlen von: Stefan Schumann
Geschrieben am: 18.11.2007 18:42:04

Hallo zusammen,

in A1:A1000 steht jeweils die Funktion =KÜRZEN(ZUFALLSZAHL();2)

In B1:B100 steht 0,00 | 0,01 | 0,02 | ... | 0,99 und 1,00

in C1:C100 steht =ZÄHLENWENN($A$1:$A$1000;B1), also die Anzahlen der Zufallszahlen von 0 bis 1 in 0,01er Schritten.

Wenn ich nun die Taste F9 für die Neuberechnung drücke und gedrückt halte fällt mir auf, dass der größte ermittelte Zufallswert 0,81 ist. Ich habe mir ein entsprechendes Säulendiagramm gemacht und die Werte darin dargestellt. Bei mir gibt es keinen größeren Zufallswert als die 0,81.

Woran kann das liegen?

Danke für Hinweise.

Gruß,

Stefan

  

Betrifft: AW: Zufallszahlen von: Lars
Geschrieben am: 18.11.2007 19:03:59

Hi,

nicht nachvollziehbar. Allerdings wird 1 nie erreicht, aber das ist ja klar.

mfg Lars


  

Betrifft: AW: Zufallszahlen von: Daniel
Geschrieben am: 18.11.2007 19:18:59

HI
kann eigentlich nicht sein
ich habs mal getestet mit 30.000 werten und da kommt jede deiner Zahlen mit ner Verteilung zwischen 1,05% und 0,95% vor, so wie es sein sollte, auch die 0,99

das einzige was sein könnte ist, da die Funtkion ZÄHLENWENN relativ langsam ist, du Excel nicht fertig rechnen lässt und die Berechnung vorzeitig abbrichst, bevor allen ZählenWenn-Formeln abgearbeitet sind
die fehlenden haben dann natürlich den Wert 0

mach zum Testen mal lieber viele Zufallszahlen (10000 oder mehr), fixire die Werte aber durch Kopiern Inhalte einfügen - Werte, und mach dann erst die auswertung mit Zählenwenn.
So hat ZählenWenn genügend Zeit, die Werte auszuwerten und muß nicht ständig mit sich ändernden Daten rumärgern

Gruß, Daniel


 

Beiträge aus den Excel-Beispielen zum Thema "Zufallszahlen"