Microsoft Excel

Herbers Excel/VBA-Archiv

Zufallszahl, speziell

Betrifft: Zufallszahl, speziell von: René C.
Geschrieben am: 23.01.2008 15:07:14

Hallo,

Ich möchte in meiner Exceltabelle für eine Rechnung eine Zufallszahl berechnen lassen. Diese Zufallszahl muss positiv sein und zwischen 0 und 8 liegen und sollte ca. 2-3 Kommazellen haben. Ich müsste die Formel aber so haben, dass ich den Maximalwert jederzeit ändern könnte also den Zufallszahlenbereich auf auf 0 bis 10 oder 0 bis 12 Ändern könnte.

mfg
WHC

  

Betrifft: AW: Zufallszahl, speziell von: Ramses
Geschrieben am: 23.01.2008 15:19:17

Hallo

probiers mal so

Tabelle1

 ABCDEF
1Min Wert0 Min Wert0 
2Max Wert8 Max Wert8 
3      
4Ergebnis7.254 Ergebnis0.659 
5      

Formeln der Tabelle
ZelleFormel
B4=ZUFALLSBEREICH(B1;B2)+ZUFALLSZAHL()
E4=ZUFALLSZAHL()*(E2-E1)+E1


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Ergeniszelle mit 3 Dezimalstellen formatieren

Gruss Rainer


  

Betrifft: AW: Zufallszahl, speziell von: Klaus M.vdT.
Geschrieben am: 23.01.2008 16:01:26

Hallo Rainer und WHC,

das formatieren auf drei Dezimalstellen ist aber rein optisch, wenn du zum weiter rechnen wirklich nur 3 Stellen haben willst, bietet sich zusätzlich die "Runden" Formel an.

=RUNDEN(ZUFALLSZAHL()*(E2-E1)+E1;3)



ZUFALLSBEREICH würd ich nicht nutzen, da diese Formel das Analyse-Addin voraussetzt.

Grüße,
Klaus M.vdT.