Microsoft Excel

Herbers Excel/VBA-Archiv

Grafik mit selektierten Daten

Betrifft: Grafik mit selektierten Daten von: Martin Mühlhoff
Geschrieben am: 05.03.2008 10:49:01

https://www.herber.de/bbs/user/50451.xls

Hallo Excel Kollegen,
hiermit komme ich nicht mehr weiter (siehe beigefügte Datei):

Ich möchte aus einer Tabelle mit verschiedenen Werte-Typen (Spalte B) eine x-y-Grafik über das Datum erstellen, die für beide (oder ggf. später mehrere) Typen separate Linien anzeigt.
Das heißt ich möchte NUR mit der oberen Tabelle und Grafik arbeiten, aber die Linien (allerdings durchgezogen) der unteren beiden Grafiken mit aufnehmen.

Gibt es so etwas wie eine Matrix.Formel in der Liniengleichung des Diagramms???

Danke für eure Hilfe.

Martin

  

Betrifft: AW: Grafik mit selektierten Daten von: fcs
Geschrieben am: 05.03.2008 12:53:27

Hallo Martin,

um ein Diagramm in der gewünschten Form darzustellen, müsste die Tabelle etwa so aussehen:


Datum	Wert A	Wert B
01.01.08	14	#NV
13.01.08	#NV	13
17.01.08	12	#NV
22.01.08	#NV	11
30.01.08	10	#NV
04.02.08	#NV	9
13.02.08	#NV	8
22.02.08	7	#NV
25.02.08	6	#NV
28.02.08	5	#NV
01.03.08	#NV	4
03.03.08	3	#NV
05.03.08	#NV	2


Anders lassen sich die Daten kaum in einem Diagramm zusammenziehen.

Gruß
Franz


  

Betrifft: AW: Grafik mit selektierten Daten von: Martin Mühlhoff
Geschrieben am: 05.03.2008 13:00:24

Hmmm,
das bedeutet man muss die gesamte Tabelle sozusagen nochmals anlegen und die Werte in deinen Spalten B und C mittels (in meinem Fall) hunderter "Wenn...dann-Abfragen" füllen (ich habe derzeit 800 Zeilen in der Originaltebelle). Und dann darauf die Grafik basieren.
Das hatte ich ehrlicherweise auch schon immer so gemacht. Erschien mir aber immer irgendwie zu umständlich.
Ich denke, da muss es was proffesionelleres geben...
Daher lasse ich den Post mal offen.

Danke trotzdem vorerst.
Martin


  

Betrifft: AW: Grafik mit selektierten Daten von: fcs
Geschrieben am: 05.03.2008 17:36:27

Hallo Martin,

es geht ein wenig einfacher. Mit SVERWEIS
Erstelle in Spalte A eine fortlaufende Liste aller Datum vom 1.1.2008 bis zum x.y.200z entsprechend dem Datumsbereich deiner Daten.


Datum	Wert A	Wert B
01.01.08	14	#NV
02.01.08	#NV	#NV

Formeln:
B2: =SVERWEIS(A2;Tabelle1!$A$18:$C$30;3;FALSCH)
C2: =SVERWEIS(A2;Tabelle1!$A$34:$C$46;3;FALSCH)
A3: =A2+1
B3: =SVERWEIS(A3;Tabelle1!$A$18:$C$30;3;FALSCH)
C3: =SVERWEIS(A3;Tabelle1!$A$34:$C$46;3;FALSCH)


Formeln in Zeile 3 kann man dann nach unten Kopieren.

Gruß
Franz


  

Betrifft: AW: Grafik mit selektierten Daten von: Martin Mühlhoff
Geschrieben am: 06.03.2008 09:46:59

Gute Idee.
Funktioniert.
Danke dir

Martin


 

Beiträge aus den Excel-Beispielen zum Thema "Grafik mit selektierten Daten"