Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt und Namensbereich

Betrifft: Summenprodukt und Namensbereich von: Markus
Geschrieben am: 26.06.2008 15:12:32

Hi,

ich braeuchte mal eure Hilfe bitte.

Ich hab hier ein Summenprodukt-Spezial:
meine Datei sieht ungefaehr so aus:
.........A ......B
1.....1000....1
2.....1000....1
3.....1001....1
4.....1001....1
5.....1002....1
6.....1002....1
7.....1003....1
8.....1004....1
9.....1005....1
10...1006....1

in Spalte A stehen Warengruppen, in B Werte.
wenn ich jetzt nur Warengruppe 1000 und 1001will sieht das ja im Summenprodukt so aus:
=summenprodukt((A1:A10={1000.1001})*(B1:B10))
...kein Problem soweit. Weiss jemand wie man diese Einzelwerte {1000.1001} in einem Namensbereich unterbringen kann um dann flexibel darauf zuzugreifen und zu aendern?

Ich habe schon so etwas wie:

Name: wert

Bezieht sich auf: ={1000.1001}

Formel: =SUMMENPRODUKT((A1:A10=wert)*(B1:B10))


versucht, geht aber nicht weil er es in der Formel behandelt als wuerde nur die 1001 in der Matrixkonstanten stehen...

Vielen Dank und Gruss
Markus

  

Betrifft: AW: Summenprodukt und Namensbereich von: David
Geschrieben am: 26.06.2008 15:15:09

versuch mal als Namensformel:

=Indirekt("{1000.1001}")

(ungetestet!)

Gruß

David


  

Betrifft: AW: Summenprodukt und Namensbereich von: Markus
Geschrieben am: 26.06.2008 15:27:53

Hallo David,

hat leider nicht funktioniert, aber danke fuer deine Antwort.

Hier mal meine Beispieldatei...

https://www.herber.de/bbs/user/53377.xls

Danke und Gruss
Markus


  

Betrifft: AW: Summenprodukt und Namensbereich von: Rudi Maintaire
Geschrieben am: 26.06.2008 15:34:38

Hallo,
=AUSWERTEN("{1002.1001}")

Gruß
Rudi


  

Betrifft: AW: Summenprodukt und Namensbereich von: Mag
Geschrieben am: 26.06.2008 15:34:46

Hallo,

bei Namen/definieren nicht auf Zelle verweisen, sondern hier z.B. ={1001.1002} reinschreiben!

Gruss


  

Betrifft: AW: Summenprodukt und Namensbereich von: Markus
Geschrieben am: 26.06.2008 15:53:18

Vielen Dank fuer die Antworten,

das mit dem Namen definieren hat am besten geklappt und ist flexibel genug!

Danke + Gruss
Markus