Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert Anzeigen

Betrifft: Mittelwert Anzeigen von: Steffi
Geschrieben am: 03.07.2008 19:22:58

Hallo Zusammen und Guten Abend,

Folgendes möchte ich machen siehe Datei: https://www.herber.de/bbs/user/53567.xls

Da ist eine Formel die aber nicht ganz das macht was ich möchte, und zwar bei einem Kreuz die Nummer Übertragen in eine andere Zelle, und bei 2Kreuze oder mehr, nur das Wort Mittelwert Anzeigen. Geht aber nur wenn ich 4Kreuze mache und auch nicht immer.

Gruß Steffi

  

Betrifft: AW: Mittelwert Anzeigen von: HermannZ
Geschrieben am: 03.07.2008 20:07:56

Hallo Steffi;

nimm einmal in Zelle A22 folgende Formel;


{=WENN(ZÄHLENWENN(H7:H14;"x")>1;"Mittelwert";INDEX(A7:A14;MIN(WENN(H7:H14="x";ZEILE(1:8)))))}

und in B22 folgende;

{=MITTELWERT(WENN($H$7:$H$14="x";B7:B14))}

Formel nach rechts kopieren.

Gruss Hermann


  

Betrifft: AW: Mittelwert Anzeigen von: Steffi
Geschrieben am: 03.07.2008 20:18:04

Hallo Werner,

DANKE genau das war´s


Schönen Abend


  

Betrifft: Du hast Dich in der Anrede vertan ;-) ... von: neopa
Geschrieben am: 04.07.2008 08:33:39

Hallo Steffi ,

... Hermann hat Dir gestern die Lösung geschickt und nicht Werner (war gestern offline)

Als ich das vorhin sah, war mir aber gleich klar, dass ich am Mittwoch hier: https://www.herber.de/forum/messages/990620.html viel zu kompliziert gedacht hatte (ich hatte angenommen, dass nur jede 4. Zeile ausgewertet werden dürfe, nämlich nur die Zeilen, die Du gelb markiert hast).

Hermanns Lösung hat nur ein kleinen Haken, nämlich wenn keine Zeile markiert ist ergeben sich Fehlerwerte.

Hier nun mein hoffentlich diesmal korrektes Lösungsangebot. Formel B22 durch Ziehen nach rechts kopieren.

 ABCDEFGH
5No:a1 a2a3b1b2b3Auswahl
6        
7123456785,004,304,404,106,004,20 
8123456794,004,304,003,904,005,80 
92345,004,304,404,106,004,20 
1034564,004,304,003,904,005,80 
1145675,004,304,404,106,004,20x
1256784,004,304,003,904,005,80 
1367895,004,304,404,106,004,20 
1467804,004,304,003,904,005,80x
15        
21Übertrag:       
22Mittelwert4,504,304,204,005,005,00 

Formeln der Tabelle
ZelleFormel
A22{=WAHL(MIN(SUMME(N($H8:$H14="x")); 2)+1;"";INDEX(A8:A14;VERGLEICH("x";H8:H14;)); "Mittelwert")}
B22{=WENN(SUMME(N($H8:$H14="x")); MITTELWERT(WENN($H$7:$H$14="x";B7:B14)); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: Du hast Dich in der Anrede vertan ;-) ... von: Steffi
Geschrieben am: 04.07.2008 16:01:27

Hallo,

Sorry, war ein Fehler meinerseits


Trotzdem Danke


 

Beiträge aus den Excel-Beispielen zum Thema "Mittelwert Anzeigen"