Microsoft Excel

Herbers Excel/VBA-Archiv

Summe mit SVERWEIS



Thema: Summe mit SVERWEIS

Betrifft: Summe mit SVERWEIS
von: Detlev
Geschrieben am: 27.09.2002 - 13:09:59

Ich möchte aus einer Matrix die Summe einer Zeile über mehrere Spalten berechnen. Die Zeile wird mit SVERWEIS definiert, derzeit mach ich das mit der Formel :

=SVERWEIS(C15;'GMEH 2001'!$C$3:$P$26;3;1)+SVERWEIS(C15;'GMEH 2001'!$C$3:$P$26;4;1)+SVERWEIS(C15;'GMEH 2001'!$C$3:$P$26;5;1)

Mit jedem neuen Monat kommt eine Spalte dazu und ich füge einen neuen SVERWEIS an. Gibt es eine Möglichkeit, diese Formel in der Art

=SUMME(SVERWEIS(C15;'GMEH 2001'!$C$3:$P$26;3;1)+SVERWEIS(C15;'GMEH 2001'!$C$3:$P$26;5;1))

abzukürzen?

Gruss aus Hannover




  

Re: Summe mit SVERWEIS
von: th.heinrich
Geschrieben am: 27.09.2002 - 14:00:42

hallo Detlev,

ich stehe mit SVERWEIS permanent auf kriegsfuss.

folgende idee: verpasse dem bereich C3:P26 einen NAMEN, muss evtl. relativ, also ohne $ sein und frage ihn in Deiner formel ab.

bin nicht sicher koennte aber funzzen.

gruss thomas

  

Re: Summe mit SVERWEIS
von: Aliba
Geschrieben am: 28.09.2002 - 11:38:32

Hi Detlev,

irgendwie steh ich auf dem Schlauch. Die Werte werden doch bereits per SVERWEIS geliefert. Warum willst Du jetzt die Summe noch einmal über den SVERWEIS erhalten, warum greifst Du nicht auf die Zeile in der die Werte stehen direkt zu?

z.B. =SUMME(C15:C27)

CU Aliba

  

Re: Summe mit SVERWEIS
von: Detlev
Geschrieben am: 30.09.2002 - 10:38:33

Hi Aliba,

in der Matrix stehen in den Zeilen Namen und in den Spalten Monate. Da ich in der Zieltabelle eine nicht definierte und veränderliche Namensreihe habe, suche ich halt über SVERWEIS.
Ein fester Bezug funktioniert an der Stelle leider nicht mehr.
Ich müßte für jeden einzelnen Eintrag in der Zieltabelle den Bezug festlegen, daher suche ich halt eine schlauere Lösung.

Hi Thomas,

mir ist nicht ganz klar wie mir eine Namenszuweisung weiterhilft ... kannst Du mir noch etwas auf die Schiene helfen?

Danke aus Hannover 16° Sonnig :)

  

Re: Summe mit SVERWEIS
von: th.heinrich
Geschrieben am: 30.09.2002 - 14:51:54

hallo Detlev,

mal folgendes beispiel, wie gesagt SVERWEIS ist nicht wirklich mein ding.


MS Excel von th.heinrich an Detlev
 ABCDEF
1strnr  kdnr.sverweis_strsverweis_nr
2a100  1a100
3b200  2b200
4c300  3c300
5a100  1a100
6e500  4e500
7d400  5d400
8        =SVERWEIS(A2;strasse;1;0)
9          =SVERWEIS(B2;nr;1;0)
10     
11      strasse_bezieht_sich_auf_$A$2:$D$7 
12      nr._auf_$B$2:$D$7 

wird eine zeile entfernt bzw. hinzugefuegt pass sich der bereich an.

gruss thomas