Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn mehrer Bereiche

Betrifft: Zählenwenn mehrer Bereiche von: Dagmar GP
Geschrieben am: 18.08.2008 14:12:56

Hallo alle miteinander,

für einen Teil meiner Frage bin ich schon im Archiv fündig geworden (Produktsumme). Ich möchte die Anzahl von Zahlen ermitteln die auf verscheidenen Tabellenblättern verteilt sind und zwischen 2 und 3 liegen. Muß ich jeden Bereich einzeln eingeben oder gibt es da eine elegantere Lösung evt. mit einer Datenbankfunktion?

vielen Dank für Eure Hilfe

Dagmar

  

Betrifft: AW: Zählenwenn mehrer Bereiche von: ede
Geschrieben am: 18.08.2008 14:16:32

Hallo Dagmar,
das kannst Du mir der Funktion Summenprodukt( (bereich1>=2) * (Bereich1<=3) ) lösen!
gruss


  

Betrifft: AW: Zählenwenn mehrer Bereiche von: Dagmar GP
Geschrieben am: 18.08.2008 14:42:25

Hallo Ede,

diese beiden Bereiche brauche ich bereits dafür, daß ich Zahlen zwischen 2 und 3 habe, oder? Meine Formel sieht (im Test) so aus:=SUMMENPRODUKT((D3:D9>=2)*(D3:D9<=3))+SUMMENPRODUKT((F3:F9>=2)*(F3:F9<=3)). Geht das nicht kürzer? Im wirklichen Beispiel liegen die Bereiche auch noch auf verschiedenen (ca. 20 Stück!!) Tabellenblättern.
Trotzdem Danke für die schnelle Meldung
Gruß
Dagmar


  

Betrifft: AW: Zählenwenn mehrer Bereiche von: heikoS
Geschrieben am: 18.08.2008 17:18:24

Hallo Dagmar,

das geht z.B. so:

Tabelle1

 ABC
24  
3   
42,5  
53  
61,8 2
7  5
8  2,1

Formeln der Tabelle
ZelleFormel
A2=SUMME(ZÄHLENWENN(INDIREKT({"A4:A6"."C6:C8"}); ">=2"))-SUMME(ZÄHLENWENN(INDIREKT({"A4:A6"."C6:C8"}); ">3"))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Klappt´s?


Gruß Heiko


  

Betrifft: AW: Zählenwenn mehrer Bereiche von: Dagmar GP
Geschrieben am: 19.08.2008 09:24:23

Hallo Heiko,

vielen Dank für die super Lösung. Es gibt immer noch eine riesen Formel aber damit kann sich die Kollegin rumschlagen die mich gefragt hat.

Vielen Dank auch für die Antwort auf meine letzte Frage zum einstellen von Exceltabellen ins web. Das werde ich das nächtste Mal anwenden.

Bei Euch erhält man doch immer eine einfache und verständliche Lösung.

Einfach genial

Schöne Grüsse
Dagmar


  

Betrifft: Bitte, danke für Deine Rückmeldung! oT von: heikoS
Geschrieben am: 19.08.2008 10:02:41




 

Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn mehrer Bereiche"