Microsoft Excel

Herbers Excel/VBA-Archiv

SUMME

Betrifft: SUMME von: Pia
Geschrieben am: 21.08.2008 21:56:09

Hallo nochmals,

kann jemand mir bitte helfen? ich habe black out!

Ich habe eine Spalte mit Formeln (bedingte Formatierung) hinterlegt :

Zelle L7 : wenn K7 kleiner als null dann Äpfel sonst Banana...und falls die Antwort Äpfel wäre, dann die Zelle soll grün markiert werden, ansonstens rot.

Es hat auch super geklappt.

Nun, möchte ich gerne fragen, zum Schluss:

- wie kann ich abfragen, wieviel rote Zelle und wieviel grüne Zelle insgesamt? (im Wirklichkeit habe ich 5 Farben in 1500 Zellen einer Spalte)
- wie kann ich eine summe von nur positive zahlen in K3 ziehen?

Vielen Dank.

Pia

  

Betrifft: AW: SUMME von: Uduuh
Geschrieben am: 21.08.2008 22:16:38

Hallo,
die Farben aus bed. Formatierung kannst du nur sehr aufwändig per VBA abfragen. Teste die Zellen auf die Bedingung.
also: =zählenwenn(K:K;">0")
2. =summewenn(bereich;">0")

Gruß aus’m Pott
Udo



  

Betrifft: AW: SUMME von: Ramses
Geschrieben am: 21.08.2008 22:17:40

Hallo

"...wie kann ich abfragen, wieviel rote Zelle und wieviel grüne Zelle insgesamt? .."
Lass es bleiben.
Wenn du die Kriterien für die Farben kennst, dann benutze ZÄHLENWENN()
Alles andere ist viel zu kompliziert.

"...wie kann ich eine summe von nur positive zahlen in K3 ziehen?..:"
Tabelle2

 AB
10WertSumme
11-56
12-4 
13-3 
14-2 
15-1 
160 
171 
182 
193 

Formeln der Tabelle
ZelleFormel
B11=SUMMEWENN(A11:A19;">"&0;A11:A19)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruss Rainer


  

Betrifft: =SUMMEWENN(A11:A19;">"&0;A11:A19) von: Uduuh
Geschrieben am: 21.08.2008 22:27:08

Hallo Rainer,

=SUMMEWENN(A11:A19;">0")


reicht vollkommen

Gruß aus’m Pott
Udo



  

Betrifft: Die Macht der Gewohnheit :-) o.w.T. von: Ramses
Geschrieben am: 21.08.2008 22:31:41

....


  

Betrifft: AW: SUMME von: wolfgang
Geschrieben am: 21.08.2008 22:18:05

Hallo Pia
mit Summewenn kanst du das machen

In der Hilfe sind die Beispiele


Gruß Wolfgang


  

Betrifft: AW: VIELEN DANK AN ALLE!SUPER!!oT von: Pia
Geschrieben am: 21.08.2008 22:29:15

hat geklappt...danke !!!