Microsoft Excel

Herbers Excel/VBA-Archiv

summenprodukt aber wie? | Herbers Excel-Forum


Betrifft: summenprodukt aber wie? von: berni
Geschrieben am: 18.10.2008 22:49:36

so nu ich wieder^^

brauch mal eure hilfe.

ich habe eine liste daten, in welcher je nach datum werte erzeugt werden.
diese soll nu in abhängigkeit von der einheit nach (genannter MAK) ausgewertet werden.

komme mit meiner summenprodukt idee nich weiter...
ich will in Auswertung je nach einheit und dem datum die summe zur einheit haben ...
(Einheiten sind die in spalte a)

https://www.herber.de/bbs/user/56099.xls

ich hoff einer hat ne blitzidee ;-)

grüsse berni

  

Betrifft: AW: summenprodukt aber wie? von: Yal
Geschrieben am: 18.10.2008 23:20:37

Hallo Berni,

immer das Problem, dass Daten in eine Auswertungähnliche Zustand liegen...

Idealerweise würden deine Daten in 3 Spalten vorliegen: Daten (diese 6-stellige Nummer), MAK und Datum.

Auf diese Datenbank orientierte Lagerung der Daten könntest Du in 10 Sek. eine Pivottabelle aufstellen (Alt+n, p, e)

So sieht es aus:
https://www.herber.de/bbs/user/56100.xls


Viel Erfolg
Yal


  

Betrifft: AW: summenprodukt aber wie? von: berni
Geschrieben am: 18.10.2008 23:27:58

yati, dank dir für die lösung,

suche aber in erster linie eine formellösung um auf ständig wechselnde eingaben zugreifen zu können...
brauch das dynamisch und will damit am ende weiterrechnen, da dann noch aus anderen tabellen werte mit reingebracht werden.

aber pivot halt ich mal als letzte option offen.

aber ne formelllösung wär mir schon lieber....


  

Betrifft: AW: summenprodukt aber wie? von: WalterK
Geschrieben am: 18.10.2008 23:37:14

Hallo,



so vielleicht:



https://www.herber.de/bbs/user/56101.xls




Servus, Walter


  

Betrifft: AW: summenprodukt aber wie? von: berni
Geschrieben am: 18.10.2008 23:42:16

wow,

jepp das ergebnis iss schonmal wie ichs brauch ich pass dett mal an meine zeilenzahl an

super, ich dank dir/euch schonmal

damit versuch ichs nu weiter.

danke für eure hilfe.

wenns nich reicht^^ (denk ich nich )
meld ich mich nochmal

berni


  

Betrifft: AW: summenprodukt aber wie? von: berni
Geschrieben am: 19.10.2008 00:04:25

=SUMMEWENN(Daten!$A$4:$A$2000;$B32;INDIREKT("Daten!"&WECHSELN(ADRESSE(1;VERGLEICH(I$3;Daten!$3:$3;0) +1;4);1;)&"4:"&WECHSELN(ADRESSE(1;VERGLEICH(I$3;Daten!$3:$3;0)+1;4);1;)&"500"))

was bedingt in der formel &"500")) ?

scheint keine auswirkungen zu haben wenn ich das ändere....???

formel schein trotzdem zu funktionieren?

berni ;-)


  

Betrifft: AW: summewenn von: Erich G.
Geschrieben am: 19.10.2008 07:18:05

Hallo Berni,
hier eine Alternative - etwas weniger kompliziert:
(Formel von C4 nach rechts und nach unten kopieren)

 BCD
3daten01.01.200908.01.2009
401000000
50105001,593,63
60108000,413,89
70109003,365,32
818030010

Formeln der Tabelle
ZelleFormel
D3=C3+7
C4=SUMMEWENN(Daten!$A$4:$A$500;$B4;BEREICH.VERSCHIEBEN(Daten!$A$4:$A$500;0;VERGLEICH(C$3;Daten!$3:$3;0)))
D4=SUMMEWENN(Daten!$A$4:$A$500;$B4;BEREICH.VERSCHIEBEN(Daten!$A$4:$A$500;0;VERGLEICH(D$3;Daten!$3:$3;0)))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: summenprodukt aber wie? von: WalterK
Geschrieben am: 19.10.2008 10:53:30

Hallo,

500 ist die Zeilennummer, in deinem Beispiel müsste man die 500 auf 2000 abändern.

Servus, Walter


  

Betrifft: AW: summenprodukt aber wie? von: berni
Geschrieben am: 19.10.2008 18:33:21

vielen dank euch beiden
klappt vorzüglich so oder so ;-)

kann ich die formel nch ergänzen, sodass ich die das genauer auswerten kann wenn neben spalte noch nen a,b,c, d steht dass ich mir das nach z.b. 0108 A, 0108B etc noch auswerfen lassen könnte?


berni :-)


  

Betrifft: AW: summenprodukt aber wie? von: WalterK
Geschrieben am: 19.10.2008 19:59:44

Hallo Berni,

kannst Du ein Beispiel zeigen!?!

Servus, Walter


  

Betrifft: AW: summenprodukt aber wie? von: berni
Geschrieben am: 19.10.2008 20:50:13

klar,

habs mal versucht darzustellen

https://www.herber.de/bbs/user/56124.xls


und schonmal vielen dank ;-)

berni ;-)


  

Betrifft: AW: summenprodukt aber wie? von: WalterK
Geschrieben am: 19.10.2008 22:51:54

Hallo,

hier meine Version:
https://www.herber.de/bbs/user/56128.xls

1.) die Formeln von K3 bis AH 4 musste ich etwas umstellen und als Hilfszellen verwenden, diese können jetzt nur Blockweise weiter nach rechts kopiert werden.
2.) verbundene Zellen sollten unbedingt vermieden werden, es gibt nur Probleme bei der Weiterbearbeitung

Servus, Walter


  

Betrifft: AW: summenprodukt von: Erich G.
Geschrieben am: 20.10.2008 06:29:24

Hallo Berni,
und hier auch meine Variante mit BEREICH.VERSCHIEBEN:

Im Blatt "Daten" habe ich die Formel =WENN(D4="x";$C4;"") geändert in
=WENN(D4="x";$C4;0) bzw. kürzer =(D4="x")*C4
Dann kommt immer eine Zahl raus - statt des Leerstrings eine Null. Damit lässt sich besser weiterrechnen.

In "Auswertung" stehen in Zeile 3 Kleinbuchstaben (wie in Daten!B:B).
Damit geht folgende Formel:

 JKLMNOPQR
2 01.01.200908.01.2009
3 abcdabcd
401000000000000
501050001,59000,960,981,690

Formeln der Tabelle
ZelleFormel
K4=SUMMENPRODUKT((Daten!$A$4:$A$329=$J4)*(Daten!$B$4:$B$329=K$3) *BEREICH.VERSCHIEBEN(Daten!$A$4:$A$329;0; VERGLEICH(MAX($K$2:K$2); Daten!$3:$3;0)))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort