Microsoft Excel

Herbers Excel/VBA-Archiv

US-Postleitzahl Prüfung | Herbers Excel-Forum


Betrifft: US-Postleitzahl Prüfung von: onlinebroker24
Geschrieben am: 19.10.2008 22:10:00

Hallo liebe Forumteilnehmer,

vielleicht kann einer von euch mir helfen.

Folgende US-Postleitzahl Prüfung soll in einer Spalte D (Error) durchgeführt werden.

In der Spalte "A" stehen die Bundestaaten und in "B" die Zip Codes.
Nun soll geprüft werden ob diese einen Sinn ergeben und falsch eingetragen wurden.

D.h. wenn in der Spalte A "TX" (Texas) steht dann sollte geprüft werden ob der Zip Code von "75000" bis "79999" in der Spalte B korrekt eingetragen wurden "0", ansonsten sollte eine "1" erscheinen.
Weiter geht es mit "MO" (Missouri) und dem Bereich von 63000 bis 64999...und das für alle 50 Bundesstaaten in der einen und selben Spalte.
Es sollen nur Fehler mit einer "1" angezeigt werden ansonsten "0", Unterscheidungen zwischen den Bundesstaaten brauchen nicht erfolgen.

Hat dafür jemand einen Formel Vorschlag? Ich dachte mir sowas aber es funzt nicht:

=WENN(UND(S2="TX";U2>=75000; U2<80000);1;0; WENN(UND(S2="MO";U2>=63000; U2<65000);1;0)

Viele Grüsse,
onlinebroker24


  

Betrifft: AW: US-Postleitzahl Prüfung von: Tino
Geschrieben am: 19.10.2008 23:06:12

Hallo,
vielleicht würde es so gehen,
in der Spalte E bis G habe ich eine Vorgabenliste eingebaut,
kannst Du ja auch in eine andere Tabelle verlagern.

 ABCDEFG
1    TX7500079999
2TX750001 MO6300064999
3TX550000    
4MO649991    
5MO650000    
6MO650010    

Formeln der Tabelle
ZelleFormel
C2=WENN(UND(B2>=SVERWEIS(A2;$E$1:$G$50;2;0); B2<=SVERWEIS(A2;$E$1:$G$50;3;0)); 1;0)
C3=WENN(UND(B3>=SVERWEIS(A3;$E$1:$G$50;2;0); B3<=SVERWEIS(A3;$E$1:$G$50;3;0)); 1;0)
C4=WENN(UND(B4>=SVERWEIS(A4;$E$1:$G$50;2;0); B4<=SVERWEIS(A4;$E$1:$G$50;3;0)); 1;0)
C5=WENN(UND(B5>=SVERWEIS(A5;$E$1:$G$50;2;0); B5<=SVERWEIS(A5;$E$1:$G$50;3;0)); 1;0)
C6=WENN(UND(B6>=SVERWEIS(A6;$E$1:$G$50;2;0); B6<=SVERWEIS(A6;$E$1:$G$50;3;0)); 1;0)




Gruß Tino