Microsoft Excel

Herbers Excel/VBA-Archiv

Vergleich von Werten | Herbers Excel-Forum


Betrifft: Vergleich von Werten von: Carolina
Geschrieben am: 27.10.2008 17:18:03

Hallo alle zusammen,

schafft es jemand von euch, das alles in eine Formel zu packen?

1. Wenn D1=D2, E1=E2 und der Wert in A2 um 1 größer ist als A1, dann rechne G1+G2, ansonsten soll er den Wert in G2 hinschreiben.

2. Wenn genau eine der Bedingungen nicht erfüllt ist (egal welche), soll er ein statt dem Wert von G2 ein X hinschreiben.

Jemand ne Idee?

lg
caro

  

Betrifft: AW: Vergleich von Werten von: JogyB
Geschrieben am: 27.10.2008 17:22:27

Hmm, mit einer Formel geht das nicht, da Du ja in die Zelle schreiben willst, in der einer der Rechenwerte steht.

Gruss, Jogy


  

Betrifft: AW: Vergleich von Werten von: Carolina
Geschrieben am: 27.10.2008 17:25:16

verstehe ich nicht, ich will die Formel ja in die Zelle H2 tun, da steht kein Wert


  

Betrifft: AW: Vergleich von Werten von: Carolina
Geschrieben am: 27.10.2008 17:28:26

ich möchte quasi sowas haben, wenn alle 3 bedingungen stimmen soll er G1+G2 rechnen, wenn genau eine nicht stimmt, soll er ein X hinschreiben, wenn 2 oder alle 3 nicht stimmen soll er den Wert von G2 hinschreiben


  

Betrifft: =WENN(UND(D1=D2;E1=E2;A2>A1);G1+G2;"x") von: WF
Geschrieben am: 27.10.2008 17:33:05

.


  

Betrifft: AW: =WENN(UND(D1=D2;E1=E2;A2>A1);G1+G2;"x") von: Carolina
Geschrieben am: 27.10.2008 17:41:27

da fehlt jetzt noch der letzte teil "wenn 2 oder alle 3 nicht stimmen soll er den Wert von G2 hinschreiben"


  

Betrifft: OK das hatte ich überlesen von: WF
Geschrieben am: 27.10.2008 18:01:41

Hi Carolina,

=WENN((D1=D2)+(E1=E2)+(A2>A1)=2;"x";(D1=D2)*(E1=E2)*(A2>A1)*G1+G2)

Salut WF


  

Betrifft: AW: OK das hatte ich überlesen von: Carolina
Geschrieben am: 27.10.2008 18:38:16

geht leider nicht in den Spalten D und E steht text, den kann ich schlecht addieren oder multiplizieren


  

Betrifft: das ist Wurscht ob Text oder Zahl von: WF
Geschrieben am: 27.10.2008 18:44:12

Hi Carolina,

=(D1=D2)*1
ergibt 1 wenn identisch sonst 0 - egal ob das Text oder Zahlen sind.

WF


  

Betrifft: AW: Vergleich von Werten von: JogyB
Geschrieben am: 27.10.2008 19:35:48

Hi.

Du hattest geschrieben, dass Du den Wert in G2 schreiben willst.

Gruss, Jogy


Beiträge aus den Excel-Beispielen zum Thema "Vergleich von Werten"