Microsoft Excel

Herbers Excel/VBA-Archiv

Formelproblem | Herbers Excel-Forum


Betrifft: Formelproblem von: Edgar
Geschrieben am: 12.11.2009 08:04:58

Hallo Excelaner,

ich habe ein Formelproblem das ich in der hochgeladenen Datei beschrieben habe.
Ich hoffe, dass es für euch Profis kein Problem ist die Formel zu finden. Ich kämpfe schon
zwei Tage lang.

Gruss

Edgar

  

Betrifft: ...wo ist die Datei ? owT von: robert
Geschrieben am: 12.11.2009 08:10:00




  

Betrifft: AW: Formelproblem von: Edgar
Geschrieben am: 12.11.2009 08:13:33

Hallo Robert,

jehttps://www.herber.de/bbs/user/65794.xls
tzt müsste er dabei sein.


  

Betrifft: AW: Formelproblem von: Edgar
Geschrieben am: 12.11.2009 08:32:44

Hallo Robert,
noch ein Versuch.
https://www.herber.de/bbs/user/65796.xls

Gruss
Edgar


  

Betrifft: AW: Formelproblem von: Mike
Geschrieben am: 12.11.2009 08:38:11


Hey Edgar,

übernimm doch "einfach" die Zelle G31 in die Berechnung
der Woche 1 - 2010.

Gruss
Mike


  

Betrifft: AW: Formelproblem von: Tino
Geschrieben am: 12.11.2009 08:45:59

Hallo,
meinst Du so?

 ABCDEFG
33Woche SollzeitIstzeitZugangAbgangZeitschuld
341Jan38,538,5  0,0
352Jan38,539,51 -1,0
363Jan38,537,5 11,0
374Jan     

Formeln der Tabelle
ZelleFormel
E34=WENN(UND(D34>C34;C34<>"";D34<>""); D34-C34;"")
F34=WENN(UND(C34>D34;C34<>"";D34<>""); C34-D34;"")
G34=WENN(ODER(C34="";D34=""); "";C34-D34)
E35=WENN(UND(D35>C35;C35<>"";D35<>""); D35-C35;"")
F35=WENN(UND(C35>D35;C35<>"";D35<>""); C35-D35;"")
G35=WENN(ODER(C35="";D35=""); "";C35-D35)
E36=WENN(UND(D36>C36;C36<>"";D36<>""); D36-C36;"")
F36=WENN(UND(C36>D36;C36<>"";D36<>""); C36-D36;"")
G36=WENN(ODER(C36="";D36=""); "";C36-D36)
E37=WENN(UND(D37>C37;C37<>"";D37<>""); D37-C37;"")
F37=WENN(UND(C37>D37;C37<>"";D37<>""); C37-D37;"")
G37=WENN(ODER(C37="";D37=""); "";C37-D37)


Gruß Tino


  

Betrifft: AW: Formelproblem von: Edgar
Geschrieben am: 12.11.2009 08:52:39

Hallo Tino,
vielen Dank für dein Bemühen
in der ersten woche soll das Zeitguthaben oder die Zeitschuld wenn die Stunden 38,5 gleich sind
vom letzten Jahr übernommen werden.

Gruss

Edgar


  

Betrifft: AW: Formelproblem von: Edgar
Geschrieben am: 12.11.2009 08:52:51

Hallo Tino,
vielen Dank für dein Bemühen
in der ersten woche soll das Zeitguthaben oder die Zeitschuld wenn die Stunden 38,5 gleich sind
vom letzten Jahr übernommen werden.

Gruss

Edgar


  

Betrifft: AW: Formelproblem von: Tino
Geschrieben am: 12.11.2009 08:58:54

Hallo,
in Zelle G34 einfach dazu addieren.

=WENN(ODER(C34="";D34="");"";C34-D34)+G31

Gruß Tino


  

Betrifft: AW: Formelproblem von: Mike
Geschrieben am: 12.11.2009 09:05:05


Hey Edgar,

Du kannst es so lösen:


E. Schell

 ABCDEFG
322010      5.5  Zeitguthaben
33Woche  SollzeitIstzeitZugangAbgangZeitschuld
341Jan38.5412.5  8.0
352Jan38.532  6.51.5
363Jan         
374Jan         

verwendete Formeln
Zelle Formel
E32 =WENN(G31>0; G31; "")
F32 =WENN(G31<0; G31; "")
E34 =WENN(D34>C34;D34-C34;"")
F34 =WENN(D34="";"";WENN(C34>D34;C34-D34;""))
G34 =WENN(C34="";"";SUMME($E$32:$E34)-SUMME($F$32:$F34))
E35 =WENN(D35>C35;D35-C35;"")
F35 =WENN(D35="";"";WENN(C35>D35;C35-D35;""))
G35 =WENN(C35="";"";SUMME($E$32:$E35)-SUMME($F$32:$F35))
E36 =WENN(D36>C36;D36-C36;"")
F36 =WENN(C36>D36;C36-D36;"")
G36 =WENN(C36="";"";SUMME($E$34:$E36)-SUMME($F$34:$F36))
E37 =WENN(D37>C37;D37-C37;"")
F37 =WENN(C37>D37;C37-D37;"")
G37 =WENN(C37="";"";SUMME($E$34:$E37)-SUMME($F$34:$F37))

Zahlenformate
Zelle Format Wert
G34 0.0_ ;[Rot]-0.0 8
G35 0.0_ ;[Rot]-0.0 1.5
G36 0.0_ ;[Rot]-0.0  
G37 0.0_ ;[Rot]-0.0  
Zellen mit Format Standard werden nicht dargestellt

Schriftformate
Zelle Rot Grün Blau Color Stil Unterstreichung Effekte Durchgestrichen Schriftart
A32 255 255 Fett       Arial (W1) 
A33:A37     Fett       Arial (W1) 
B32:B33 Fett       Arial (W1) 
B34:B37        Arial (W1) 
C32        Calibri 
C33 Fett       Calibri 
C34:C35 102 204 13395456        Calibri 
C36:C37 204 255 16763904        Calibri 
D32        Calibri 
D33 Fett       Calibri 
D34:D35 102 204 13395456        Calibri 
D36:D37 204 255 16763904        Calibri 
E32:E33 Fett       Calibri 
E34:E35 102 204 13395456 Fett       Calibri 
E36:E37 204 255 16763904 Fett       Calibri 
F32 Fett       Calibri 
F33:F37 255 255 Fett       Calibri 
G32 102 204 13395456 Fett       Calibri 
G33 255 255 Fett       Calibri 
G34:G37 102 204 13395456 Fett       Calibri 
Zellen mit Schriftformatierung automatisch werden nicht dargestellt

Tabellendarstellung in Foren Version 4.28



Gruss
Mike


  

Betrifft: AW: Formelproblem von: robert
Geschrieben am: 12.11.2009 08:44:56

hi,

meinst du so ?

gruß
robert
E. Schell

 EF
33ZugangAbgang
34  -7

verwendete Formeln
Zelle Formel
E34 =WENN(G31>0;G31;"")
F34 =WENN(G31<0;G31;"")

Tabellendarstellung in Foren Version 4.28




  

Betrifft: Formelproblem von: robert
Geschrieben am: 12.11.2009 09:21:40

hi,

vielleicht so?

vorträge werden separat ausgewiesen und im neuen jahr berücksichtigt

gruß
robert

https://www.herber.de/bbs/user/65799.xls


  

Betrifft: AW: Formelproblem von: Edgar
Geschrieben am: 12.11.2009 09:28:59

Hallo Robert,

das ist es. Eine SUPER Lösung.
Vielen herzlichen Dank.
Auch ein herzliches Dankeschön an Tino und Mike für die Bemühungen.
Roberts Lösung ist einfacher.

Gruss

Edgar


  

Betrifft: Danke f.Rückmeldung :-) owT Gruß von: robert
Geschrieben am: 12.11.2009 09:40:54