Microsoft Excel

Herbers Excel/VBA-Archiv

Monatskalender | Herbers Excel-Forum


Betrifft: Monatskalender von: Jonathan
Geschrieben am: 13.11.2009 00:55:27

Hey,

ich brauche einen ganz einfachen Monatskalender:

Mo Di Mi ...
Tage...

Die Werte für Jahr und Monat will ich in zwei Zellen angeben.

Könnte mir bitte jemand mit der Formel helfen?

Ich danke Euch vorab!

LG

  

Betrifft: Monatskalender mini von: Erich G.
Geschrieben am: 13.11.2009 01:08:32

Hallo ,
da ein paar Formeln (und Zahlformate) gebraucht werden, mal schnell als Mappe:
https://www.herber.de/bbs/user/65838.xls

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Monatskalender mini von: Jonathan
Geschrieben am: 13.11.2009 01:18:29

Hey,

Ihr seid ja noch genau so schnell wie vor Jahren schon! ;-)

Ich habe versucht, die Tabelle anzupassen - vielen Dank!! -, leider ohne Erfolg. Ich möchte einen Kalender haben wie folgt:

Du kenst doch diesen Standard-Monatskalender... Beginnt bei Mo, Di, ... So; darunter dann passend das Tagesdatum. November z.B. beginnt erst am So, 01.11.. Die Zellen vor So bis Mo beinhalten dann noch die Daten des vorherigen Monats....

Wäre super nett, wenn du mir noch etwas helfen könntest!

LG


  

Betrifft: tschulligung, Erich,Jonathan, dass ich ... von: Oberschlumpf
Geschrieben am: 13.11.2009 01:25:29

...dazwischen quatsche.

Aber ich denk, es is einfacher, wenn du erst mal deine Datei genau so erstellst, wie du es dir vorstellst.
(ich mein das Layout, Farben und sonstige Formatierungen, Spalten/Zeilengrößen etc)

Wenn du damit fertig bist, dann stellst du uns deine Datei per Upload zur Verfügung, und wir versuchen dann, dem Ganzen "Leben einzuhauchen".

Was haltet ihr von dieser Idee?

Ciao
Thorsten


  

Betrifft: AW: Monatskalender von: Oberschlumpf
Geschrieben am: 13.11.2009 01:21:57

Hi Jonathan

Zwar nich ganz so schnell, hab aber auch ich ne Idee :-)
https://www.herber.de/bbs/user/65840.xls

Hilfts?

Ciao
Thorsten


  

Betrifft: AW: Monatskalender von: Jonathan
Geschrieben am: 13.11.2009 01:27:18

Hey,

;-)

So soll es aussehen:




  

Betrifft: AW: Monatskalender von: Oberschlumpf
Geschrieben am: 13.11.2009 01:29:57

Hi

Du musst die Datei nicht selbst erstellen, kannst auch diese Arbeit ruhig uns überlassen, aber....freundlicher wäre es schon von dir, wenn auch du ein wenig mithilfst... ;-)

Ciao
Thorsten


  

Betrifft: AW: Monatskalender von: Jonathan
Geschrieben am: 13.11.2009 01:32:21

Sorry, waren etwa gleichschnell! ;-)



https://www.herber.de/bbs/user/65842.xlsx


  

Betrifft: AW: Monatskalender von: Oberschlumpf
Geschrieben am: 13.11.2009 01:34:34

grins..danke..aber..hab leider noch Excel XP...haste die Datei bitte auch im xls-Format?


  

Betrifft: AW: Monatskalender von: Jonathan
Geschrieben am: 13.11.2009 01:39:04

https://www.herber.de/bbs/user/65843.xls

;-) sorry, nicht dran gedacht!


  

Betrifft: Wo stehen Jahres- und Monats-Vorgabe? von: Erich G.
Geschrieben am: 13.11.2009 02:17:21

Hi Jonathan,
du hst eingangs geschrieben: "Die Werte für Jahr und Monat will ich in zwei Zellen angeben."
Wo hast du das jetzt vorgesehen?

@Thorsten: Danke, das war eine hilfreiche Intervention - erst mal das Layout klären!

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW:Newsletter Monatskalender von: hary
Geschrieben am: 13.11.2009 06:16:28

Moin zusammen
Hatte Hans Herber nicht so was in einem seiner Newsletter, sollte als Ersatz vom Kalender-Steuerelement dienen. Habe ich zuhause noch rumliegen. Kann aber erst heute nachmittag bescheid geben.
Gruss hary


  

Betrifft: AW: Monatskalender von: Heinz A. Wankmüller
Geschrieben am: 13.11.2009 06:54:50

Hallo Jonathan,

hier auch ein Versuch
https://www.herber.de/bbs/user/65846.xls

Gruß
Heinz


  

Betrifft: AW: Monatskalender von: werni
Geschrieben am: 13.11.2009 07:32:19

Hallo Jonathan

Schau dir mal diesen an. Ist fix und fertig.
Ev. an eigene Bedürfnisse anpassen. Bevor du ihn herunterlädst, klicke auf view, da kannst du immer noch entscheiden.

http://ms-excel.eu/index.php?option=com_docman&task=cat_view&gid=79&Itemid=40

Gruss Werner


  

Betrifft: natürlich auf excelformeln.de von: WF
Geschrieben am: 13.11.2009 08:39:52

http://www.excelformeln.de/tips.html?welcher=32
der zweite download

Salut WF


  

Betrifft: @WF: Vorschlag zu Tipp Nr. 32 von: Erich G.
Geschrieben am: 13.11.2009 23:40:27

Hi Walter,
ein paar kleine Vorschläge zur Vereinfachung - v.a. in Zeile 12 und in der KW-Spalte H:

 ABCDEFGH
10MODIMIDOFRSASOKW
11        
120102030405060749.
13        
140809101112131450.
15        
161516171819202151.
17  HeiligabendWeihnachenWeihnachen   
182223242526272852.
19  Silvester     
20293031010203041.
21        
2205060708091011 

Formeln der Tabelle
ZelleFormel
A11=WENN(ISTNV(SVERWEIS(A12;$N:$O;2;0)); "";SVERWEIS(A12;$N:$O;2;0))
B11=WENN(ISTNV(SVERWEIS(B12;$N:$O;2;0)); "";SVERWEIS(B12;$N:$O;2;0))
C11=WENN(ISTNV(SVERWEIS(C12;$N:$O;2;0)); "";SVERWEIS(C12;$N:$O;2;0))
D11=WENN(ISTNV(SVERWEIS(D12;$N:$O;2;0)); "";SVERWEIS(D12;$N:$O;2;0))
E11=WENN(ISTNV(SVERWEIS(E12;$N:$O;2;0)); "";SVERWEIS(E12;$N:$O;2;0))
F11=WENN(ISTNV(SVERWEIS(F12;$N:$O;2;0)); "";SVERWEIS(F12;$N:$O;2;0))
G11=WENN(ISTNV(SVERWEIS(G12;$N:$O;2;0)); "";SVERWEIS(G12;$N:$O;2;0))
A12=DATUM($L$1;$L$2;1)+SPALTE()-REST(DATUM($L$1;$L$2;1)-2;7)-1
B12=A12+1
C12=B12+1
D12=C12+1
E12=D12+1
F12=E12+1
G12=F12+1
H12=KÜRZEN((A12-WOCHENTAG(A12;2)-DATUM(JAHR(A12+4-WOCHENTAG(A12;2)); 1;-10))/7)
A13=WENN(ISTNV(SVERWEIS(A14;$N:$O;2;0)); "";SVERWEIS(A14;$N:$O;2;0))
B13=WENN(ISTNV(SVERWEIS(B14;$N:$O;2;0)); "";SVERWEIS(B14;$N:$O;2;0))
C13=WENN(ISTNV(SVERWEIS(C14;$N:$O;2;0)); "";SVERWEIS(C14;$N:$O;2;0))
D13=WENN(ISTNV(SVERWEIS(D14;$N:$O;2;0)); "";SVERWEIS(D14;$N:$O;2;0))
E13=WENN(ISTNV(SVERWEIS(E14;$N:$O;2;0)); "";SVERWEIS(E14;$N:$O;2;0))
F13=WENN(ISTNV(SVERWEIS(F14;$N:$O;2;0)); "";SVERWEIS(F14;$N:$O;2;0))
G13=WENN(ISTNV(SVERWEIS(G14;$N:$O;2;0)); "";SVERWEIS(G14;$N:$O;2;0))
A14=+G12+1
B14=+A14+1
C14=+B14+1
D14=+C14+1
E14=+D14+1
F14=+E14+1
G14=+F14+1
H14=H12+1
A15=WENN(ISTNV(SVERWEIS(A16;$N:$O;2;0)); "";SVERWEIS(A16;$N:$O;2;0))
B15=WENN(ISTNV(SVERWEIS(B16;$N:$O;2;0)); "";SVERWEIS(B16;$N:$O;2;0))
C15=WENN(ISTNV(SVERWEIS(C16;$N:$O;2;0)); "";SVERWEIS(C16;$N:$O;2;0))
D15=WENN(ISTNV(SVERWEIS(D16;$N:$O;2;0)); "";SVERWEIS(D16;$N:$O;2;0))
E15=WENN(ISTNV(SVERWEIS(E16;$N:$O;2;0)); "";SVERWEIS(E16;$N:$O;2;0))
F15=WENN(ISTNV(SVERWEIS(F16;$N:$O;2;0)); "";SVERWEIS(F16;$N:$O;2;0))
G15=WENN(ISTNV(SVERWEIS(G16;$N:$O;2;0)); "";SVERWEIS(G16;$N:$O;2;0))
A16=+G14+1
B16=+A16+1
C16=+B16+1
D16=+C16+1
E16=+D16+1
F16=+E16+1
G16=+F16+1
H16=H14+1
A17=WENN(ISTNV(SVERWEIS(A18;$N:$O;2;0)); "";SVERWEIS(A18;$N:$O;2;0))
B17=WENN(ISTNV(SVERWEIS(B18;$N:$O;2;0)); "";SVERWEIS(B18;$N:$O;2;0))
C17=WENN(ISTNV(SVERWEIS(C18;$N:$O;2;0)); "";SVERWEIS(C18;$N:$O;2;0))
D17=WENN(ISTNV(SVERWEIS(D18;$N:$O;2;0)); "";SVERWEIS(D18;$N:$O;2;0))
E17=WENN(ISTNV(SVERWEIS(E18;$N:$O;2;0)); "";SVERWEIS(E18;$N:$O;2;0))
F17=WENN(ISTNV(SVERWEIS(F18;$N:$O;2;0)); "";SVERWEIS(F18;$N:$O;2;0))
G17=WENN(ISTNV(SVERWEIS(G18;$N:$O;2;0)); "";SVERWEIS(G18;$N:$O;2;0))
A18=+G16+1
B18=+A18+1
C18=+B18+1
D18=+C18+1
E18=+D18+1
F18=+E18+1
G18=+F18+1
H18=H16+1
A19=WENN(ISTNV(SVERWEIS(A20;$N:$O;2;0)); "";SVERWEIS(A20;$N:$O;2;0))
B19=WENN(ISTNV(SVERWEIS(B20;$N:$O;2;0)); "";SVERWEIS(B20;$N:$O;2;0))
C19=WENN(ISTNV(SVERWEIS(C20;$N:$O;2;0)); "";SVERWEIS(C20;$N:$O;2;0))
D19=WENN(ISTNV(SVERWEIS(D20;$N:$O;2;0)); "";SVERWEIS(D20;$N:$O;2;0))
E19=WENN(ISTNV(SVERWEIS(E20;$N:$O;2;0)); "";SVERWEIS(E20;$N:$O;2;0))
F19=WENN(ISTNV(SVERWEIS(F20;$N:$O;2;0)); "";SVERWEIS(F20;$N:$O;2;0))
G19=WENN(ISTNV(SVERWEIS(G20;$N:$O;2;0)); "";SVERWEIS(G20;$N:$O;2;0))
A20=+G18+1
B20=+A20+1
C20=+B20+1
D20=+C20+1
E20=+D20+1
F20=+E20+1
G20=+F20+1
H20=WENN(MONAT(A20)=$L$2;KÜRZEN((A20-WOCHENTAG(A20;2)-DATUM(JAHR(A20+4-WOCHENTAG(A20;2)); 1;-10))/7); 0)
A21=WENN(ISTNV(SVERWEIS(A22;$N:$O;2;0)); "";SVERWEIS(A22;$N:$O;2;0))
B21=WENN(ISTNV(SVERWEIS(B22;$N:$O;2;0)); "";SVERWEIS(B22;$N:$O;2;0))
C21=WENN(ISTNV(SVERWEIS(C22;$N:$O;2;0)); "";SVERWEIS(C22;$N:$O;2;0))
D21=WENN(ISTNV(SVERWEIS(D22;$N:$O;2;0)); "";SVERWEIS(D22;$N:$O;2;0))
E21=WENN(ISTNV(SVERWEIS(E22;$N:$O;2;0)); "";SVERWEIS(E22;$N:$O;2;0))
F21=WENN(ISTNV(SVERWEIS(F22;$N:$O;2;0)); "";SVERWEIS(F22;$N:$O;2;0))
G21=WENN(ISTNV(SVERWEIS(G22;$N:$O;2;0)); "";SVERWEIS(G22;$N:$O;2;0))
A22=+G20+1
B22=+A22+1
C22=+B22+1
D22=+C22+1
E22=+D22+1
F22=+E22+1
G22=+F22+1
H22=WENN(MONAT(A22)=$L$2;KÜRZEN((A22-WOCHENTAG(A22;2)-DATUM(JAHR(A22+4-WOCHENTAG(A22;2)); 1;-10))/7); 0)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: @WF: noch ne Korrektur von: Erich G.
Geschrieben am: 13.11.2009 23:48:19

Hi Walter,
damit es keine KW 54 usw gibt, muss in H14 eine andere Formel:

 H
1253.
13 
141.

Formeln der Tabelle
ZelleFormel
H12=KÜRZEN((A12-WOCHENTAG(A12;2)-DATUM(JAHR(A12+4-WOCHENTAG(A12;2)); 1;-10))/7)
H14=(H12<52)*H12+1

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: @WF: noch ne Korrektur von: Jonathan
Geschrieben am: 14.11.2009 01:09:36

Hey zusammen!

Vielen lieben Dank für Eure Hilfe und die vielen Dateien!!!

Hat mir sehr geholfen!!

Danke!

LG