Live-Forum - Die aktuellen Beiträge
Datum
Titel
15.04.2024 16:30:01
15.04.2024 13:59:59
15.04.2024 13:54:18
Anzeige
Archiv - Navigation
1116to1120
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summewenn??

Summewenn?
Snewi
Hallo,
ich habe mehrere Zahlen die ich anhand des Kürzels über den Spalten Zeilenmäßig addieren möchte! wie kann ich das realisieren?
https://www.herber.de/bbs/user/65853.xls
Gruß

20
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
Richtig, SUMMEWENN
13.11.2009 10:28:32
Björn
Hallo,
ich verstehe Dein PRoblem nicht, du schreibst die Lösung selbst schon in den Betreff!
Ja, das geht mit Summewenn. Syntax steht in der Hilfe. Das sollte jemand mit Excel-gut locker schaffen.
Hast Du es schon versucht?
Was funktioniert denn nicht?
In Deiner Datei steht ja gar keine Formel, also hast Du es wohl nicht nicht versucht.
Gruß
Björn
AW: Richtig, SUMMEWENN
13.11.2009 10:30:59
Snewi
Vielleicht war ich ein bischen voreilig hatte die Bereiche zur Berechnung vertauscht! Mhh!
Danke hat funktioniert :-)
nur mal so
13.11.2009 10:32:09
Oberschlumpf
Hi Björn
Vielleicht is er?/sie? ja blockiert, kommt nich weiter, oder kennt sich mit summewenn nich aus.
Ich denke, dass ich auch Excel = gut bin...mache aber trotzdem um indirekt(), sverweis(),wverweis(),pivot und bestimmt noch mehr Funktionen, von denen ich nich mal weiß, dass es sie gibt...immer wieder n großen Bogen, weil ich es einfach nich kapiere :)
Ciao
Thorsten
Anzeige
nicht .. nur mal so
13.11.2009 10:41:04
Mike
Hey Thorsten,
nicht verzweifeln, Summewenn / Sverweis / Wverweis sind doch
soooo nützlich und eigentlich gar nicht schwer zu verstehen .. ;-)
Gruss
Mike
außer SummeWenn hats noch nich Klick gemacht :-)oT
13.11.2009 10:42:48
Oberschlumpf
man nehme ..
13.11.2009 10:51:54
Mike
Hey Thorsten,
aus einer Liste werden nach Angabe z.B. der Artikelnummer die
Infos zugewiesen:
Auswahl
 BCDEF
23         
24Liste:    Auswahl: 
25Artikel    gewünschter Artikel 
26         
271001Schnürrsenkel  1005Schuhsohle
281005Schuhsohle     
291010Schuhcreme     
30         

verwendete Formeln
Zelle Formel
F27 =SVERWEIS(E27;B27:C29; 2; FALSCH)

Schriftformate
Zelle Rot Grün Blau Color Stil Unterstreichung Effekte Durchgestrichen Schriftart
B25:C25 255 255 153 10092543         
E24 255 153 39423 Fett        
E25     Fett        
Zellen mit Schriftformatierung automatisch werden nicht dargestellt

Tabellendarstellung in Foren Version 4.28


Gut ist Sverweis auch, wenn zwei Listen verglichen werden, denn nichtvorhandene Einträge
werden mit #NV angezeigt.
Gruss
Mike
Anzeige
AW: man nehme ..
13.11.2009 13:02:33
Oberschlumpf
Hallo Mike und...
...vielen Dank Mike...für die Mühe!
Damit auch ICH irgdwann zum Excel-Profi aufsteige :-), werde ich mich damit wohl mal befassen müssen.
Ciao
Thorsten
und weils ..
13.11.2009 10:58:51
Mike
Hey Thorsten,
und weils so schön ist, noch ein weiteres Beispiel:
Rechnung
 BCDEFGHIJKLMNOPQRSTUVWX
3                                             
4  Rechnung          RechnungSverweis mit Namen        Liste          Liste     
5                                             
6  Artikel:1        Artikel:110      ArtikelBeschreibungPreise in €      ArtikelBeschreibungPreise in € 
7  Bezeichnung:Handtrockner        Bezeichnung:HandtrocknerIpod      001Handtrockner10.00      010Ipod10.00 
8                          002Fusstrockner25.00      020Tastatur25.00 
9  Preis:10.00        Preis:10.0010.00                         
10  Menge:9.00        Menge:15.0015.00                         
11                                             
12  TOTAL90.00        TOTAL150.00150.00                         
13                                             
14                                             
15                                             
16                                             
17                                             
18                                             

verwendete Formeln
Zelle Formel
D7 =SVERWEIS(D6; $O$7:$Q$8; 2; FALSCH)
J7 =SVERWEIS(J6; HaFu; 2; FALSCH)
K7 =SVERWEIS(K6; Elek; 2; FALSCH)
D9 =SVERWEIS(D6; $O$7:$Q$8; 3; FALSCH)
J9 =SVERWEIS(J6; HaFu; 3; FALSCH)
K9 =SVERWEIS(K6; Elek; 3; FALSCH)
D12 =D9*D10
J12 =J9*J10
K12 =K9*K10

definierte Namen
Name Bezieht sich auf Tabelle
Elek =Rechnung!$U$7:$W$17 
HaFu =Rechnung!$O$7:$Q$17 

Tabellendarstellung in Foren Version 4.28


Gruss
Mike
Anzeige
AW: und weils ..
13.11.2009 13:04:00
Oberschlumpf
..ma eben nich so in ner Minute fertig war (denk ich)...auch hierfür n grosses DANKE! :-)
Ciao
Thorsten
ein paar ..
13.11.2009 13:08:37
Mike
Hey Thorsten,
ein paar Mal angewendet und das System wird klar.
Bis auf das Quercheck-Beispiel hatte ich den Rest
pfannenfertig als Vorlage. Wird ja immer wieder
danach gefragt .. ;-)
Gruss
Mike
und auch ...
13.11.2009 11:15:11
Mike
Hey Thorsten,
und auch noch das Quercheck-Beispiel:
Auswahl
 LMNOPQR
21  Quercheck         
22             
23    Liste 1      Liste 2
24  ABAB    ABAB
25  #NVCD    #NVDB
26  EFEF    EFEF
27  GHGH    GHGH
28  #NVHI    #NVJK
29  #NVJK    #NVLM
30             
31             
32richtige Werte  Liste 1  richtige Werte  Liste 2
33ausgeblendet  AB  ausgeblendet  AB
34  #NVCD    #NVDB
35    EF      EF
36    GH      GH
37  #NVHI      JK
38    JK    #NVLM
39             
40             
41Fehler   Liste 1  Fehler   Liste 2
42ausgeblendetABAB  ausgeblendetABAB
43    CD      DB
44  EFEF    EFEF
45  GHGH    GHGH
46    HI    JKJK
47  JKJK      LM
48             

verwendete Formeln
Zelle Formel
M24 =SVERWEIS(N24;$R$24:$R$27; 1; FALSCH)
Q24 =SVERWEIS(R24;$N$24:$N$27; 1; FALSCH)
M25 =SVERWEIS(N25;$R$24:$R$27; 1; FALSCH)
Q25 =SVERWEIS(R25;$N$24:$N$27; 1; FALSCH)
M26 =SVERWEIS(N26;$R$24:$R$27; 1; FALSCH)
Q26 =SVERWEIS(R26;$N$24:$N$27; 1; FALSCH)
M27 =SVERWEIS(N27;$R$24:$R$27; 1; FALSCH)
Q27 =SVERWEIS(R27;$N$24:$N$27; 1; FALSCH)
M28 =SVERWEIS(N28;$R$24:$R$27; 1; FALSCH)
Q28 =SVERWEIS(R28;$N$24:$N$27; 1; FALSCH)
M29 =SVERWEIS(N29;$R$24:$R$27; 1; FALSCH)
Q29 =SVERWEIS(R29;$N$24:$N$27; 1; FALSCH)
M33 =WENN(SVERWEIS(N33;$R33:$R38; 1; FALSCH)=N33; ""; SVERWEIS(N33;$R33:$R38; 1; FALSCH))
Q33 =WENN(SVERWEIS(R33;$N33:$N38; 1; FALSCH)=R33; ""; SVERWEIS(R33;$N33:$N38; 1; FALSCH))
M34 =WENN(SVERWEIS(N34;$R33:$R38; 1; FALSCH)=N34; ""; SVERWEIS(N34;$R33:$R38; 1; FALSCH))
Q34 =WENN(SVERWEIS(R34;$N33:$N38; 1; FALSCH)=R34; ""; SVERWEIS(R34;$N33:$N38; 1; FALSCH))
M35 =WENN(SVERWEIS(N35;$R33:$R38; 1; FALSCH)=N35; ""; SVERWEIS(N35;$R33:$R38; 1; FALSCH))
Q35 =WENN(SVERWEIS(R35;$N33:$N38; 1; FALSCH)=R35; ""; SVERWEIS(R35;$N33:$N38; 1; FALSCH))
M36 =WENN(SVERWEIS(N36;$R33:$R38; 1; FALSCH)=N36; ""; SVERWEIS(N36;$R33:$R38; 1; FALSCH))
Q36 =WENN(SVERWEIS(R36;$N33:$N38; 1; FALSCH)=R36; ""; SVERWEIS(R36;$N33:$N38; 1; FALSCH))
M37 =WENN(SVERWEIS(N37;$R33:$R38; 1; FALSCH)=N37; ""; SVERWEIS(N37;$R33:$R38; 1; FALSCH))
Q37 =WENN(SVERWEIS(R37;$N33:$N38; 1; FALSCH)=R37; ""; SVERWEIS(R37;$N33:$N38; 1; FALSCH))
M38 =WENN(SVERWEIS(N38;$R33:$R38; 1; FALSCH)=N38; ""; SVERWEIS(N38;$R33:$R38; 1; FALSCH))
Q38 =WENN(SVERWEIS(R38;$N33:$N38; 1; FALSCH)=R38; ""; SVERWEIS(R38;$N33:$N38; 1; FALSCH))
M42 =WENN(ISTNV(SVERWEIS(N42;$R$42:$R$47;1;FALSCH));"";SVERWEIS(N42;$R$42:$R$47;1;FALSCH))
Q42 =WENN(ISTNV(SVERWEIS(R42;$N$42:$N$47;1;FALSCH));"";SVERWEIS(R42;$N$42:$N$47;1;FALSCH))
M43 =WENN(ISTNV(SVERWEIS(N43;$R$42:$R$47;1;FALSCH));"";SVERWEIS(N43;$R$42:$R$47;1;FALSCH))
Q43 =WENN(ISTNV(SVERWEIS(R43;$N$42:$N$47;1;FALSCH));"";SVERWEIS(R43;$N$42:$N$47;1;FALSCH))
M44 =WENN(ISTNV(SVERWEIS(N44;$R$42:$R$47;1;FALSCH));"";SVERWEIS(N44;$R$42:$R$47;1;FALSCH))
Q44 =WENN(ISTNV(SVERWEIS(R44;$N$42:$N$47;1;FALSCH));"";SVERWEIS(R44;$N$42:$N$47;1;FALSCH))
M45 =WENN(ISTNV(SVERWEIS(N45;$R$42:$R$47;1;FALSCH));"";SVERWEIS(N45;$R$42:$R$47;1;FALSCH))
Q45 =WENN(ISTNV(SVERWEIS(R45;$N$42:$N$47;1;FALSCH));"";SVERWEIS(R45;$N$42:$N$47;1;FALSCH))
M46 =WENN(ISTNV(SVERWEIS(N46;$R$42:$R$47;1;FALSCH));"";SVERWEIS(N46;$R$42:$R$47;1;FALSCH))
Q46 =WENN(ISTNV(SVERWEIS(R46;$N$42:$N$47;1;FALSCH));"";SVERWEIS(R46;$N$42:$N$47;1;FALSCH))
M47 =WENN(ISTNV(SVERWEIS(N47;$R$42:$R$47;1;FALSCH));"";SVERWEIS(N47;$R$42:$R$47;1;FALSCH))
Q47 =WENN(ISTNV(SVERWEIS(R47;$N$42:$N$47;1;FALSCH));"";SVERWEIS(R47;$N$42:$N$47;1;FALSCH))

Tabellendarstellung in Foren Version 4.28


Gruss
Mike
Anzeige
AW: und auch ...
13.11.2009 13:06:08
Oberschlumpf
uihuihuihhhh....mir schwirren die Sinne! :-)
Danke!
AW: nur mal so
13.11.2009 11:15:51
Björn
Hallo Thorsten,
schon klar, ich hänge auch oft an "einfachen" Problemen. Ich versuche aber diese selbst zu lösen, und wenn ich dann nicht weiter komme, dann schreibe ich auch hier einen Beitrag.
Schreibe dann aber, was ich gemacht habe, und was nicht funktioniert.
Oft werden hier aber einfach Probleme oder Fragen eingestellt, ohne Ansatz und ohne den Gedanken, die sich der Fragesteller gemacht hat. Dann erscheint es für mich so, dass der Fragesteller einfach zu faul ist, selber nachzudenken, und das Forum als kostenlose "Auftragsarbeit" missbraucht.
Das finde ich nicht in Ordnung.
Hier sollen diejenigen Fragen stellen, die an der Lösung interessiert sind, und diese auch verstehen möchten, um es nächstes Mal dann alleine zu können oder vielleicht sogar einem anderen erklären können.
Nun zu diesem Beitrag.
Wenn ich eine Datei sehe, die keine Lösungsansätze enthält und auch nicht beschrieben ist, was genau nicht funktioniert, dann gehe ich davon aus, dass es der-/diejenige nicht versucht hat.
Wenn dann sogar noch im Betreff der richtige Ansatz steht, verstehe ich noch viel weniger, warum man es nicht versucht. Das ist echt keine schrwierige Formel.
Zu deutsch: =SummeWEnn(hier;das steht;dann hier zusammenzählen)
Außerdem ist diese Formel sehr gut in der Hilfe beschrieben.
Wenn es dann immer noch Verständnisproblem gibt, dann helfe ich und wahrscheinlich auch jeder andere gerne.
Ich finde aber ungenaue Problemstellungen einfach nicht so prickelnd, und werde auch weiterhin mit spitzen Bemerkungen darauf reagieren. Der ein oder andere lernt vielleicht auch daraus.
Ich will damit aber niemandem auf den Schlips treten (oder bei nicht Schlipsträgern auf ein anderes Kleidungsstück Deiner Wahl).
So, und wann gehen wir jetzt ein Bier trinken?
Gruß
Björn
Anzeige
... noch etwas ausgedeutschter
13.11.2009 12:06:30
Mike
Hey Björn,
oder so ausgedeutscht: =SummeWEnn(Liste mit verschiedenen Suchbegriffen;Suchbegriff (das steht); Liste mit verschiedenen Werten (zum hier zusammenzählen))
Gruss
Mike
@ Björn
13.11.2009 12:34:46
Jens
Hallo Björn
Zuerst einmal muss ich Dir sagen, dass ich Deine Meinung zum großen Teil teile, aber man sollte nicht alle Forums-User über einen Kamm scheren.
Als Beispiel: Die einen wollen die Hilfe nicht benutzen und dadurch verstehen, die anderen verstehen sie einfach nicht. Auch ich blicke bei manchen Dingen nicht durch, in der Hilfe.
Zum Teil gibt es aber auch einfach Leute, die selbst mit der XL-Hilfe nicht klar kommen. Entweder, weil das Verständnis (für die Materie) fehlt, oder, weil die Hilfe einfach nicht verständlich ist (in den wenigsten Fällen der Fall).
Meine Kenntnisse reichen für vieles aus, aber wenn ich Codes von z.B. Nepumuk oder Formeln von WF und/oder {Boris} sehe, dann fange ich auch an, zu schlottern. Dafür kann ich wahrscheinlich einigen was von prozessabhängiger Parametrierung und Steuerung von Ultraschallschweißanlagen o.ä. erzählen.
Jeder hat wohl sein Spezialgebiet.
Der eine programmiert eine kaffeekochende Waschmaschine ;o), der andere kann es halt im Steuerrecht.
Das ist auch keine Kritik an Dir persönlich, sondern lediglich meine eigene Meinung.
Außerdem steht es ja jedem frei, hier zu antworten/helfen.
Ich sehe es eher locker. Wenn es nicht fruchtet, dann ziehe ich mich aus dem Thread zurück. Aber meistens betrachte ich so etwas als eine Art Herausforderung, den Leuten auf die Sprünge zu helfen, so weit ich kann.
Deshalb: Sieh es nicht so hart.
Gruß aus dem Sauerland
Jens
PS: Aber unbelehrbare Fragensteller gibt es hier trotzdem ;o)
Anzeige
AW: nur mal so
13.11.2009 13:28:40
Oberschlumpf
Hi Björn
Ich finde aber ungenaue Problemstellungen einfach nicht so prickelnd, und werde auch weiterhin mit spitzen Bemerkungen darauf reagieren.

DAS kann ich nur bestätigen!
(könnt ja jetzt mal ne Linkliste meiner spitzen Bemerkungen posten...aber ich glaube, dafür würde der Platz hier im Textfenster nich ausreichen ;-) )
Aber nix desto trotz denk ich, dass ich mich vielleicht hier und da doch mal ein wenig zurücknehmen sollte...hmm....sorry an alle "unter mir Leidenden" :-) für mein hin und wieder zu arrogantes Auftreten.
Die Ursache ist eigtl immer, dass ich, wenn ich mal ne Frage stelle, versuche, mich in die möglichen Leser meiner Frage hineinzuversetzen, um dann eben in meine Frage alle Informationen zu packen, die erforderlich sind, damit die Leser nicht noch ein größeres Fragezeichen als ich im Gesicht haben :-)
Wenn ich dann aber ne Frage lese, die entweder ausser der Frage gar keine Infos hat, oder mögliche Infos nur gerade mal eben so angedeutet werden....oha...in dem Moment sollte der Fragende nich neben mir sitzen :-)
Aber Aber Aber
Ich kann NICHT voraussetzen, dass JEDER ANDERE genau so denkt und handelt wie ich.
Und jeder Anfänger (egal in welcher Tätigkeit) macht immer wieder die selben Fehler, die schon die Anfänger vor den Anfängern vor den Anfängern ...huch..Endlosschleife :-)...schnell ein On Error Goto weiter im Direktfenster eingegeben :-))
weiter:
...gemacht haben. :-)
Also..Thorsten (spreche gerade mit mir selber:-) )...vergiss nicht, dass auch DU irgdwann mal genau die selben Fragen gestellt hast!
Björn, auch ich versichere, dass dieser mein Text NICHT als Kritik in welcher Form auch immer an dich gerichtet war, sondern genau so, wie schon bei meinen Vorrednern, nur meine Meinung wiedergibt.
In diesem Sinne...und bei allen weiteren Anfängern....AUF SIE MIT ATTACKKKÄÄÄÄÄÄ!!!....grins
Ciao
Thorsten
Anzeige
@ Thorsten: Datt Leben is...
13.11.2009 13:33:51
Jens
Moinsen
...viel zu kurz, um sich über solche "Nichtigkeiten" aufzuregen
Gruß aus dem Sauerland
Jens
danke..theoretisch hab ich es ja verstanden :-)owT
13.11.2009 14:02:18
Oberschlumpf
AW: Summewenn?
13.11.2009 10:29:06
Oberschlumpf
Hi Name?
Meinst du so?
Formel in M8: =SUMMEWENN(C4:K4;D4;C8:K8)
Formel in N8: =SUMMEWENN(C4:K4;E4;C8:K8)
die Formeln für die unteren Zeilen entsprechend anpassen.
Hilfts?
Ciao
Thorsten
einfach .. Summe
13.11.2009 10:44:41
Mike
Hey Unbekannter,
die l und u sind ja klar den Spalten zugeordnet, so gehts auch
mit einfachen Berechnungen:
Tabelle1
 LMN
7  Summe uSumme I
81Summe Zeile für uSumme Zeile für I
921'392.25282'206
1031'915.48868'814
1141'857.75154'579
1251'741.43775'927
1362'140.26481'797
1471'932.33655'579

verwendete Formeln
Zelle Formel
M9 =D9+H9
N9 =C9+SUMME(E9:G9)+SUMME(I9:K9)
M10 =D10+H10
N10 =C10+SUMME(E10:G10)+SUMME(I10:K10)
M11 =D11+H11
N11 =C11+SUMME(E11:G11)+SUMME(I11:K11)
M12 =D12+H12
N12 =C12+SUMME(E12:G12)+SUMME(I12:K12)
M13 =D13+H13
N13 =C13+SUMME(E13:G13)+SUMME(I13:K13)
M14 =D14+H14
N14 =C14+SUMME(E14:G14)+SUMME(I14:K14)

Zahlenformate
Zelle Format Wert
L8 #'##01
L9 #'##02
M9 #'##0.0001392.25193558393
N9 #'##082205.7174603175
L10 #'##03
M10 #'##0.0001915.48835157967
N10 #'##068813.9
L11 #'##04
M11 #'##0.0001857.75095889966
N11 #'##054579.0992063492
L12 #'##05
M12 #'##0.0001741.43662178755
N12 #'##075927.025
L13 #'##06
M13 #'##0.0002140.26425462341
N13 #'##081797.3
L14 #'##07
M14 #'##0.0001932.33619362354
N14 #'##055578.5
Zellen mit Format Standard werden nicht dargestellt

Schriftformate
Zelle Rot Grün Blau Color Stil Unterstreichung Effekte Durchgestrichen Schriftart
L10:L14     Fett        
L8:L9     Fett        
M7:N7     Fett        
Zellen mit Schriftformatierung automatisch werden nicht dargestellt

Tabellendarstellung in Foren Version 4.28


Gruss
Mike
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige