Microsoft Excel

Herbers Excel/VBA-Archiv

Häufigkeit in VBA | Herbers Excel-Forum


Betrifft: Häufigkeit in VBA von: MBorn
Geschrieben am: 14.11.2009 12:02:19

Hallo,

gibt es eigentlich eine einfach VBA-Lösung für die
Matrix-Formel, mit der die Häufigkeit verschiedener
Werte in einem Range gezählt werden kann?

{SUMME(WENN(HÄUFIGKEIT($D$2:D26;$D$2:D26)>0;1))}

Herzlichen Dank,

Born

  

Betrifft: Was verstehst du unter `einfach´? Immerhin... von: Luc:-?
Geschrieben am: 14.11.2009 12:14:25

...müsste diese Fktionalität ja nachgebaut wdn, was einen PgmZyklus erforderlich machen würde, Born.
Die Verarbeitungsgeschwindigkeit wäre dann ein anderes, hier wohl irrelevantes Thema...
Gruß + schöWE, Luc :-?


  

Betrifft: AW: Was verstehst du unter `einfach´? Immerhin... von: MBorn
Geschrieben am: 14.11.2009 12:16:29

Ja, natürlich ist einfach relativ. Aber kompliziert wäre
wohl ein Modul mit 5000 Zeilen. Das meine ich damit.

Gruß,

Born


  

Betrifft: Na dann... Ja! Gruß owT von: Luc:-?
Geschrieben am: 14.11.2009 12:21:48

:-?


  

Betrifft: AW: Na dann... gelöst von: MBorn
Geschrieben am: 14.11.2009 12:47:24

Danke,

ist gelöst. Ging einfach über eine CountIf-Funktion.

Born


  

Betrifft: AW: Na dann... zu von: robert
Geschrieben am: 14.11.2009 13:06:52




  

Betrifft: AW: Na dann... gelöst von: fcs
Geschrieben am: 14.11.2009 13:34:23

Hallo Born,

hier eine benutzerdefinierte Funktion, die deine Arrayformel in einer VBA-Prozedur ersetzen kann.

Gruß
Franz

Function fncSpezialHaeufigkeit(Bereich As Range) As Long
  Dim arrFrequency, intI As Long
  '{=SUMME(WENN(HÄUFIGKEIT($D$2:D26;$D$2:D26)>0;1))}
  
  With Application.WorksheetFunction
    arrFrequency = .Frequency(Bereich, Bereich)
    For intI = LBound(arrFrequency) To UBound(arrFrequency)
      If arrFrequency(intI, 1) > 0 Then fncSpezialHaeufigkeit = fncSpezialHaeufigkeit + 1
    Next
  End With
End Function



  

Betrifft: AW: Na dann... gelöst - Danke Franz von: MBorn
Geschrieben am: 14.11.2009 15:24:56

Vielen Dank für diese Arbeit, Franz.
Damit erspare ich mir viel Fummelei mit der countif-Funktion.

Mercie bien,

Born


Beiträge aus den Excel-Beispielen zum Thema "Häufigkeit in VBA"