Microsoft Excel

Herbers Excel/VBA-Archiv

Per Makro auf.- bzw. abrunden | Herbers Excel-Forum


Betrifft: Per Makro auf.- bzw. abrunden von: Joachim
Geschrieben am: 16.11.2009 08:29:14

Hi,

ich habe ein Spalte (L) mit Ergebnissen (ab Zeile 7) , die per Makro rein gepumpt werden. Die Ergebnisse dieser Spalte sollen nun (per Makro) gerunden werden:

0-4,999 = 0%
5,0-14,999 = 10%
15,0-24,999 = 20%

95,0-100 = 100%

Ich weis nicht, ob es möglich ist, diese Ergebnisse zu runden und das neue Ergebnis einfach wieder in die gleiche Zelle schreiben (altes überschreiben)

Falls nicht, würde ich auch mit einer Hilfsspalte arbeiten.

Hat da jemand eine Idee ?

Danke
Joachim

  

Betrifft: AW: Per Makro auf.- bzw. abrunden von: Jens
Geschrieben am: 16.11.2009 10:01:46

Hallo

ich habe ein Spalte (L) mit Ergebnissen (ab Zeile 7) , die per Makro rein gepumpt werden
Wie sieht denn Dein bisheriger Code aus?

Gruß Jens


  

Betrifft: AW: Per Makro auf.- bzw. abrunden von: David
Geschrieben am: 16.11.2009 11:40:47

Hallo Joachim,

per Formel würde die Rundung so gehen:

Wert in A1:
=RUNDEN(A1*10;-2)/10

Möglich ist per VBA (fast) alles. Aber wie schon Jens schrieb, dazu müsste man deinen Code schon sehen, dann könnte man die Rundung wahrscheinlich gleich beim Holen der Werte mit integrieren.

Gruß
David