Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

Überlappung benamter Bereiche? | Herbers Excel-Forum


Betrifft: Überlappung benamter Bereiche? von: Gregor
Geschrieben am: 17.11.2009 15:31:00

Hallo Leute,

habe zwei sich überlappende benamte Bereiche mit Zahlenwerten.

Ich möchte erreichen, dass die Summe vom überlappenden Bereich errechnet wird.

Geht das überhaupt und falls ja, wie?

Grüße Gregor

  

Betrifft: AW: Überlappung benamter Bereiche? von: Rudi Maintaire
Geschrieben am: 17.11.2009 15:47:18

Hallo,
per VBA?

Sub tt()
  MsgBox Application.Sum(Intersect(Range("_r1"), Range("_r2")))
End Sub

Gruß
Rudi


  

Betrifft: Danke und sorry, per Formel. oT von: Gregor
Geschrieben am: 17.11.2009 16:01:31

oT


  

Betrifft: Summe von Schnittmengen - per VBA von: NoNet
Geschrieben am: 17.11.2009 16:05:54

Hallo Gregor,

ohne sich "die Arme zu verbiegen" ist das nur per VBA möglich, da Excel selbst keine entsprechende Funktion enthält.

Kopiere folgenden VBA-Code ein allgemeines Modul (z.B. "Modul1") im VBA-Editor :

Public Function Schnittmenge(rngB1, rngB2) As Range
    Application.Volatile
    Set Schnittmenge = Intersect(rngB1, rngB2)
End Function
Und hier eine Beispieltabelle - Siehe Aufruf der VBA-Funktion in E17 :

ABCDE
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

Funktionen im Tabellenblatt :
Zelle Formel 
E15   =SUMME(Bereich1) 
E16   =SUMME(Bereich2) 
E17   =SUMME(Schnittmenge(Bereich1;Bereich2)

Tabelle eingefügt mit Syntaxhighlighter 4.15

Gruß, NoNet


  

Betrifft: AW: Überlappung benamter Bereiche? von: Original Kurt
Geschrieben am: 17.11.2009 16:16:58

Hi,

=SUMME(Bereich1 Bereich2)

Der Operator für Schnittmengen ist das Leerzeichen.

mfg Kurt


  

Betrifft: Guter Tipp : Kannte ich auch noch nicht ! _oT von: NoNet
Geschrieben am: 17.11.2009 16:25:55

_oT


  

Betrifft: Das ist einer von insges 3 Bezugsoperatoren... von: Luc:-?
Geschrieben am: 18.11.2009 05:23:55

...in xl (Priorität 2, also nach : und noch vor ;), den es wohl schon immer gibt, NoNet,
den MS aber wohl erst mit der neuen Hilfe unter xl12 wieder in die Operatorenübersicht aufgenommen hat. Da ich das auch nicht als Operator kannte, habe ich mal in der xlHilfe nachgeforscht. Unter xl9 wird er nur ganz versteckt im Zusammenhang mit Formelnotation erwähnt → über Beziehungen und Unterschiede zu Lotus 1-2-3 auffindbar. Wurde wohl sonst schlicht vergessen, so wie manches andere auch...
Kurt gebührt das Verdienst, ihn wiederentdeckt zu haben (viell dank xl12)!
Gruß Luc :-?


  

Betrifft: ist in XL10 unter von: Rudi Maintaire
Geschrieben am: 18.11.2009 11:09:00

Informationen zu Operatoren für Berechnung-Arten von Operatoren zu finden.

Bezugsoperatoren Verknüpfen Zellbereiche für die Durchführung von Berechnungen mit folgenden Operatoren.

Bezugsoperator Bedeutung (Beispiel)
: (Doppelpunkt) Bereichsoperator, der einen Bezug auf alle Zellen erstellt, die zwischen zwei Bezügen liegen, einschließlich der beiden Bezugszellen (B5:B15)
; (Semikolon) Verbindungsoperator, der die Verbindung mehrerer Bezüge in einem Bezug ermöglicht (SUMME(B5:B15;D5:D15))
(Leerschritt) Schnittmengenoperator, der einen Bezug zu Zellen erstellt, die für beide Bezüge gleich sind (B7:D7 C6:C8)

Gruß
Rudi


  

Betrifft: Danke Kurt, super! oT von: Gregor
Geschrieben am: 17.11.2009 17:02:42

oT


Beiträge aus den Excel-Beispielen zum Thema "Überlappung benamter Bereiche?"