Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

Zeiten Berechnen | Herbers Excel-Forum


Betrifft: Zeiten Berechnen von: Steffi
Geschrieben am: 18.11.2009 17:32:33

Hallo Zusammen,

schon lange kein Problem gehabt, und wenn es keine Chef gebe hätte ich auch jetzt kein Problem.

So nun zu meinem Anliegen, ich sollte in einer Tabelle verschiedene Zeiten berechnen siehe Exceldatei.

Gibt es eine Formel die das Abdeckt.

- 2 Schichtbetrieb 06:00 - 14:00Uhr 14:00 - 22:00Uhr

- Pause von 12:00 - 12:50 und von 18:00 - 18:50Uhr

- Wochenende keine Arbeit

Und dann kleine Auswertung Kalenderwoche:

- Mittelwert jeder KW
- wie lange Einzelne Postion Zeit

Kann man die wünsche über Formeln berechnen, schonmal Danke für die Hilfe

Gruß Steffi

https://www.herber.de/bbs/user/66026.xlsx

  

Betrifft: AW: Zeiten Berechnen - schade... von: jockel
Geschrieben am: 18.11.2009 17:41:01

hi Steffi, du hast eine XL2007 datei hochgeladen, damit schließt du die user aus, die eine niedriegere version haben...

cu jörg


  

Betrifft: AW: Zeiten Berechnen - schade... von: Steffi
Geschrieben am: 18.11.2009 17:58:54

Ups....


Danke für den Hinweis, habe sie nochmals Angehängt


Steffi

https://www.herber.de/bbs/user/66028.xls


  

Betrifft: AW: Zeiten Berechnen - schade... von: BoskoBiati
Geschrieben am: 18.11.2009 20:34:28

allo Steffi,

hier mal ein Entwurf:

Tabelle1

 ABCDEFGHIJKL
2Datum UhrzeitTypWareDatum UhrzeitDurchlauf Stunden  KW 45KW 46KW 47
306.11.200910:002206.11.200912:0002:00 Mittelwert02:00  
406.11.200911:302206.11.200912:0000:30 Anzahl60 
506.11.200911:402206.11.200914:0001:30     
606.11.200915:002206.11.200915:5000:50     
706.11.200916:002206.11.200921:0004:10     
806.11.200921:002209.11.200908:0003:00     

Formeln der Tabelle
ZelleFormel
G3=WENN(WOCHENTAG(A3;2)>WOCHENTAG(E3;2); -3+(22/24-B3)+(F3-0,25); F3-B3)-((B3<0,5)*(F3>0,5)+(B3<0,75)*(F3>0,75))*MIN(MAX(B3-0,75;F3-0,5); 5/6/24)+DATEDIF(A3;E3;"d")
G4=WENN(WOCHENTAG(A4;2)>WOCHENTAG(E4;2); -3+(22/24-B4)+(F4-0,25); F4-B4)-((B4<0,5)*(F4>0,5)+(B4<0,75)*(F4>0,75))*MIN(MAX(B4-0,75;F4-0,5); 5/6/24)+DATEDIF(A4;E4;"d")


Tabelle1

 J
302:00
46

Formeln der Tabelle
ZelleFormel
J3=MITTELWERT((A3:A8>=("4.1."&JAHR(A3))+TEIL(J2;4;2)*7-7-REST("2.1."&JAHR(A3); 7))*(E3:E8<=("4.1."&JAHR(A3))+TEIL(J2;4;2)*7-7-REST("2.1."&JAHR(A3); 7)+4)*(G3:G8))
J4=ZÄHLENWENN($A$3:$A$8;">="&("4.1."&JAHR($A$3))+TEIL(J$2;4;2)*7-7-REST("2.1."&JAHR($A$3); 7))-ZÄHLENWENN($A$3:$A$8;">"&(("4.1."&JAHR($A$3))+TEIL(J$2;4;2)*7-7-REST("2.1."&JAHR($A$3); 7)+4))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß

Bosko


  

Betrifft: AW: Zeiten Berechnen - schade... von: Steffi
Geschrieben am: 18.11.2009 22:25:19

Hallo Bosko,

Danke für die raschen Entwurf, kann man noch die Pausenezeiten einpflegen.

Da 2Schichtbetrieb 1x 12:00-12:50 und 1x 18:00-18:50Uhr, das heißt wenn ein Ganzen Tag benötigt wird sind auch 2x Pausen abzurechnen. Oder wenn nur eine Schicht benötigt wird auch nur eine Pause.


Gruß Steffi

Ps. siehe auch mein dritten Beitrag.


  

Betrifft: AW: Zeiten Berechnen - schade... von: Steffi
Geschrieben am: 18.11.2009 23:03:29

Hallo Zusammen,

in der Excel-Datei ist der Knoten drin, KW 45 geht mit Mittelwert ab KW 46 nicht mehr???

https://www.herber.de/bbs/user/66040.xlsx


Gruß Steffi


  

Betrifft: AW: Zeiten Berechnen - schade... von: BoskoBiati
Geschrieben am: 18.11.2009 23:16:44

Hallo Steffi,

es gab schon mal den Hinweis, dass nicht jeder xlsx Dateien öffnen kann. Ich kanns auch nicht!

Gruß

Bosko


  

Betrifft: AW: Zeiten Berechnen - schade... von: Steffi
Geschrieben am: 19.11.2009 04:24:25

Hallo und Guten Morgen,

hier nochmal die Datei für alle


https://www.herber.de/bbs/user/66041.xls

Gruß Steffi


  

Betrifft: AW: Zeiten Berechnen - schade... von: BoskoBiati
Geschrieben am: 19.11.2009 05:52:27

Hallo Steffi,

Du solltest die Formeln schon auf Deine Tabelle anpassen. Momentan ist sie auf die paar Zeilen ausgelegt, die in der Mustertabelle enthalten sind.

Gruß

Bosko


  

Betrifft: AW: Zeiten Berechnen - schade... von: Steffi
Geschrieben am: 19.11.2009 17:13:38

Hallo Bosko,

Danke für den HInweis, aber die Formeln berücksichtigen nicht die Pausenzeiten.

Kann man dieses noch Einpflegen.


Gruß Steffi


Beiträge aus den Excel-Beispielen zum Thema "Zeiten Berechnen"