Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Funktion | Herbers Excel-Forum


Betrifft: Wenn Funktion von: westcasio
Geschrieben am: 19.11.2009 13:58:34

Hallo Leute,

ich wollte fragen, ob es möglich ist, eine wenn Funktion aufzubauen die einen Wert in einem Bereich sucht?

=wenn(A1=B1;"ja";"nein")

Das klappt sehr gut, wenn die Werte auch so in der Tabelle stehen, wenn es aber so ist, geht es nicht mehr:

A B
1
2 1
2
Also muss die Formel einen Bereich absuchen und sagen, ob der Wert in A1 auch in der Spalte B vorkommet!

Kann mir jemand helfen? Vielen Dank im Voraus.

Gruß west

  

Betrifft: AW: Wenn Funktion von: Björn B.
Geschrieben am: 19.11.2009 14:04:26

Hallo,

meinst Du SVERWEIS? (Lies dazu mal die Hilfe)
Oder ich verstehe Deine Frage nicht ganz.
Versuch mal besser zu beschreiben (mit Beispiel), was wo gefunden werden soll.

Gruß
Björn


  

Betrifft: AW: Wenn Funktion von: westcasio
Geschrieben am: 19.11.2009 14:11:20

Hallo Björn,

also in der Spalte A und B stehen die folgenden Werte

A1 x B1 y
A2 y B2 t
A3 z B3 z

Nun möchte ich in Spalte C eine Prüfung haben die prüft, ob der Wert A1 in der Spalte B vorkommt, wenn ja dann soll er "ja" schreiben, wenn nein dann soll er "nein" schreiben.

Ich hoffe, dass war jetzt besser erklärt. Schon einmal vielen Dank für die Mühe. ;o))

Gruß west


  

Betrifft: AW: Wenn Funktion von: Björn B.
Geschrieben am: 19.11.2009 14:22:11

Hallo,
Wenn(Dudasmeinst;dannSVERWEIS);-)

Auf deutsch: ja, das macht man mit Sverweis.
in C1 muss folgendes stehen:

=WENN(ISTNV(SVERWEIS(A1;$B$1:$B$100;1;0));"nein";"ja")

Den Suchbereich "$B$1:$B$100" musst Du natürlich auf Deinen Bereich anpassen.

War es das?

Gruß
Björn B.


  

Betrifft: =WENN(ZÄHLENWENN(A:A;B1)>0;"ja";"nein") von: WF
Geschrieben am: 19.11.2009 14:23:41

das in C1 und runterkopieren.

Salut WF


  

Betrifft: ok, gewonnen von: Björn B.
Geschrieben am: 19.11.2009 14:27:02

Hallo WF,

das ist dann doch die elegantere und vor allem einfachere Lösung.
Respekt.

Gruß
Björn


  

Betrifft: =WENN(ZÄHLENWENN(B:B;A1)>0;"ja";"nein") von: Björn B.
Geschrieben am: 19.11.2009 14:31:05

Allerdings suchst du verkehrt, Du schaust, ob B1 in A vorkommt.
so wäre es richtig:
=WENN(ZÄHLENWENN(B:B;A1)>0;"ja";"nein")

Was nichts daran ändert, dass Deine Formel besser als meine ist.

Gruß
Björn B.


  

Betrifft: AW: =WENN(ZÄHLENWENN(B:B;A1)>0;"ja";"nein") von: westcasio
Geschrieben am: 19.11.2009 14:34:36

Hallo Björn, hallo WF,

es klappt einwandfrei, super Lösung. Vielen Dank für Eure Unterstützung. ;o)) Das ersprt mir jetzt ein Haufen Arbeit.


Beiträge aus den Excel-Beispielen zum Thema "Wenn Funktion"