Microsoft Excel

Herbers Excel/VBA-Archiv

Rangfolge ändern | Herbers Excel-Forum


Betrifft: Rangfolge ändern von: Philipp
Geschrieben am: 27.11.2009 10:13:04

Hallo zusammen,

ich stehe vor folgendem Problem:

Beispiel:

Ausgangswerte sind: 1,1,2,1
Das Ergebnis der Rangfolge ist demnach: 2,2,1,2

Ich brauche jedoch für für mein excel sheet das Ergebnis: 4,4,1,4

Sprich bei gleichen Werten sollen nicht alle den höchstmöglichen (im Beispiel 2) Rang, sondern
den niedrigsten möglichen (also 4) annehmen. Danach sollen die Ränge normal weiterzählen, also:

Bei Werten: 1 , 1.5 , 1.5 , 2 , 3
ist mein Wunschergebnis: 5 , 4 , 4 , 2 , 1

Hört sich eigentlich ganz einfach einfach an, aber ich habe jetzt schon viel probiert und es nicht hinbekommen. Eine VBA-Lösung könnte ich wohl schreiben,
hilft mir aber leider nicht weiter, da ich zur Umsetzung eine Lösung im excel sheet brauche.

Ich bin gespannt wie man dies löst und danke euch im voraus für eure Hilfe.

VG Phil

  

Betrifft: AW: Rangfolge ändern von: Mike
Geschrieben am: 27.11.2009 10:32:48


Hey Phil,

wieso soll aus den Rängen 1 sowie 3x 2 eine 1 und 3x4 werden?

Weil die Logik ja eher umgekehrt ist: gibt es zwei 2. Ränge, gibts
keinen Dritten.

Gruss
Mike


  

Betrifft: AW: Rangfolge ändern von: Philipp
Geschrieben am: 27.11.2009 10:41:30

Hallo Mike,

das geschilderte Problem ist Bestandteil einer größeren Berechnung.
Durch die Rangfolge werden automatisch unterschiedliche Gewichtungen zugewiesen,
es handelt sich hierbei um die Einschätzung verschiedener Märkte. Aufgrund des restlichen Modells wäre die Bewertung der Märkte (wenn alle Platz 2 belegen würden) überschätzt, sprich zu positiv.

Ich stimme dir zu, dass dies eigentlich nicht logisch erscheint ;), aber innerhalb unserer Berechnungen ist es leider notwendig, diese "unlogische" Verteilung der Rangfolge zu erreichen.

Ich hoffe das geht überhaupt.

Danke, Gruß Phil


  

Betrifft: AW: Rangfolge ändern von: Philipp
Geschrieben am: 27.11.2009 10:48:21

Ach eines ist mir noch eingefallen, vielleicht ist dies relevant...
es handelt sich bei der realen Umsetzung ebenfalls nur um 5 Werte...also keine große Menge! ;)

Gruß


  

Betrifft: mitgezählt .. Rangfolge ändern von: Mike
Geschrieben am: 27.11.2009 10:49:10


Hey Phil,

so kannst Du es bewerkstelligen:

Tabelle1

 BC
4RangWert
513
622
741.5
841.5
951

verwendete Formeln
Zelle Formel
B5 =WENN(ZÄHLENWENN( $C$5:C9; C5)>1; RANG(C5;$C$5:$C$9; 0)+1;RANG(C5;$C$5:$C$9; 0))
B6 =WENN(ZÄHLENWENN( $C$5:C10; C6)>1; RANG(C6;$C$5:$C$9; 0)+1;RANG(C6;$C$5:$C$9; 0))
B7 =WENN(ZÄHLENWENN( $C$5:C11; C7)>1; RANG(C7;$C$5:$C$9; 0)+1;RANG(C7;$C$5:$C$9; 0))
B8 =WENN(ZÄHLENWENN( $C$5:C12; C8)>1; RANG(C8;$C$5:$C$9; 0)+1;RANG(C8;$C$5:$C$9; 0))
B9 =WENN(ZÄHLENWENN( $C$5:C13; C9)>1; RANG(C9;$C$5:$C$9; 0)+1;RANG(C9;$C$5:$C$9; 0))

Tabellendarstellung in Foren Version 4.28



Gruss
Mike


  

Betrifft: AW: mitgezählt .. Rangfolge ändern von: Philipp
Geschrieben am: 27.11.2009 11:11:07

Hallo Mike,

vielen Dank, das ist es....schon fast ;).

Ich habe noch ein Problem wenn es 3 oder mehr gleiche Werte sind.
Beispiel:

Werte: 1,1,1,2,1
Ergebnis mit deiner Formel: 3,3,3,1,3

Gewünschtes Ergebnis: 5,5,5,1,5

Sprich je mehr gleiche Werte es sind umso weiter muss es sich verschieben. Leider weiß ich auch nicht wie ich das mache...

Gruß Phil


  

Betrifft: AW: mitgezählt .. Rangfolge ändern von: Philipp
Geschrieben am: 27.11.2009 11:32:41

Hallo nochmal,

den Rest habe ich jetzt doch geschafft! ;)

Danke Mike.


  

Betrifft: aus der Tausch .. Rangfolge ändern von: Mike
Geschrieben am: 27.11.2009 12:36:56


Hey Philipp,

schön, dass es klappte und im Zuge des Wissensaustausches
könnte man ja nun auch die Lösung noch präsentieren.

Gut, da es maximal bis auf fünf Werte geht, ists nicht so schwierig .. ;-)

Gruss
Mike


  

Betrifft: AW: aus der Tausch .. Rangfolge ändern von: Philipp
Geschrieben am: 27.11.2009 12:49:06

So,

hier also die Formel die ich nun verwende, vermutlich nicht die schönste ;)

=WENN(ZÄHLENWENN( $C$8:$C$12; C9)>1; RANG(C9;$C$8:$C$12; 0)+ZÄHLENWENN( $C$8:$C$12; C9)-1;RANG(C9; $C$8:$C$12; 0))

Ich habe in deiner Formel also nur die "+1" ausgetauscht gegen "ZÄHLENWENN( $C$8:$C$12; C9)-1", wodurch sich der Rang abhängig von der Anzahl der gleichen Werte verschiebt, und damit klappt es.

Schöne Grüße und bestimmt bis bald mal wieder!


  

Betrifft: perfekt .. Rangfolge ändern von: Mike
Geschrieben am: 27.11.2009 12:56:49


... gut gelöst, bravo! Danke fürs Feedback,

Gruss
Mike


  

Betrifft: AW: mitgezählt .. Rangfolge ändern von: ingoG
Geschrieben am: 27.11.2009 11:44:14

Hallo Phil,

folgende formel sollte funzen:

=ZÄHLENWENN(A:A;">="&A1)


Gruß Ingo

PS eine Rückmeldung wäre nett...


Beiträge aus den Excel-Beispielen zum Thema "Rangfolge ändern"