Microsoft Excel

Herbers Excel/VBA-Archiv

Teilergebnis + Summenprodukt | Herbers Excel-Forum


Betrifft: Teilergebnis + Summenprodukt von: Stef@n
Geschrieben am: 03.12.2009 17:01:29

Hallo Zusammen

ich versuche, die Funktionen Teilergebnis und Summemprodukt "zusammen zu fassen"

Es soll das Summenprodukt bei der Autofilterung einer Tabelle errechent werden.
=Teilergebnis(9;summenprodukt((...)) funktioniert leider nicht

Hier die relevante Formel
=SUMMENPRODUKT((I2:I2544=$D$2:$D$2544)*1)

Hat jemand einen Tip ?
Freu mich auf eine Antwort
Gruss
Stef@n

  

Betrifft: AW: Teilergebnis + Summenprodukt von: Beate Schmitz
Geschrieben am: 03.12.2009 17:05:09

Hallo Stefan,

guckst du: http://www.excelformeln.de/formeln.html?welcher=386

Gruß,
Beate


  

Betrifft: AW: Teilergebnis + Summenprodukt von: Stef@n
Geschrieben am: 03.12.2009 17:14:31

Hallo Beate,
danke für den Link:)

Wenn ich das umsetzte, erscheint eine Fehlermeldung #Bezug
hier die Formel
=SUMMENPRODUKT(TEILERGEBNIS(9;INDIREKT((I2:I2544=$D$2:$D$2544)*1)))


Noch nen Tip ?
Gruss Stef@n


  

Betrifft: AW: Teilergebnis + Summenprodukt von: werni
Geschrieben am: 03.12.2009 17:14:54

Hi Stefan

Hilfsspalte:
=WENN(TEILERGEBNIS(9;A2:B2)>0;1;0)

Dann die Summenproduktformel

https://www.herber.de/bbs/user/66349.htm

Gruss Werner


Beiträge aus den Excel-Beispielen zum Thema "Teilergebnis + Summenprodukt"